xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 5 days ago

#2423 closed defect (fixed)

xpra start: switching between 2 windows causes maximization to change

Reported by: stdedos Owned by: Antoine Martin
Priority: critical Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc: jiang.qian@…

Description

server:

$ xpra version
xpra for python 2.7 is not installed
 retrying with python3
3.0-r23724
$ lsb_release -rd
Description:	Ubuntu 16.04.6 LTS
Release:	16.04

client:

Windows 10
Xpra GTK3 client version 3.0-r23770 64-bit

I have started a gnome-terminal, and from that I have started this https://community.microfocus.com/t5/Identity-Manager-Tips/Jarek-Gawor-s-excellent-LDAP-Browser-Editor-v2-8-2/ta-p/1771772.

I have maximized gnome-terminal. If I switch to the Gawor app (which is not maximized), gnome-terminal "cancels" the maximized state.

I have also replicated this with a VS Code (run locally from windows, not through xpra). VS Code is maximized.

Attachments (1)

Xpra_cmd_2019-10-09_12-16-42.png (22.7 KB) - added by stdedos 11 days ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

Can you reproduce this problem with any regular open-source applications or just those two?
Can you attach the -d state,metadata client output of just when this happens?

comment:2 Changed 4 weeks ago by stdedos

  • Define regular open-source applications.
  • Would you accept the issue with only gnome-terminal exhibiting this behavior?

I will try the diagnostis of these (or the proposed) apps tomorrow.

comment:3 Changed 4 weeks ago by Antoine Martin

Define regular open-source applications.

Something I can just dnf install or apt-get install

Would you accept the issue with only gnome-terminal exhibiting this behavior?

Not sure I understand. I thought you needed Gawor or vscode to reproduce?

comment:4 in reply to:  3 Changed 4 weeks ago by stdedos

Replying to Antoine Martin:

Define regular open-source applications.

Something I can just dnf install or apt-get install

So, I assume that gnome-terminal qualifies. Perfect! I'll try the solo test before moving to one that contains multiple windows. (1)

Would you accept the issue with only gnome-terminal exhibiting this behavior?

Not sure I understand. I thought you needed Gawor or vscode to reproduce?

VS Code was used in place to a random app that I would switch to (it *does* require at least one app, as I need to switch to it. At least, that's how I saw the initial problem). If gawor is required, or is affecting somehow, I don't know. I will have to look at that in more detail (i.e. (1)).

I won't close the current season, I'll just start a new one. I hope reproduction would be easy as that.

Last edited 3 weeks ago by Antoine Martin (previous) (diff)

comment:5 Changed 3 weeks ago by stdedos

Owner: changed from stdedos to Antoine Martin

It's much easier to reproduce: Just maximize the xpra-provided window, and switch to *anything*:

Xpra-Python3-x86_64_3.0-r23770\xpra_cmd" start ssh://user@ip/2 -d state,metadata --start-new-commands=yes --microphone=off --speaker=off --webcam=no --pulseaudio=no --start=gnome-terminal

2019-09-25 12:42:35,683 Xpra GTK3 client version 3.0-r23770 64-bit
2019-09-25 12:42:35,685  running on Microsoft Windows 10
2019-09-25 12:42:36,525 GStreamer version 1.16.0 for Python 3.7.4 64-bit
2019-09-25 12:42:36,809 OpenGL_accelerate module loaded
2019-09-25 12:42:36,838 Using accelerated ArrayDatatype
2019-09-25 12:42:37,420 Warning: vendor 'Intel' is greylisted,
2019-09-25 12:42:37,421  you may want to turn off OpenGL if you encounter bugs
2019-09-25 12:42:37,614 popup_types([])=()
2019-09-25 12:42:37,743 update_metadata({b'has-alpha': False, b'size-constraints': {}})
2019-09-25 12:42:37,744 set_metadata({b'has-alpha': False, b'size-constraints': {}})
2019-09-25 12:42:37,744 apply_geometry_hints({}) geometry=<Gdk.Geometry object at 0x0000000004a72770 (void at 0x000000000922be80)>, hints=<flags 0 of type Gdk.WindowHints>
2019-09-25 12:42:37,816 OpenGL enabled with Intel(R) HD Graphics 4000
2019-09-25 12:42:37,950  keyboard settings: layout=us
2019-09-25 12:42:37,958  desktop size is 1600x900 with 1 screen:
2019-09-25 12:42:37,959   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2019-09-25 12:42:37,962     (Standard monitor types) Generic PnP Monitor (309x174 mm - DPI: 131x131)
2019-09-25 12:42:45,951 enabled remote logging
2019-09-25 12:42:45,954 Xpra GTK3 X11 server version 3.0-r23788 64-bit
2019-09-25 12:42:45,955  running on Linux Ubuntu 16.04 xenial

(Xpra_cmd.exe:9852): Pango-WARNING **: 12:42:46.176: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
2019-09-25 12:42:46,193 process_new_common: [1, 0, 0, 732, 431, {b'size-constraints': {b'increment': (9, 17), b'gravity': 1, b'base-size': (12, 23), b'minimum-size': (260, 52)}, b'pid': 5698, b'group-leader-xid': 8388609, b'xid': b'0x80000a', b'title': b'Terminal', b'client-machine': b'win-client', b'role': b'gnome-terminal-window-80cefdb8-9f18-49c1-8af0-2774cd046bd8', b'class-instance': (b'gnome-terminal-server', b'Gnome-terminal'), b'iconic': False, b'has-alpha': True, b'window-type': (b'NORMAL',), b'icon-title': b'Terminal'}], metadata={b'size-constraints': {b'increment': (9, 17), b'gravity': 1, b'base-size': (12, 23), b'minimum-size': (260, 52)}, b'pid': 5698, b'group-leader-xid': 8388609, b'xid': b'0x80000a', b'title': b'Terminal', b'client-machine': b'win-client', b'role': b'gnome-terminal-window-80cefdb8-9f18-49c1-8af0-2774cd046bd8', b'class-instance': (b'gnome-terminal-server', b'Gnome-terminal'), b'iconic': False, b'has-alpha': True, b'window-type': (b'NORMAL',), b'icon-title': b'Terminal'}, OR=False
2019-09-25 12:42:46,197 popup_types(['NORMAL'])=()
2019-09-25 12:42:46,200 update_metadata({b'size-constraints': {b'increment': (9, 17), b'gravity': 1, b'base-size': (12, 23), b'minimum-size': (260, 52)}, b'pid': 5698, b'group-leader-xid': 8388609, b'xid': b'0x80000a', b'title': b'Terminal', b'client-machine': b'win-client', b'role': b'gnome-terminal-window-80cefdb8-9f18-49c1-8af0-2774cd046bd8', b'class-instance': (b'gnome-terminal-server', b'Gnome-terminal'), b'iconic': False, b'has-alpha': True, b'window-type': (b'NORMAL',), b'icon-title': b'Terminal'})
2019-09-25 12:42:46,202 set_metadata({b'size-constraints': {b'increment': (9, 17), b'gravity': 1, b'base-size': (12, 23), b'minimum-size': (260, 52)}, b'pid': 5698, b'group-leader-xid': 8388609, b'xid': b'0x80000a', b'title': b'Terminal', b'client-machine': b'win-client', b'role': b'gnome-terminal-window-80cefdb8-9f18-49c1-8af0-2774cd046bd8', b'class-instance': (b'gnome-terminal-server', b'Gnome-terminal'), b'iconic': False, b'has-alpha': True, b'window-type': (b'NORMAL',), b'icon-title': b'Terminal'})
2019-09-25 12:42:46,203 apply_geometry_hints({b'min_width': 260, b'min_height': 52, b'base_width': 12, b'base_height': 23, b'width_inc': 9, b'height_inc': 17}) geometry=<Gdk.Geometry object at 0x0000000008f458f0 (void at 0x00000000097e2dc0)>, hints=<flags GDK_HINT_MIN_SIZE | GDK_HINT_BASE_SIZE | GDK_HINT_RESIZE_INC of type Gdk.WindowHints>
2019-09-25 12:42:46,247 ClientWindow(1).window_state_updated(ClientWindow(1), <Gdk.EventWindowState object at 0x0000000008f458f0 (void at 0x0000000009549be0)>) changed_mask=<flags GDK_WINDOW_STATE_WITHDRAWN | GDK_WINDOW_STATE_FOCUSED of type Gdk.WindowState>, new_window_state=<flags GDK_WINDOW_STATE_FOCUSED of type Gdk.WindowState>
2019-09-25 12:42:46,251 _focused=True (was False)
2019-09-25 12:42:46,253 window_state_updated(..) state updates: {'focused': True}, actual updates: {'focused': True}, server updates: {'focused': True}
2019-09-25 12:42:46,281 metadata update for window 1: {b'iconic': False}
2019-09-25 12:42:46,284 update_metadata({b'iconic': False})
2019-09-25 12:42:46,285 set_metadata({b'iconic': False})
2019-09-25 12:42:49,302 ClientWindow(1).window_state_updated(ClientWindow(1), <Gdk.EventWindowState object at 0x0000000011b70b30 (void at 0x00000000097dda10)>) changed_mask=<flags GDK_WINDOW_STATE_MAXIMIZED of type Gdk.WindowState>, new_window_state=<flags GDK_WINDOW_STATE_MAXIMIZED | GDK_WINDOW_STATE_FOCUSED of type Gdk.WindowState>
2019-09-25 12:42:49,304 _maximized=True (was False)
2019-09-25 12:42:49,306 window_state_updated(..) state updates: {'maximized': True}, actual updates: {'maximized': True}, server updates: {'maximized': True}
2019-09-25 12:42:49,327 metadata update for window 1: {b'maximized': True}
2019-09-25 12:42:49,329 update_metadata({b'maximized': True})
2019-09-25 12:42:49,331 set_metadata({b'maximized': True})
2019-09-25 12:42:50,226 ClientWindow(1).window_state_updated(ClientWindow(1), <Gdk.EventWindowState object at 0x0000000011b70ef0 (void at 0x00000000097ddab0)>) changed_mask=<flags GDK_WINDOW_STATE_FOCUSED of type Gdk.WindowState>, new_window_state=<flags GDK_WINDOW_STATE_MAXIMIZED of type Gdk.WindowState>
2019-09-25 12:42:50,230 _focused=False (was True)
2019-09-25 12:42:50,236 window_state_updated(..) state updates: {'focused': False}, actual updates: {'focused': False}, server updates: {'focused': False}
2019-09-25 12:42:50,307 metadata update for window 1: {b'maximized': False}
2019-09-25 12:42:50,313 update_metadata({b'maximized': False})
2019-09-25 12:42:50,318 set_metadata({b'maximized': False})
2019-09-25 12:42:50,330 ClientWindow(1).window_state_updated(ClientWindow(1), <Gdk.EventWindowState object at 0x0000000011b70fb0 (void at 0x00000000097ddd30)>) changed_mask=<flags GDK_WINDOW_STATE_MAXIMIZED | GDK_WINDOW_STATE_FOCUSED of type Gdk.WindowState>, new_window_state=<flags GDK_WINDOW_STATE_FOCUSED of type Gdk.WindowState>
2019-09-25 12:42:50,334 _focused=True (was False)
2019-09-25 12:42:50,336 window_state_updated(..) state updates: {'maximized': False, 'focused': True}, actual updates: {'focused': True}, server updates: {'focused': True}

comment:6 Changed 3 weeks ago by Antoine Martin

Cc: jiang.qian@… added
Owner: changed from Antoine Martin to Antoine Martin
Priority: majorcritical
Status: newassigned

Changed 11 days ago by stdedos

comment:7 Changed 11 days ago by stdedos

I don't know if it's related, but drawing before/after maximization comes "weird".

comment:8 Changed 5 days ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

This was caused by r23562 for #2390.

Fixed in r24140.

Note: See TracTickets for help on using tickets.