xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 2 months ago

Last modified 7 weeks ago

#2425 closed defect (invalid)

Multiple OpenGL issues on a new screen

Reported by: stdedos Owned by: stdedos
Priority: minor Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc:

Description

I am not aware of their severity. A quick search reveals that they haven't been reported.

I tried to truncate the 1+ occurences to minimize the text spam

Xpra-Python3-x86_64_3.0-r23770\xpra_cmd" start ssh://user@ip/2  --start-new-commands=yes --microphone=off --speaker=off --webcam=no --pulseaudio=no --start=gnome-terminal

2019-09-25 12:38:41,651 Xpra GTK3 client version 3.0-r23770 64-bit
2019-09-25 12:38:41,654  running on Microsoft Windows 10
2019-09-25 12:38:42,511 GStreamer version 1.16.0 for Python 3.7.4 64-bit
2019-09-25 12:38:42,846 OpenGL_accelerate module loaded
2019-09-25 12:38:42,881 Using accelerated ArrayDatatype
2019-09-25 12:38:43,475 Warning: vendor 'Intel' is greylisted,
2019-09-25 12:38:43,476  you may want to turn off OpenGL if you encounter bugs
2019-09-25 12:38:44,005 OpenGL enabled with Intel(R) HD Graphics 4000
2019-09-25 12:38:44,141  keyboard settings: layout=us
2019-09-25 12:38:44,144  desktop size is 1600x900 with 1 screen:
2019-09-25 12:38:44,144   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2019-09-25 12:38:44,144     (Standard monitor types) Generic PnP Monitor (309x174 mm - DPI: 131x131)
2019-09-25 12:38:57,390 enabled remote logging
2019-09-25 12:38:57,391 Xpra GTK3 X11 server version 3.0-r23788 64-bit
2019-09-25 12:38:57,392  running on Linux Ubuntu 16.04 xenial

(Xpra_cmd.exe:964): Pango-WARNING **: 12:38:57.648: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/mixins/window_manager.py", line 1047, in _process_window_move_resize
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_window_base.py", line 1925, in move_resize
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_window_base.py", line 1862, in resize
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_window_base.py", line 1842, in _set_backing_size
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 336, in init
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 363, in resize_fbo
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 532, in init_fbo
  File "src/errorchecker.pyx", line 53, in OpenGL_accelerate.errorchecker._ErrorChecker.glCheckError
OpenGL.error.GLError: GLError(
        err = 1286,
        baseOperation = glClear,
        cArguments = (GL_COLOR_BUFFER_BIT,)
)
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gl/gtk3/gl_client_window.py", line 23, in do_configure_event
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_window_base.py", line 1779, in do_configure_event
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_window_base.py", line 1799, in process_configure_event
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_window_base.py", line 1842, in _set_backing_size
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 336, in init
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 355, in resize_fbo
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 497, in gl_init
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 532, in init_fbo
  File "src/errorchecker.pyx", line 53, in OpenGL_accelerate.errorchecker._ErrorChecker.glCheckError
OpenGL.error.GLError: GLError(
        err = 1286,
        baseOperation = glClear,
        cArguments = (GL_COLOR_BUFFER_BIT,)
)
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
  File "E:\Xpra\trunk\src/xpra/client/gl/gtk_base/gl_drawing_area.py", line 79, in cairo_draw
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 497, in gl_init
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 532, in init_fbo
  File "src/errorchecker.pyx", line 53, in OpenGL_accelerate.errorchecker._ErrorChecker.glCheckError
OpenGL.error.GLError: GLError(
        err = 1286,
        baseOperation = glClear,
        cArguments = (GL_COLOR_BUFFER_BIT,)
)
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/mixins/window_manager.py", line 479, in _process_cursor
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_base.py", line 775, in set_windows_cursor
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_window_base.py", line 633, in set_cursor_data
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_window_base.py", line 731, in when_realized
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 909, in set_cursor_data
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 497, in gl_init
  File "E:\Xpra\trunk\src/xpra/client/gl/gl_window_backing_base.py", line 532, in init_fbo
  File "src/errorchecker.pyx", line 53, in OpenGL_accelerate.errorchecker._ErrorChecker.glCheckError
OpenGL.error.GLError: GLError(
        err = 1286,
        baseOperation = glClear,
        cArguments = (GL_COLOR_BUFFER_BIT,)
)
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/mixins/window_manager.py", line 479, in _process_cursor
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/mixins/window_manager.py", line 479, in _process_cursor
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk3/gtk3_client_window.py", line 160, in drawing_area_draw
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/mixins/window_manager.py", line 479, in _process_cursor
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/mixins/window_manager.py", line 479, in _process_cursor

server:

$ xpra version
xpra for python 2.7 is not installed
 retrying with python3
3.0-r23724
$ lsb_release -rd
Description:  Ubuntu 16.04.6 LTS
Release:  16.04

client:

Windows 10
Xpra GTK3 client version 3.0-r23770 64-bit

Change History (6)

comment:1 Changed 3 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

Please try r23971 or later.
There is a beta 4.0 build for mswindows: https://xpra.org/beta/windows

As per the command line output:

Warning: vendor 'Intel' is greylisted,
 you may want to turn off OpenGL if you encounter bugs

This looks like an Intel driver bug.

If the bug still occurs, please attach the output of OpenGL_check.exe -v.

The error from _process_cursor may or may not have been the same, so it may still be present.

comment:2 Changed 2 months ago by stdedos

Owner: changed from stdedos to Antoine Martin

I cannot run it:

Xpra-Python3-x86_64_4.0-r23971\xpra_cmd" start ssh://user@ip/2 -d state,metadata --opengl=no --start-new-commands=yes --microphone=off --speaker=off --webcam=no --pulseaudio=no --start=gnome-terminal

Traceback (most recent call last):
  File "C:/msys64/mingw64/lib/python3.7/site-packages\cx_Freeze/initscripts/__startup__.py", line 14, in run
  File "C:/msys64/mingw64/lib/python3.7/site-packages\cx_Freeze/initscripts/Console.py", line 26, in run
  File "scripts/xpra", line 5, in <module>
  File "E:\Xpra\trunk\src/xpra/platform/__init__.py", line 9, in <module>
  File "C:/msys64/mingw64/lib/python3.7/site-packages/gi/__init__.py", line 42, in <module>
ImportError: DLL load failed: The specified module could not be found.

comment:3 Changed 2 months ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

This bug is actually a duplicate of an old bug: #1358.
Now that we have a subprocess to probe the opengl driver (#1994, #2204), we enable opengl rendering on more chipsets, including Intel.
The problem here is that this error is fairly minor and didn't cause a crash, so we ignored it.
We should catch all errors, including minor ones, so we can deal with them and only enable opengl on a clean setup.

I found some other references to it, so we may also be able to fix the underlying cause too:

comment:4 Changed 2 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos
Status: assignednew

ImportError: DLL load failed: The specified module could not be found.
Was caused by r23803 and is fixed in r24004. Thank you for your patience!

comment:5 Changed 2 months ago by stdedos

Resolution: invalid
Status: newclosed

Works on r24004 +

comment:6 Changed 7 weeks ago by Antoine Martin

See also #2459, r24234 improves on this fix.

Note: See TracTickets for help on using tickets.