xpra icon
Bug tracker and wiki

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#243 closed defect (fixed)

0.8.0: "xpra upgrade" kills applications

Reported by: onlyjob Owned by: Antoine Martin
Priority: blocker Milestone: 0.8
Component: core Version: trunk
Keywords: Cc:

Description

Starting with 0.8.0 xpra upgrade command terminate most applications in session. For example gwenview and iceweasel are terminated on xpra upgrade but kate for whatever reason is not.

r2628 makes xpra crash on upgrade.

Change History (5)

comment:1 Changed 8 years ago by Antoine Martin

Owner: set to Antoine Martin
Status: newaccepted

Confirmed - I very much doubt that it is r2628 that causes this crash though!

Please try r2632 to see if that fixes the crash (but not the application terminating - that's still pending)

comment:2 Changed 8 years ago by Antoine Martin

I've bisected it down to r2281 - which unfortunately is a fairly large changeset..

comment:3 Changed 8 years ago by Antoine Martin

Resolution: fixed
Status: acceptedclosed

fixed in r2642

comment:4 Changed 8 years ago by onlyjob

Fixed in 0.8.1, but 0.8.1 unnecessarily reverted "system-tray = yes" in /etc/xpra/xpra.conf

# (disabled by default: crashes some applications on "xpra upgrade")
system-tray = no


It was only our unconfirmed wild guess that system tray is somehow related to apps termination on xpra upgrade.

I can't reproduce the problem in 0.8.1 any more and I'm trying with "system-tray = yes" all the time so IMHO system tray is unrelated and therefore there is no reason to disable it by default.

comment:5 Changed 8 years ago by Antoine Martin

re-enabled system-tray in r2647

Note: See TracTickets for help on using tickets.