xpra icon
Bug tracker and wiki

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#2434 closed defect (duplicate)

dual screen setup, maximized state of window lost when shifted to another window

Reported by: Jiang Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: android Version: 3.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

I am running 64-bit xpra 3.0, newly installed from xpra PPA, on ubuntu 18.04 on both server and client.

The client has a dual-screen setup, with a laptop screen 1440x900 and an external display of 1280x1024 (both of those are well over a decade old! That's why I connect them to a server with speedier hardware!). This is an extended desktop setup. I am running gnome desktop, but not wayland or gnome3 but in a "fallback" desktop environment with metacity Window manager

I put my browser windows on the external display. When I maximize them (e.g. by hitting the maximization the maximization button on the window, or by using keyboard shortcut), the window fills the external display (1280x1024), as expected.

But as soon as my cursor move to the laptop window, the maximization state is lost and the window shrinks to the original smaller size. Moving the cursor back to external display the window does not go back to original size.

In xpra 2.*, the window stay maximized and fill up the external display wherever I move my cursors, as expected.

Other than this, xpra 3.0 has been working well for me. Thank you for your hardwork!

P.S. I got these errors on the client side several times, don't know whether they are related to the bug:

2019-10-01 00:15:13,208 Error handling unmap event
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/xpra/client/gtk_base/gtk_client_window_base.py", line 1990, in do_unmap_event
    gtk.Window.do_unmap_event(self, event)
GLib.GError: g-invoke-error-quark: Class GtkWindow doesn't implement unmap_event (1)
2019-10-01 00:16:07,229 Error handling unmap event
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/xpra/client/gtk_base/gtk_client_window_base.py", line 1990, in do_unmap_event
    gtk.Window.do_unmap_event(self, event)
GLib.GError: g-invoke-error-quark: Class GtkWindow doesn't implement unmap_event (1)
2019-10-01 00:16:07,254 Error handling unmap event
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/xpra/client/gtk_base/gtk_client_window_base.py", line 1990, in do_unmap_event
    gtk.Window.do_unmap_event(self, event)
GLib.GError: g-invoke-error-quark: Class GtkWindow doesn't implement unmap_event (1)

Change History (1)

comment:1 Changed 2 months ago by Antoine Martin

Description: modified (diff)
Resolution: duplicate
Status: newclosed

The Error handling unmap event should be fixed in r24051.
Do you mind telling me how to trigger it?
It was reported before but I just could not find a way to trigger it, which is why I left the warning.

But as soon as my cursor move to the laptop window, the maximization state is lost...

This is an exact duplicate of #2423.

Last edited 2 months ago by Antoine Martin (previous) (diff)
Note: See TracTickets for help on using tickets.