xpra icon
Bug tracker and wiki

Opened 8 days ago

Closed 43 hours ago

#2438 closed defect (fixed)

ubuntu 18.04 gnome scaling

Reported by: Peter Bleszynski Owned by: Antoine Martin
Priority: critical Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Recently xpra stopped working with Ubuntu 18.04.3 LTS when a Gnome desktop scaling factor other than 100% is used.

The effect is that the interface fills the lower left quarter of the window instead of scaling to fit the entire window. Mouse interactions seem to be mapped to the correct positions, however.

This problem affects all programs, including xcalc and xeyes. I am able to reproduce the problem on multiple machines, under both wayland and xorg, and different display drivers.

$ sudo dpkg-query -l | grep xpra
ii  python2-xpra    3.0-r24095-1  amd64  tool to detach/reattach running X programs
ii  python3-xpra    3.0-r24095-1  amd64  tool to detach/reattach running X programs
ii  xpra            3.0-r24095-1  amd64  tool to detach/reattach running X programs
ii  xpra-html5      3.0-r24095-1  amd64  html5 xpra client

Change History (6)

comment:1 Changed 8 days ago by Antoine Martin

Description: modified (diff)
Status: newassigned

How do you set the desktop scaling factor?
Does the problem go away if you turn opengl off?

comment:2 Changed 8 days ago by Peter Bleszynski

In the case of HiDPI displays, I use the Gnome Settings widget to change scale from 100% to 200%.

In the case of non-HiDPI displays, the scale widget is not displayed but I can reproduce the problem by opening dconf-editor, navigating to org.gnome.desktop.interface, and setting the scaling factor to 2. I think this has the same effect as the widget.

Regarding opengl, I was able to reproduce the problem in a "Gnome Flashback (Compiz)" session which appears to not use hardware acceleration. This was on a non-HiDPI display. I will try other machines tomorrow. If there is a better way to disable opengl then please let me know.

Last edited 8 days ago by Peter Bleszynski (previous) (diff)

comment:3 Changed 8 days ago by Antoine Martin

Regarding opengl, I was able to reproduce the problem in a "Gnome Flashback (Compiz)" session which appears to not use hardware acceleration

I meant starting xpra with --opengl=no or using the system tray to disable opengl.

comment:4 Changed 7 days ago by Peter Bleszynski

Starting xpra attach with --opengl=no scales the application (xcalc) to fit the window. The pointer sometimes disappears and is not mapped to the correct xy position.

We were using xpra to scale a Java gui application on a HiDPI display in Gnome 3. Recently the application started to respect the gnome desktop scaling factor under Wayland sessions. I don't understand how this works but it solves the main problem for us.

comment:5 Changed 44 hours ago by Antoine Martin

Priority: majorcritical

Links:

Related changes:

  • r24125 if the desktop scaling value is set, honour it
  • r24128 keep scaling value with mmap
  • r24131 fix cursor scaling

Found an easy workaround: run the client with xsettings=no.
The problem is that we're synchronising the GTK property that makes it report adjusted coordinates on the server, then all the calls we make to GTK report values that aren't real.
This will need to be filtered out.

comment:6 Changed 43 hours ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Fixed in r24133.

This will be included in the next stable update. Until then, the xsettings=no is a viable workaround - works for both client and server command lines.

Note: See TracTickets for help on using tickets.