xpra icon
Bug tracker and wiki

Opened 5 weeks ago

Closed 4 weeks ago

#2442 closed defect (fixed)

Internal package conflict on libx264.so.155 vs 157 on CentOS 7.7

Reported by: micket Owned by: micket
Priority: major Milestone: 4.0
Component: packaging Version: 3.0.x
Keywords: Cc:

Description

Reposyncing the latest RPMs and trying to update a system I get

--> Processing Dependency: libx264.so.155()(64bit) for package: ffmpeg-xpra-4.2.1-1.el7_7.x86_64
--> Finished Dependency Resolution
Error: Package: ffmpeg-xpra-4.2.1-1.el7_7.x86_64 (@c3se-xpra7)
           Requires: libx264.so.155()(64bit)
           Removing: x264-xpra-20190109-1.el7_7.x86_64 (@c3se-xpra7)
               libx264.so.155()(64bit)
           Updated By: x264-xpra-20190929-1.el7_7.x86_64 (c3se-xpra7)
              ~libx264.so.157()(64bit)

and, as far as I can tell, it's just a packaging bug with contradictory dependencies.

Updating with --skip-broken i get

Skipped (dependency problems):
 libvpx-xpra                         x86_64                 1.8.1-1.el7_7                                    c3se-xpra7                       713 k
 libyuv                              x86_64                 0-0.35.20190401git4bd08cb.el7_7                  c3se-xpra7                       113 k
 python2-xpra                        x86_64                 3.0-0.r24048.el7_7                               c3se-xpra7                       2.7 M
 python2-xpra-client                 x86_64                 3.0-0.r24048.el7_7                               c3se-xpra7                       609 k
 python2-xpra-server                 x86_64                 3.0-0.r24048.el7_7                               c3se-xpra7                       776 k
 x264-xpra                           x86_64                 20190929-1.el7_7                                 c3se-xpra7                       648 k
 xpra                                x86_64                 3.0-0.r24048.el7_7                               c3se-xpra7                        67 k
 xpra-common                         noarch                 3.0-0.r24048.el7_7                               c3se-xpra7                       329 k
 xpra-common-client                  noarch                 3.0-0.r24048.el7_7                               c3se-xpra7                        71 k
 xpra-common-server                  noarch                 3.0-0.r24048.el7_7                               c3se-xpra7                       112 k
 xpra-html5                          noarch                 3.0-0.r24048.el7_7                               c3se-xpra7                       2.3 M

Change History (2)

comment:1 Changed 5 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to micket

Sorry about that, the package should have been rebuilt against the new x264 package but for some reason it wasn't.

I've just pushed an update, can you try:

yum clean all
yum update

comment:2 Changed 4 weeks ago by micket

Resolution: fixed
Status: newclosed

Thank you for the quick response, updating the packages works fine now.

Note: See TracTickets for help on using tickets.