xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 3 years ago

Closed 21 months ago

Last modified 17 months ago

#2444 closed defect (fixed)

Maximized application in HTML5 has mouse offset

Reported by: Florian Feldhaus Owned by: Antoine Martin
Priority: major Milestone: 4.1
Component: html5 Version: 3.0.x
Keywords: Cc:


When a window inside an HTML5 client is scaled to the maximum width (e.g. by maximizing the window), the mouse cursor is offset. If the width is modified several times, the offset changes and can increase even more.

This was discovered using XPRA 3.0 and different clients running Linux and Mac OS X with low and high resolutions.

The closed ticket #2124 describes a similar situation.

Change History (7)

comment:1 Changed 3 years ago by Florian Feldhaus

Component: androidhtml5

comment:2 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to Florian Feldhaus

What server OS are you using?
What application can I use to reproduce? What browser?

I have tried with a Fedora server and xterm with a client running in Firefox, there is no offset no matter how many times I maximize or resize.

comment:3 Changed 3 years ago by Florian Feldhaus

I tried this on Mac OS X 10.14.6 with Firefox 69 and Chrome 77 as well as on a Pixelbook with Chrome OS 77.

While the issue immediately occured on my 5K monitor and on the Pixelbook with a resolution of 1200x800, on my MacBook Retina display it only showed up after I resized the Browser. It always occured when I resized the Browser window to half the height. Modifying the width didn't cause problems until very small window sizes.

You can try this for yourself by using my docker image from here:

Basically you have to install Docker, then run

docker run -p 14500:14500 --name wireshark ffeldhaus/wireshark

and access via

Last edited 3 years ago by Florian Feldhaus (previous) (diff)

comment:4 Changed 3 years ago by Antoine Martin

Milestone: 3.14.0
Owner: changed from Florian Feldhaus to Antoine Martin
Status: newassigned

I can't reproduce this with my 4K monitors and wireshark...
So this may take a while to fix.

comment:5 Changed 2 years ago by Antoine Martin

Milestone: 4.04.1

Simple steps with an xterm or something simple would help me to reproduce it.
Anything that requires a 5K monitor or running a docker container is a non-starter.

comment:6 Changed 21 months ago by Florian Feldhaus

Resolution: fixed
Status: assignedclosed

I recently checked this issue with the latest XPRA release (4.0.4) and my 5K monitor (the same where the issue first occured) and I wasn't able to reproduce the issue. Therefore I will close the issue now.

comment:7 Changed 17 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2444

Note: See TracTickets for help on using tickets.