Xpra: Ticket #2444: Maximized application in HTML5 has mouse offset

When a window inside an HTML5 client is scaled to the maximum width (e.g. by maximizing the window), the mouse cursor is offset. If the width is modified several times, the offset changes and can increase even more.

This was discovered using XPRA 3.0 and different clients running Linux and Mac OS X with low and high resolutions.

The closed ticket #2124 describes a similar situation.

Mon, 14 Oct 2019 16:22:03 GMT - Florian Feldhaus: component changed

Tue, 15 Oct 2019 14:37:58 GMT - Antoine Martin: owner changed

What server OS are you using? What application can I use to reproduce? What browser?

I have tried with a Fedora server and xterm with a client running in Firefox, there is no offset no matter how many times I maximize or resize.

Wed, 16 Oct 2019 14:45:51 GMT - Florian Feldhaus:

I tried this on Mac OS X 10.14.6 with Firefox 69 and Chrome 77 as well as on a Pixelbook with Chrome OS 77.

While the issue immediately occured on my 5K monitor and on the Pixelbook with a resolution of 1200x800, on my MacBook Retina display it only showed up after I resized the Browser. It always occured when I resized the Browser window to half the height. Modifying the width didn't cause problems until very small window sizes.

You can try this for yourself by using my docker image from here: https://github.com/ffeldhaus/docker-wireshark

Basically you have to install Docker, then run

docker run -p 14500:14500 --name wireshark ffeldhaus/wireshark

and access via


Tue, 22 Oct 2019 08:30:55 GMT - Antoine Martin: owner, status, milestone changed

I can't reproduce this with my 4K monitors and wireshark... So this may take a while to fix.

Fri, 08 May 2020 14:41:18 GMT - Antoine Martin: milestone changed

Simple steps with an xterm or something simple would help me to reproduce it. Anything that requires a 5K monitor or running a docker container is a non-starter.

Thu, 22 Oct 2020 06:51:45 GMT - Florian Feldhaus: status changed; resolution set

I recently checked this issue with the latest XPRA release (4.0.4) and my 5K monitor (the same where the issue first occured) and I wasn't able to reproduce the issue. Therefore I will close the issue now.

Sat, 23 Jan 2021 05:51:26 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2444