xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 4 weeks ago

#2461 closed defect (fixed)

clipboard copying from server to client doesn't work.

Reported by: Jiang Owned by: Antoine Martin
Priority: blocker Milestone: 4.0
Component: android Version: 3.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

After updating from 3.0 (r24095) to 3.0.1(r24241), the text clipboard copying from server window to client doesn't work any more.

I am using Ubuntu 18.04 64 bit on both server and client. Before the update, clipboard copying on both directions work. after updating, I can only copy from client to server, but not from server to client. Clipboard was of course selected as "both direction".

This seems to be the bug in client side, because when I run the server as 3.0.1 and client downgraded to 3.0.0, the clipboard copying works again in both directions, though I constantly got message

2019-10-23 02:52:31,514  valid targets: TIMESTAMP, TARGETS, SAVE_TARGETS, MULTIPLE, STRING, UTF8_STRING, TEXT, text/plain
2019-10-23 02:52:31,515  dropping the request

on the client logs, these seems not to affect the copying process.

Needless to say, this is a major blocking issue and it forces me to downgrade the client. Please let me know what more help I can provide to debug this.

Change History (2)

comment:1 Changed 4 weeks ago by Antoine Martin

Description: modified (diff)
Status: newassigned

This is likely to be caused by #2450, you should be able to revert r24231.

comment:2 Changed 4 weeks ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

The commit has been reverted in r24245, and the correct fix applied in r24247.

I will re-issue 3.0.1 with this one fix applied on top.

Note: See TracTickets for help on using tickets.