xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 3 weeks ago

#2463 closed defect (fixed)

Seeing an error in expire_delayed_region, in window_source.py, when mousing over browser regions

Reported by: alas Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: html5 Version: trunk
Keywords: Cc:

Description

Updated fedora 30 server to 4.0-r24232 and launched with

xpra start :13 --no-daemon --bind-tcp=0.0.0.0:1234 --bind-ws=0.0.0.0:1237 --start-child=xterm --start-child=xterm --exit-with-children

Connected with a Windows 7 html5 client (Chrome 77), and installed chromium (since firefox seems to be problematic?) on the server.

The interaction periodically froze... and then I noticed the following traceback recurring with the regularity that you will probably expect.

Traceback (most recent call last):
  File "/usr/lib64/python3.7/site-packages/xpra/server/window/window_source.py", line 1447, in expire_delayed_region
    self.may_send_delayed()
  File "/usr/lib64/python3.7/site-packages/xpra/server/window/window_source.py", line 1611, in may_send_delayed
    self.do_send_delayed()
  File "/usr/lib64/python3.7/site-packages/xpra/server/window/window_source.py", line 1622, in do_send_delayed
    self.send_delayed_regions(delayed)
  File "/usr/lib64/python3.7/site-packages/xpra/server/window/window_source.py", line 1640, in send_delayed_regions
    self.do_send_delayed_regions(dr.damage_time, dr.regions, dr.encoding, dr.options)
  File "/usr/lib64/python3.7/site-packages/xpra/server/window/window_video_source.py", line 810, in do_send_delayed_regions
    send_nonvideo(regions=regions, encoding=None, exclude_region=actual_vr)
  File "/usr/lib64/python3.7/site-packages/xpra/server/window/window_video_source.py", line 710, in send_nonvideo
    super().do_send_delayed_regions(damage_time, regions, encoding, options, exclude_region=exclude_region, get_best_encoding=get_best_encoding)
TypeError: super(type, obj): obj must be an instance or subtype of type

I was able to trigger when mousing over regions (probably triggering nonvideo region repaints?...) of chromium or firefox, but not in applications like xterm or gedit.

Running videos don't trigger, but it looks like keyboard input also triggers it, and those typed characters are often not rendering as the error is triggered when typing into browser fields.

Change History (1)

comment:1 Changed 3 weeks ago by Antoine Martin

Resolution: fixed
Status: newclosed

Good catch, that was caused by r24174 and is fixed in r24259.

There may be more, so I'll inspect the changeset again.

Note: See TracTickets for help on using tickets.