xpra icon
Bug tracker and wiki

Opened 2 weeks ago

Closed 2 weeks ago

Last modified 10 days ago

#2469 closed defect (duplicate)

version 3.0.1 is broken

Reported by: Nuno Dias Owned by: Antoine Martin
Priority: blocker Milestone: 4.0
Component: android Version: 3.0.x
Keywords: Cc:

Description

The rendering of the window in the client is broken (see screenshot), because of this xpra is not usable anymore.

In the server I have this version
xpra-common-server-3.0.1-0.r24252.fc30.noarch
In the client
xpra-3.0.1-0.r24252.fc31.x86_64

Attachments (3)

Screenshot.png (101.8 KB) - added by Nuno Dias 2 weeks ago.
xpra.log (34.3 KB) - added by Nuno Dias 2 weeks ago.
blacklist-intel.patch (648 bytes) - added by Antoine Martin 13 days ago.
hopefully not needed

Download all attachments as: .zip

Change History (13)

Changed 2 weeks ago by Nuno Dias

Attachment: Screenshot.png added

comment:1 Changed 2 weeks ago by Nuno Dias

Forgot to say, the client has a 3200 x 1800 screen resolution, don't know if this info is important.

comment:2 Changed 2 weeks ago by Antoine Martin

Resolution: duplicate
Status: newclosed

Duplicate of #2466.

Until 3.0.2 is released, turn off opengl and things should work.

comment:3 Changed 2 weeks ago by Antoine Martin

Please post the output of

XPRA_ALL_DEBUG=1 xpra opengl-probe

And try running the client with:

XPRA_REPAINT_ALL=1 xpra attach

Does that help?

You can also use the python2 builds to workaround this issue:

python2 /usr/bin/xpra attach ..
Last edited 2 weeks ago by Antoine Martin (previous) (diff)

comment:4 Changed 2 weeks ago by Antoine Martin

This may work for you:

XPRA_OPENGL_DRAW_REFRESH=1 xpra attach ...

Changed 2 weeks ago by Nuno Dias

Attachment: xpra.log added

comment:5 Changed 2 weeks ago by Nuno Dias

The output of XPRA_ALL_DEBUG=1 xpra opengl-probe is in xpra.log attach
The other options don't work, and running python2 client is not also an option because when I try to install python2-xpra-client I have this error

nothing provides pygtkglext needed by python2-xpra-client-3.0-0.r24048.fc31.x86_64
Last edited 2 weeks ago by Antoine Martin (previous) (diff)

comment:6 Changed 2 weeks ago by Antoine Martin

The other options don't work

Have you tried --opengl=no?

nothing provides pygtkglext needed by python2-xpra-client-3.0-0.r24048.fc31.x86_64

That's fixed in r24361 (r24362 was also needed), dnf should now pick it up, you may need to force the refresh if not.

From your log:

vendor: Intel Open Source Technology Center
renderer: Mesa DRI Intel(R) Haswell Mobile

The command line should have given you a greylist warning about that.

Intel drivers are known to cause problems, we even have a wiki entry dedicated to them: wiki/ClientRendering/OpenGL

Last edited 2 weeks ago by Antoine Martin (previous) (diff)

comment:7 Changed 13 days ago by Nuno Dias

Sorry forgot about the --opengl=no, with that options works.

With the install of the python2-xpra now I have another error
nothing provides python2-rencode needed by python2-xpra-3.0-0.r24048.fc31.x86_64

Last edited 13 days ago by Antoine Martin (previous) (diff)

Changed 13 days ago by Antoine Martin

Attachment: blacklist-intel.patch added

hopefully not needed

comment:8 Changed 13 days ago by Antoine Martin

r24384 blacklists old Intel drivers: Ivybridge, Haswell

comment:9 Changed 12 days ago by Antoine Martin

nothing provides python2-rencode needed by python2-xpra-3.0-0.r24048.fc31.x86_64

That's also fixed, thanks for reporting it.
Xpra 3.0.2 has been released with the fixes from this ticket and #2466.

comment:10 Changed 10 days ago by Nuno Dias

Thanks, everything works now.

Note: See TracTickets for help on using tickets.