xpra icon
Bug tracker and wiki

Opened 2 weeks ago

Closed 2 weeks ago

#2473 closed defect (fixed)

%d format: a number is required, not str

Reported by: sto6 Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc:

Description

Similar error as #2437 but from macos client using GUI, when .ssh/config entry has a 'Port 22' (i.e. I believe any explicit numeric Port line, default or not, but it is the default value of 22 in my case).

Of course the GUI-form forces a value to be entered for the Port field, and I enter 22 there in any case (this is probably not relevant).

I used the download: Xpra-Python2-x86_64-3.0.1-r24240.dmg
For my case, all these are different: OS, python2 not 3, version 3.0.1 not 3.0, GUI (not cmd-line 'xpra attach'), '%d' not '%i'.

% Xpra_Version_info
Build:
* local_modifications             : 0
* revision                        : 24240
* version                         : 3.0.1

Platform:
* architecture                    : 64bit,
* machine                         : x86_64
* name                            : Mac OS X 10.13.6
* platform                        : Darwin-17.7.0-x86_64-i386-64bit
* processor                       : Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz
* release                         : 17.7.0
* sys                             : darwin
* sysrelease                      : 10.13.6

Host:
* byteorder                       : little
* gid                             : 20
* hostname                        : blah.local
* pid                             : 55927
* pyobjc.version                  : 5.2
* python
  - bits                          : 64
  - full_version                  : 2.7.16 (default, Sep 30 2019, 11:55:05) \n[GCC 4.2.1 Compatible Apple LLVM 7.3.0 (clang-703.0.31)]
  - version                       : 2.7.16
* uid                             : 501

Attachments (1)

Screen Shot 2019-11-03 at 3.39.08 PM.png (159.3 KB) - added by sto6 2 weeks ago.
Launcher error in screenshot

Download all attachments as: .zip

Change History (2)

Changed 2 weeks ago by sto6

Launcher error in screenshot

comment:1 Changed 2 weeks ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks for the bug report, this is fixed in r24363 and will be in the next stable update.
In the meantime, you could apply this by hand as the change is quite small.

Note: See TracTickets for help on using tickets.