xpra icon
Bug tracker and wiki

Opened 2 months ago

Last modified 2 months ago

#2483 assigned defect

html5 scroll paint error and disconnection

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: html5 Version: 3.0.x
Keywords: Cc:

Description

Caught this in my server log and the client got disconnected:

@http://192.168.2.100:10000/js/Window.js:1453:31
paint@http://192.168.2.100:10000/js/Window.js:1225:17
paint@http://192.168.2.100:10000/js/Window.js:1212:7
XpraClient.prototype._process_draw_queue@http://192.168.2.100:10000/js/Client.js:2657:7
XpraClient.prototype._process_draw@http://192.168.2.100:10000/js/Client.js:2571:7
XpraClient.prototype._route_packet@http://192.168.2.100:10000/js/Client.js:515:5
XpraProtocolWorkerHost.prototype.open/<@http://192.168.2.100:10000/js/Protocol.js:47:9
error painting scroll TypeError: Argument 1 of CanvasRenderingContext2D.drawImage could not be converted to any of: HTMLImageElement, SVGImageElement, HTMLCanvasElement, HTMLVideoElement, ImageBitmap.

client was running an xterm and gedit

Change History (2)

comment:1 Changed 2 months ago by Antoine Martin

Status: newassigned
Summary: html5 scroll paint errorhtml5 scroll paint error and disconnection

#2487 closed as duplicate of this bug.

comment:2 Changed 2 months ago by Antoine Martin

The line that causes the error is:

this.offscreen_canvas_ctx.drawImage(this.draw_canvas, sx, sy, sw, sh, sx+xdelta, sy+ydelta, sw, sh);

Two things to look into:

  • swap_buffers must be called at least once before we can use scroll paint
  • maybe the paint exception handler is buggy?
Last edited 2 months ago by Antoine Martin (previous) (diff)
Note: See TracTickets for help on using tickets.