xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#2487 closed defect (duplicate)

HTML5 session disconnects spontaneously then tries to reconnect and hits client decoding error, triggering reconnection failure.

Reported by: alas Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: html5 Version: 3.0.x
Keywords: Cc:

Description

Launched a 4.0-r24425 Fedora 30 server with the command-

xpra start :13 --no-daemon --bind-tcp=0.0.0.0:1234 --bind-ws=0.0.0.0:1237 --bind-wss=0.0.0.0:1239 --ssl-cert=/etc/xpra/148-ssl.pem  --start-child=xterm --start-child=xterm --exit-with-children -d clipboard

Connected with a Firefox html5 client with client-side debugging enabled.
Launched gedit from one of the xterms, and then went slowly through the now familiar clipboard tests (type & copy 'one' in gedit application, shift focus to a local text editor, Word in this case, and pasted with control-v, then typed and copied 'two', then shifted focus back to gedit server-side by clicking at the end of the still highlighted 'one' text, used arrow key to get to next line and tried to paste with right-click menu, then used keyboard to add a space, then pasted with control-v, successfully pasting 'two'... then shifted focus to a new putty window to check the exact xpra version).

Before I could do anything to sort through putty window server logs - the session disconnected with the following errors in the server logs.

2019-11-18 14:01:55,892 Handshake complete; enabling connection
2019-11-18 14:01:55,894 Disconnecting client 10.0.4.54:54818:
2019-11-18 14:01:55,894  new client (the new client does not wish to share)
2019-11-18 14:01:55,894 client None is the clipboard peer, helper=X11Clipboard
2019-11-18 14:01:55,894 enabling selections:
2019-11-18 14:01:55,894 X11ClipboardProxy(CLIPBOARD).set_enabled(False)
2019-11-18 14:01:55,895 X11ClipboardProxy(PRIMARY).set_enabled(False)
2019-11-18 14:01:55,895 X11ClipboardProxy(SECONDARY).set_enabled(False)
2019-11-18 14:01:55,896 xpra client 1 disconnected.
2019-11-18 14:01:55,907 client clipboard: enabled=True, notifications=False
2019-11-18 14:01:55,907 client clipboard: greedy=True, want_targets=True, client_selections=['CLIPBOARD', 'PRIMARY'], contents_slice_fix=True
2019-11-18 14:01:55,908 HTML5 Microsoft Windows Firefox client version 3.0
2019-11-18 14:01:55,914 client ClientConnection(2 : WebSocket(wss socket: 10.0.3.148:1239 <- 10.0.4.54:54989)) is the clipboard peer, helper=X11Clipboard
2019-11-18 14:01:55,914  greedy=True
2019-11-18 14:01:55,914  want targets=True
2019-11-18 14:01:55,914  server has selections: CLIPBOARD, PRIMARY, SECONDARY
2019-11-18 14:01:55,914  client initial selections: CLIPBOARD, PRIMARY
2019-11-18 14:01:55,914 X11ClipboardProxy(CLIPBOARD).set_greedy_client(True)
2019-11-18 14:01:55,914 X11ClipboardProxy(PRIMARY).set_greedy_client(True)
2019-11-18 14:01:55,914 X11ClipboardProxy(SECONDARY).set_greedy_client(True)
2019-11-18 14:01:55,914 set_want_targets_client(True)
2019-11-18 14:01:55,914 enabling selections: CLIPBOARD, PRIMARY
2019-11-18 14:01:55,915 X11ClipboardProxy(CLIPBOARD).set_enabled(True)
2019-11-18 14:01:55,915 X11ClipboardProxy(PRIMARY).set_enabled(True)
2019-11-18 14:01:55,915 X11ClipboardProxy(SECONDARY).set_enabled(False)
2019-11-18 14:01:55,915 keyboard mapping already configured (skipped)
2019-11-18 14:01:55,916  client root window size is 1024x576 with 1 display:
2019-11-18 14:01:55,916   HTML (271x152 mm - DPI: 95x96)
2019-11-18 14:01:55,916     Canvas
2019-11-18 14:01:55,966 server virtual display now set to 1024x576
2019-11-18 14:01:55,973 clipboard_helper=X11Clipboard, clipboard_client=ClientConnection(2 : WebSocket(wss socket: 10.0.3.148:1239 <- 10.0.4.54:54989)), source=ClientConnection(2 : WebSocket(wss socket: 10.0.3.148:1239 <- 10.0.4.54:54989)), clipboard=True
2019-11-18 14:01:55,973 get_loop_uuids()={'CLIPBOARD': 'Xpra-Clipboard-Loop-Detection:740370c6c9244ce599ee66f77bcd9ba1', 'PRIMARY': 'Xpra-Clipboard-Loop-Detection:d67265c836834f92b9b51a5c9982d1a6', 'SECONDARY': 'Xpra-Clipboard-Loop-Detection:2d7acd2a663a4564b98a3330c2989db2'}
2019-11-18 14:01:55,973  automatic picture encoding enabled, also available:
2019-11-18 14:01:55,974   jpeg, png, rgb32, h264, mpeg1
2019-11-18 14:01:56,004 DPI set to 96 x 96
2019-11-18 14:01:56,018 Warning: failed to add virtual printer 'HTML5 client'
2019-11-18 14:01:56,018  failed to connect to server
2019-11-18 14:01:56,075 client   2 received xdg start menu data
2019-11-18 14:01:56,119 Error: wss request failure
2019-11-18 14:01:56,119  errno=0
2019-11-18 14:01:56,119  for client 10.0.4.54:55022:
2019-11-18 14:01:56,119  request as hex: '160301021501000211030385ab1a8761223364d84d6bf1'
2019-11-18 14:01:56,119  [Errno 0] Error
2019-11-18 14:01:56,149 set_session_driver(ClientConnection(2 : WebSocket(wss socket: 10.0.3.148:1239 <- 10.0.4.54:54989))) clipboard_enabled=True, clipboard helper=X11Clipboard
2019-11-18 14:01:56,149 selections: ['CLIPBOARD', 'PRIMARY']
2019-11-18 14:01:56,150 client   2 startup complete
2019-11-18 14:01:56,153 client   2 connection-established
2019-11-18 14:01:56,154 client   2 update encodings: [object Object]
2019-11-18 14:01:56,634 client   2 XpraWindow.prototype.do_paint@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:30651
2019-11-18 14:01:56,634 client   2 XpraWindow.prototype.may_paint_now@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:25552
2019-11-18 14:01:56,634 client   2 XpraWindow.prototype.paint@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:25179
2019-11-18 14:01:56,634 client   2 XpraClient.prototype._process_draw_queue@https://xpra-bob.mycyberinc.com:1239/js/Client.js:2:26605
2019-11-18 14:01:56,634 client   2 XpraClient.prototype._process_draw@https://xpra-bob.mycyberinc.com:1239/js/Client.js:2:24984
2019-11-18 14:01:56,635 client   2 XpraClient.prototype._route_packet@https://xpra-bob.mycyberinc.com:1239/js/Client.js:1:10733
2019-11-18 14:01:56,635 client   2 XpraProtocolWorkerHost.prototype.open/<@https://xpra-bob.mycyberinc.com:1239/js/Protocol.js:1:707
2019-11-18 14:01:56,659 client   2 error painting scroll TypeError: Argument 1 of CanvasRenderingContext2D.drawImage could not be converted to any of: HTMLImageElement, SVGImageElement, HTMLCanvasElement, HTMLVideoElement, ImageBitmap.
2019-11-18 14:01:56,660 Warning: client decoding error:
2019-11-18 14:01:56,660  TypeError: Argument 1 of CanvasRenderingContext2D.drawImage could not be converted to any of: HTMLImageElement, SVGImageElement, HTMLCanvasElement, HTMLVideoElement, ImageBitmap.
2019-11-18 14:01:57,824 client   2 XpraWindow.prototype.do_paint@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:30651
2019-11-18 14:01:57,824 client   2 XpraWindow.prototype.may_paint_now@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:25552
2019-11-18 14:01:57,825 client   2 XpraWindow.prototype.paint@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:25179
2019-11-18 14:01:57,825 client   2 XpraClient.prototype._process_draw_queue@https://xpra-bob.mycyberinc.com:1239/js/Client.js:2:26605
2019-11-18 14:01:57,825 client   2 XpraClient.prototype._process_draw@https://xpra-bob.mycyberinc.com:1239/js/Client.js:2:24984
2019-11-18 14:01:57,825 client   2 XpraClient.prototype._route_packet@https://xpra-bob.mycyberinc.com:1239/js/Client.js:1:10733
2019-11-18 14:01:57,826 client   2 XpraProtocolWorkerHost.prototype.open/<@https://xpra-bob.mycyberinc.com:1239/js/Protocol.js:1:707
2019-11-18 14:01:57,842 client   2 error painting scroll TypeError: Argument 1 of CanvasRenderingContext2D.drawImage could not be converted to any of: HTMLImageElement, SVGImageElement, HTMLCanvasElement, HTMLVideoElement, ImageBitmap.
2019-11-18 14:01:57,843 Warning: client decoding error:
2019-11-18 14:01:57,843  TypeError: Argument 1 of CanvasRenderingContext2D.drawImage could not be converted to any of: HTMLImageElement, SVGImageElement, HTMLCanvasElement, HTMLVideoElement, ImageBitmap.
2019-11-18 14:01:59,034 client   2 XpraWindow.prototype.do_paint@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:30651
2019-11-18 14:01:59,035 client   2 XpraWindow.prototype.may_paint_now@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:25552
2019-11-18 14:01:59,035 client   2 XpraWindow.prototype.paint@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:25179
2019-11-18 14:01:59,035 client   2 XpraClient.prototype._process_draw_queue@https://xpra-bob.mycyberinc.com:1239/js/Client.js:2:26605
2019-11-18 14:01:59,036 client   2 XpraClient.prototype._process_draw@https://xpra-bob.mycyberinc.com:1239/js/Client.js:2:24984
2019-11-18 14:01:59,036 client   2 XpraClient.prototype._route_packet@https://xpra-bob.mycyberinc.com:1239/js/Client.js:1:10733
2019-11-18 14:01:59,036 client   2 XpraProtocolWorkerHost.prototype.open/<@https://xpra-bob.mycyberinc.com:1239/js/Protocol.js:1:707
2019-11-18 14:01:59,037 client   2 error painting scroll TypeError: Argument 1 of CanvasRenderingContext2D.drawImage could not be converted to any of: HTMLImageElement, SVGImageElement, HTMLCanvasElement, HTMLVideoElement, ImageBitmap.
2019-11-18 14:01:59,037 Warning: client decoding error:
2019-11-18 14:01:59,037  TypeError: Argument 1 of CanvasRenderingContext2D.drawImage could not be converted to any of: HTMLImageElement, SVGImageElement, HTMLCanvasElement, HTMLVideoElement, ImageBitmap.
2019-11-18 14:02:00,218 client   2 XpraWindow.prototype.do_paint@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:30651
2019-11-18 14:02:00,218 client   2 XpraWindow.prototype.may_paint_now@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:25552
2019-11-18 14:02:00,219 client   2 XpraWindow.prototype.paint@https://xpra-bob.mycyberinc.com:1239/js/Window.js:1:25179
2019-11-18 14:02:00,219 client   2 XpraClient.prototype._process_draw_queue@https://xpra-bob.mycyberinc.com:1239/js/Client.js:2:26605
2019-11-18 14:02:00,219 client   2 XpraClient.prototype._process_draw@https://xpra-bob.mycyberinc.com:1239/js/Client.js:2:24984
2019-11-18 14:02:00,219 client   2 XpraClient.prototype._route_packet@https://xpra-bob.mycyberinc.com:1239/js/Client.js:1:10733
2019-11-18 14:02:00,220 client   2 XpraProtocolWorkerHost.prototype.open/<@https://xpra-bob.mycyberinc.com:1239/js/Protocol.js:1:707
2019-11-18 14:02:00,235 client   2 error painting scroll TypeError: Argument 1 of CanvasRenderingContext2D.drawImage could not be converted to any of: HTMLImageElement, SVGImageElement, HTMLCanvasElement, HTMLVideoElement, ImageBitmap.
2019-11-18 14:02:00,236 Warning: client decoding error:
2019-11-18 14:02:00,236  TypeError: Argument 1 of CanvasRenderingContext2D.drawImage could not be converted to any of: HTMLImageElement, SVGImageElement, HTMLCanvasElement, HTMLVideoElement, ImageBitmap.
2019-11-18 14:02:01,043 client None is the clipboard peer, helper=X11Clipboard
2019-11-18 14:02:01,044 enabling selections:
2019-11-18 14:02:01,044 X11ClipboardProxy(CLIPBOARD).set_enabled(False)
2019-11-18 14:02:01,044 X11ClipboardProxy(PRIMARY).set_enabled(False)
2019-11-18 14:02:01,044 X11ClipboardProxy(SECONDARY).set_enabled(False)
2019-11-18 14:02:01,045 xpra client 2 disconnected.

Not sure why it dosconnected like that, perhaps wss error because I had to click through a cert error (no SAN in cert causing a problem, as a guess?)... which is leading to wss errors (which I'll add below as well)?

The apparent attempt to configure the HTML5 client as a printer seems likely to be part of the problem - 2019-11-18 14:01:56,018 Warning: failed to add virtual printer 'HTML5 client'?

The wss error which I was trying to ignore- which I saw on initial connection, and also saw just prior to the new round of clipboard tests.

2019-11-18 13:58:34,620 Error: wss request failure
2019-11-18 13:58:34,620  errno=0
2019-11-18 13:58:34,620  for client 10.0.4.54:54833:
2019-11-18 13:58:34,620  request as hex: '1603010215010002110303c7e46ddb61ac4b1cec65d97fba7ef2db662a4e20a36999fbd19e77db5948cf40200bea8b495e59be203f35a8aed7455fc5286b45598861d306f331bf1dd06303130024130113031302c02bc02fcca9cca8c02cc030c0'
2019-11-18 13:58:34,620 setting response 'None' to property GDK_SELECTION of window 'gedit' as None
2019-11-18 13:58:34,620 set_selection_response(<GdkX11.X11Window object at 0x7f23a12ddb40 (GdkX11Window at 0x557ede8a72a0)>, TARGETS, GDK_SELECTION, None, None, "'None'", 2634287383)
2019-11-18 13:58:34,620  [Errno 0] Error

... it looks like this error was triggered on the connection that seemed to work, as well as the spontaneous reconnection attempt. Seems unlikely to be the trigger, but perhaps contributing?

(I'll attach the parsed clipboard test logs that preceded this in #2452, in case those might also be contributing factors... though the timing seems wrong.)

Change History (4)

comment:1 Changed 3 weeks ago by Antoine Martin

Resolution: duplicate
Status: newclosed

perhaps wss error because I had to click through a cert error

I don't think so, I believe that I have reproduced this without ssl: #2483

The apparent attempt to configure the HTML5 client as a printer seems likely to be part of the problem
Warning: failed to add virtual printer 'HTML5 client'?

No, this is just a warning.
You may want to run your server with -d printing to figure out what is wrong with your system.

The wss error which I was trying to ignore

Xpra does the same. Those are harmless and in v4 we silence them: r24420, r24383.

I'm closing this as a duplicate of #2483.

comment:2 Changed 3 weeks ago by alas

With -d printer, using 4.0-r24461 Fedora 30 server and Firefox HTML5 client on Windows 7... I'm seeing the following traceback & logs.

2019-11-19 15:30:38,797 set_printers({b'HTML5 client': {b'printer-info': b'Print to PDF in client browser', b'printer-make-and-model': b'HTML5 client version', b'mimetypes': [b'application/pdf']}}, [], None, , ) for ClientConnection(1 : WebSocket(wss socket: 10.0.3.148:1239 <- 10.0.4.54:64732))
2019-11-19 15:30:38,797 printer attributes: {'display': ':13', 'source': '2c34d10b-55a4-fb45-3a1c-c9403887e813', 'socket-path': '/run/user/1000/xpra/xpra-lib-fed30-2-13'}
2019-11-19 15:30:38,797 add_printer('HTML5 client', {b'printer-info': b'Print to PDF in client browser', b'printer-make-and-model': b'HTML5 client version', b'mimetypes': [b'application/pdf']}, 'Print to PDF in client browser', 'via xpra', {'display': ':13', 'source': '2c34d10b-55a4-fb45-3a1c-c9403887e813', 'socket-path': '/run/user/1000/xpra/xpra-lib-fed30-2-13', 'remote-printer': b'HTML5 client', 'remote-device-uri': None}, <function FilePrintMixin.setup_printer.<locals>.printer_added at 0x7fe44c1a5200>)
2019-11-19 15:30:38,799 Warning: failed to add virtual printer 'HTML5 client'
2019-11-19 15:30:38,799  failed to connect to server
2019-11-19 15:30:38,799 setup_printer(b'HTML5 client', {b'printer-info': b'Print to PDF in client browser', b'printer-make-and-model': b'HTML5 client version', b'mimetypes': [b'application/pdf']}, {'display': ':13', 'source': '2c34d10b-55a4-fb45-3a1c-c9403887e813', 'socket-path': '/run/user/1000/xpra/xpra-lib-fed30-2-13'})
Traceback (most recent call last):
  File "/usr/lib64/python3.7/site-packages/xpra/server/source/fileprint_mixin.py", line 147, in setup_printer
    add_printer(printer, props, info, location, attrs, success_cb=printer_added)
  File "/usr/lib64/python3.7/site-packages/xpra/platform/pycups_printing.py", line 280, in add_printer
    if xpra_printer_name in get_all_printers():
  File "/usr/lib64/python3.7/site-packages/xpra/platform/pycups_printing.py", line 408, in get_all_printers
    conn = cups.Connection()
RuntimeError: failed to connect to server

Is this just a cups install/configuration error on my part? (I'll leave this closed... since it probably is.)

comment:3 Changed 3 weeks ago by Antoine Martin

RuntimeError: failed to connect to server

The cupsd service is either not installed or not running.

comment:4 Changed 3 weeks ago by alas

Huh.

systemctl start cups

Then launched server with same command... and get

2019-11-20 15:11:44,800 client   1 update encodings: [object Object]
2019-11-20 15:11:44,925 returncode(['/usr/sbin/lpadmin', '-p', 'HTML5-client', '-v', 'xpraforwarder:/tmp?display=%3A13&source=7d4d75e5-f7ae-e370-20b0-4907586ba6c5&socket-path=%2Frun%2Fuser%2F1000%2Fxpra%2Fxpra-lib-fed30-2-13&remote-printer=HTML5+client&remote-device-uri=None&mimetype=application%2Fpdf', '-D', 'Print to PDF in client browser', '-L', 'via xpra', '-E', '-o', 'printer-is-shared=false', '-u', 'allow:maint', '-P', '/usr/share/ppd/cupsfilters/Generic-PDF_Printer-PDF.ppd'])=0
2019-11-20 15:11:44,925 the remote printer 'HTML5 client' has been configured

... not sure what stopped the service, but that was a pretty simple fix.

Thanks.

Note: See TracTickets for help on using tickets.