xpra icon
Bug tracker and wiki

Opened 12 days ago

Closed 12 days ago

Last modified 6 days ago

#2499 closed defect (duplicate)

macOS openGL client errors (gl_paint_planar)

Reported by: mjlbach Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: client Version: 4.0.x
Keywords: Cc:

Description

When using macOS with the latest xpra client beta, I'm receiving errors of the form:

2019-11-29 10:00:03,375 Error painting planar update
Traceback (most recent call last):
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/gl/gl_window_backing_base.py", line 1101, in gl_paint_planar
    self.render_planar_update(x, y, enc_width, enc_height, x_scale, y_scale, shader)
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/gl/gl_window_backing_base.py", line 1199, in render_planar_update
    glEnd()
  File "src/latebind.pyx", line 44, in OpenGL_accelerate.latebind.Curry.__call__
  File "/Applications/Xpra.app/Contents/Resources/lib/python/site-packages.zip/OpenGL/GL/exceptional.py", line 45, in glEnd
    return baseFunction( )
  File "src/errorchecker.pyx", line 53, in OpenGL_accelerate.errorchecker._ErrorChecker.glCheckError
OpenGL.error.GLError: GLError(
	err = 1282,
	description = b'invalid operation',
	baseOperation = glEnd,
	cArguments = ()
)
2019-11-29 10:00:03,380  flush=0, image=ImageWrapper(YUV420P:(0, 0, 640, 344, 24):PACKED), coords=(0, 0, 640, 344), size=640x344
2019-11-29 10:00:03,383 Error presenting FBO:
2019-11-29 10:00:03,384  GLError(
	err = 1282,
	description = b'invalid operation',
	baseOperation = glEnd,
	cArguments = ()
)
2019-11-29 10:00:03,386 Error painting planar update
Traceback (most recent call last):
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/gl/gl_window_backing_base.py", line 1101, in gl_paint_planar
    self.render_planar_update(x, y, enc_width, enc_height, x_scale, y_scale, shader)
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/gl/gl_window_backing_base.py", line 1199, in render_planar_update
    glEnd()
  File "src/latebind.pyx", line 44, in OpenGL_accelerate.latebind.Curry.__call__
  File "/Applications/Xpra.app/Contents/Resources/lib/python/site-packages.zip/OpenGL/GL/exceptional.py", line 45, in glEnd
    return baseFunction( )
  File "src/errorchecker.pyx", line 53, in OpenGL_accelerate.errorchecker._ErrorChecker.glCheckError
OpenGL.error.GLError: GLError(
	err = 1282,
	description = b'invalid operation',
	baseOperation = glEnd,
	cArguments = ()
)

Change History (5)

comment:1 Changed 12 days ago by mjlbach

Component: androidclient
Summary: macOS openGL client errors (gl_paint_planar)macOS openGL client errors (gl_paint_planar) on entering full screen

comment:2 Changed 12 days ago by mjlbach

Summary: macOS openGL client errors (gl_paint_planar) on entering full screenmacOS openGL client errors (gl_paint_planar)

comment:3 Changed 12 days ago by mjlbach

Of note, this affects start-up. The client xpra window will start completely black until openGL is toggled on/off.

comment:4 Changed 12 days ago by Antoine Martin

Resolution: duplicate
Status: newclosed

Duplicate of #2491

comment:5 Changed 6 days ago by Antoine Martin

Finally fixed (that was hard), see ticket:2491#comment:10.
The latest beta builds have this fix and this will also be included in 3.0.3

Please report if you still have problems.

Note: See TracTickets for help on using tickets.