xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

#250 closed defect (duplicate)

review and fix/disable strict aliasing GCC warnings

Reported by: Antoine Martin Owned by:
Priority: major Milestone: 0.8
Component: core Version: trunk
Keywords: Cc:

Description

Recent versions of GCC will print lots of scary warnings when building some of the Cython code:

  • wimpiggy.lowlevel:
    wimpiggy/lowlevel/bindings.c: In function '__pyx_pf_8wimpiggy_8lowlevel_8bindings_44is_mapped':
    wimpiggy/lowlevel/bindings.c:7248:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    wimpiggy/lowlevel/bindings.c:7248:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    (...)
    

And another dozen after that..

  • rencode:
    xpra/rencode/rencode.c: In function '__pyx_f_4xpra_7rencode_8_rencode_decode':
    xpra/rencode/rencode.c:5540:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    xpra/rencode/rencode.c:5540:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    xpra/rencode/rencode.c:5576:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    xpra/rencode/rencode.c:5576:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    xpra/rencode/rencode.c: In function 'init_rencode':
    xpra/rencode/rencode.c:6027:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    xpra/rencode/rencode.c:6027:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    xpra/rencode/rencode.c:6071:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    xpra/rencode/rencode.c:6071:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    

we should fix the warnings, preferably by making the compiler happy or if needed by adding f[no-]strict-aliasing where needed.

Change History (1)

comment:1 Changed 7 years ago by Antoine Martin

Resolution: duplicate
Status: newclosed

dupe of #151

Note: See TracTickets for help on using tickets.