xpra icon
Bug tracker and wiki

#2515 closed defect (fixed)

Launching python 3.0-r24039 client (with Intel GPU) triggers some gtk warnings.

Reported by: alas Owned by: alas
Priority: minor Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc:

Description

Not sure if you're aware, no real problem was triggered, but there are warnings being triggered.

3.0-r24039 OSX python client, with an Intel Iris video card (it might be the warning about the greylisting also leading to gtk warnings?)... I see the following in the client output.

Schadenfreude:MacOS Schadenfreude$ ./Xpra attach tcp:10.0.3.148:1234 
2019-12-12 13:24:38.181 Xpra[67719:27268959] *** WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead. 
Warning: vendor 'Intel Inc.' is greylisted,
 you may want to turn off OpenGL if you encounter bugs
/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/gui.py:110: Warning: invalid cast from 'GtkMenuBar' to 'GtkWindow'
  osxapp.set_menu_bar(mh.rebuild())
/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/gui.py:110: GtkWarning: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed
  osxapp.set_menu_bar(mh.rebuild())
2019-12-12 13:24:41,689 Xpra GTK2 client version 3.0-r24039 64-bit
2019-12-12 13:24:41,742  running on Mac OS X 10.12.6
2019-12-12 13:24:43,230 GStreamer version 1.14.4 for Python 2.7.16 64-bit
2019-12-12 13:24:43,503 OpenGL_accelerate module loaded
2019-12-12 13:24:43,516 Using accelerated ArrayDatatype
2019-12-12 13:24:43,952 Warning: vendor 'Intel Inc.' is greylisted,
2019-12-12 13:24:43,953  you may want to turn off OpenGL if you encounter bugs
2019-12-12 13:24:44,060 OpenGL enabled with Intel Iris OpenGL Engine
2019-12-12 13:24:44,665  keyboard settings: layout=us
2019-12-12 13:24:44,809  desktop size is 3600x1080 with 1 screen:
2019-12-12 13:24:44,809   schadenfreude.local (1270x381 mm - DPI: 72x72)
2019-12-12 13:24:44,809     monitor 2 1680x1050 at 1920x0 (592x370 mm - DPI: 72x72) workarea: 1680x1023 at 0x23
2019-12-12 13:24:44,810     monitor 3 1920x1080 (677x381 mm - DPI: 72x72) workarea: 1920x1057 at 0x23
/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/osx_tray.py:91: Warning: invalid cast from 'GtkMenuBar' to 'GtkWindow'
  self.macapp.set_menu_bar(self.menu)
/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/osx_tray.py:91: GtkWarning: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed
  self.macapp.set_menu_bar(self.menu)

Certainly not a big deal...

Change History (2)

comment:1 Changed 12 months ago by Antoine Martin

Owner: changed from Antoine Martin to alas

WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.

This one is unavoidable, it's GTK that is calling it.

You are using a GTK2 build, try the Python3 / GTK3 build.

/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/gui.py:110: Warning: invalid cast from 'GtkMenuBar' to 'GtkWindow'
osxapp.set_menu_bar(mh.rebuild())
/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/gui.py:110: GtkWarning: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed
osxapp.set_menu_bar(mh.rebuild())

Those are still present in GTK3.
I believe this is a gtk-osx "feature": we are using the API as intended, and it does do what it is supposed to do..

comment:2 Changed 11 months ago by alas

Resolution: fixed
Status: newclosed

Sure enough, when I use the 3.0.4-r24778 OSX client, the first of the warnings (WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.) disappears... and the others remain.

I'll go ahead and resolve this as fixed, since there's no "feature, not a bug" resolution option.

Note: See TracTickets for help on using tickets.