xpra icon
Bug tracker and wiki

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#2524 closed defect (fixed)

xpra client crashes using nautilus

Reported by: stdedos Owned by: stdedos
Priority: major Milestone: 4.0
Component: client Version: 4.0.x
Keywords: Cc:

Description

Nemo

Xpra-Python3-x86_64_4.0-r24581\xpra_cmd" attach ssh://user@ip/2

2019-12-22 12:30:42,113 Xpra GTK3 client version 4.0-r24581 64-bit
2019-12-22 12:30:42,117  running on Microsoft Windows 10
2019-12-22 12:30:42,642 Warning: failed to import opencv:
2019-12-22 12:30:42,643  No module named 'cv2'
2019-12-22 12:30:42,644  webcam forwarding is disabled
2019-12-22 12:30:44,741 GStreamer version 1.16.1 for Python 3.8.0 64-bit
2019-12-22 12:30:45,868 OpenGL_accelerate module loaded
2019-12-22 12:30:45,911 Using accelerated ArrayDatatype
2019-12-22 12:30:46,568 Warning: vendor 'Intel' is greylisted,
2019-12-22 12:30:46,569  you may want to turn off OpenGL if you encounter bugs
2019-12-22 12:30:46,846 OpenGL enabled with Intel(R) HD Graphics 4000
2019-12-22 12:30:47,769  keyboard settings: layout=us
2019-12-22 12:30:47,772  desktop size is 1600x900 with 1 screen:
2019-12-22 12:30:47,773   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2019-12-22 12:30:47,773     (Standard monitor types) Generic PnP Monitor (309x174 mm - DPI: 131x131)
2019-12-22 12:31:05,143 enabled remote logging
2019-12-22 12:31:05,145 Xpra GTK3 X11 server version 3.0.3-r24690 64-bit
2019-12-22 12:31:05,146  running on Linux Ubuntu 16.04 xenial
2019-12-22 12:31:05,147 Attached to ip:22
2019-12-22 12:31:05,148  (press Control-C to detach)

(xpra_cmd:14068): Pango-WARNING **: 12:35:19.448: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
Exception code=0xc0000005 flags=0x0 at 0x00007FFECA67333D. Access violation - attempting to read data at address 0x0000000009998000
2019-12-22 12:36:05,298 Warning: long timer waiting time,
2019-12-22 12:36:05,360 sound output stopping

and Nautilus crashes:

Xpra-Python3-x86_64_4.0-r24581\xpra_cmd" attach ssh://user@ip/2

2019-12-22 12:38:25,485 Xpra GTK3 client version 4.0-r24581 64-bit
2019-12-22 12:38:25,487  running on Microsoft Windows 10
2019-12-22 12:38:25,576 Warning: failed to import opencv:
2019-12-22 12:38:25,577  No module named 'cv2'
2019-12-22 12:38:25,577  webcam forwarding is disabled
2019-12-22 12:38:26,205 GStreamer version 1.16.1 for Python 3.8.0 64-bit
2019-12-22 12:38:26,546 OpenGL_accelerate module loaded
2019-12-22 12:38:26,583 Using accelerated ArrayDatatype
2019-12-22 12:38:27,103 Warning: vendor 'Intel' is greylisted,
2019-12-22 12:38:27,104  you may want to turn off OpenGL if you encounter bugs
2019-12-22 12:38:27,407 OpenGL enabled with Intel(R) HD Graphics 4000
2019-12-22 12:38:27,632  keyboard settings: layout=us
2019-12-22 12:38:27,635  desktop size is 1600x900 with 1 screen:
2019-12-22 12:38:27,636   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2019-12-22 12:38:27,636     (Standard monitor types) Generic PnP Monitor (309x174 mm - DPI: 131x131)
2019-12-22 12:38:33,614 enabled remote logging
2019-12-22 12:38:33,616 Xpra GTK3 X11 server version 3.0.3-r24690 64-bit
2019-12-22 12:38:33,618  running on Linux Ubuntu 16.04 xenial
2019-12-22 12:38:33,630 Attached to ip:22
2019-12-22 12:38:33,634  (press Control-C to detach)


(xpra_cmd:8992): Pango-WARNING **: 12:38:34.761: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
2019-12-22 12:38:34,883 sound output using 'opus' audio codec
2019-12-22 12:38:35,077 Warning: static gravity is not handled
Exception code=0xc0000005 flags=0x0 at 0x00007FFEC920333D. Access violation - attempting to read data at address 0x0000000031EBB000
2019-12-22 12:39:10,927 Warning: long timer waiting time,
2019-12-22 12:39:10,934  UI thread polling waited 10.6 seconds longer than intended (11.1 vs 0.5)
2019-12-22 12:39:11,011 sound output stopping

Change History (5)

comment:1 Changed 9 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

Can you reproduce with a more up-to-date build? Or even with 3.0.4?
Does it still occur with opengl turned off?

comment:2 Changed 9 months ago by Antoine Martin

Also, assuming that it still does crash, please run with --debug=all and post the end of output. (the last few thousand lines)

comment:3 Changed 9 months ago by stdedos

Resolution: fixed
Status: newclosed

It seems that the server update worked: I cannot replicate the issue anymore on a new xpra start.

However, I failed to upgrade my existing session:

$ xpra list
xpra for python 2.7 is not installed
 retrying with python3
Found the following xpra sessions:
/run/user/1000/xpra:
	LIVE session at :2
/run/xpra:
	LIVE session at :2
$ xpra upgrade :2
xpra for python 2.7 is not installed
 retrying with python3
WARNING: low display number: 2
 You are attempting to run the xpra server
 against a low X11 display number: ':2'.
 This is generally not what you want.
 You should probably use a higher display number
 just to avoid any confusion and this warning message.
Entering daemon mode; any further errors will be reported to:
  /run/user/1000/xpra/display-:2-$TIMESTAMP.log
$ bat /run/user/1000/xpra/display-
display-:0.log                 display-:0-$TIMESTAMP.log      display-:2.log                 display-:2-$TIMESTAMP.log      
display-:0.log.old             display-:0-$TIMESTAMP.log.old  display-:2.log.old             display-:2-$TIMESTAMP.log.old  
$ bat /run/user/1000/xpra/display-\:2
display-:2.log                 display-:2.log.old             display-:2-$TIMESTAMP.log      display-:2-$TIMESTAMP.log.old  
$ bat /run/user/1000/xpra/display-\:2-\$TIMESTAMP.log 
───────┬────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
       │ File: /run/user/1000/xpra/display-:2-$TIMESTAMP.log
───────┼────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
   1   │ 2019-12-26 16:55:54,386 created unix domain socket '/run/user/1000/xpra/sntentos-precision-t3620-2'
   2   │ 2019-12-26 16:55:54,386 created unix domain socket '/run/xpra/sntentos-precision-t3620-2'
   3   │ 2019-12-26 16:55:54,478 pointer device emulation using XTest
   4   │ 2019-12-26 16:55:54,516 serving html content from '/usr/share/xpra/www'
   5   │ 2019-12-26 16:55:54,527 xvfb pid=4874
   6   │ 2019-12-26 16:55:54,527 found previous Xpra instance
   7   │ 2019-12-26 16:56:00,413 Warning: OpenGL support check failed:
   8   │ 2019-12-26 16:56:00,413  unknown error
───────┴────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
$ env | grep -i displa
CKCON_X11_DISPLAY=:2
DISPLAY=:2

The log is from the very same xpra attach session. Xpra client seemed unaffected (I would expect e.g. that it will try to reconnect)

comment:4 Changed 9 months ago by stdedos

However, the session appeared crashed:

$ xpra list
xpra for python 2.7 is not installed
 retrying with python3
Found the following xpra sessions:
/run/user/1000/xpra:
	UNKNOWN session at :2
	LIVE session at :20
/run/xpra:
	UNKNOWN session at :2
	LIVE session at :20
Re-probing unknown sessions in: /run/xpra, /run/user/1000/xpra
xpra stop	UNKNOWN session at :2 (cleaned up)
	UNKNOWN session at :2 (cleaned up)

I cannot re-use it, because xpra start :2 --use-display fails with the same error as before. --opengl=no gives the same error again.

comment:5 Changed 9 months ago by Antoine Martin

However, I failed to upgrade my existing session:

Thanks for pointing that out, it's a bug: #2533.

Note: See TracTickets for help on using tickets.