xpra icon
Bug tracker and wiki

Opened 4 months ago

Closed 4 months ago

Last modified 3 months ago

#2562 closed task (fixed)

refactoring: don't keep server caps around

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc:

Description

Process them when we receive the hello packet then drop them.

Change History (3)

comment:1 Changed 4 months ago by Antoine Martin

Status: newassigned

Updates:

  • r25069: pass caps to all parsing methods
  • r25070: use flag to verify we have connected instead of the whole server caps
  • r25071: pass caps to do_command() method

Still TODO:

  • session info uses capabilities because the client may have disabled the feature - replace with "?" if the client feature is disabled
Last edited 4 months ago by Antoine Martin (previous) (diff)

comment:2 Changed 4 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed
  • r25111 + 25112: don't assume that the mixins are enabled
  • r25113 keep a copy of the list of packet encoders / compressors
  • r25114 move the remaining attributes we need to serverinfo mixin
  • r25115 attribute removed

comment:3 Changed 3 months ago by Antoine Martin

Caused a regression: #2599.

Note: See TracTickets for help on using tickets.