xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 5 months ago

#2581 closed defect (fixed)

Typelib file for namespace 'cairo', version '1.0' not found

Reported by: stdedos Owned by: stdedos
Priority: major Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc:

Description

On Win10:

"Xpra-Python3_4.0-r25145\xpra_cmd" shadow ssh://user@ip/0  --opengl=no --desktop-scaling=0.75 --min-speed=70 --webcam=no --speaker=off --microphone=off --pulseaudio=no

xpra main error:
Traceback (most recent call last):
  File "C:/msys32/mingw32/lib/python3.8/site-packages/gi/importer.py", line 138, in load_module
  File "C:/msys32/mingw32/lib/python3.8/site-packages/gi/module.py", line 265, in get_introspection_module
  File "C:/msys32/mingw32/lib/python3.8/site-packages/gi/module.py", line 117, in __init__
gi.RepositoryError: Typelib file for namespace 'cairo', version '1.0' not found

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/scripts/main.py", line 115, in main
  File "E:\Xpra\trunk\src/xpra/scripts/main.py", line 342, in run_mode
  File "E:\Xpra\trunk\src/xpra/scripts/main.py", line 1853, in run_remote_server
  File "E:\Xpra\trunk\src/xpra/scripts/main.py", line 1756, in make_client
  File "E:\Xpra\trunk\src/xpra/client/gtk3/client.py", line 6, in <module>
  File "C:/msys32/mingw32/lib/python3.8/site-packages/gi/importer.py", line 140, in load_module
ImportError: Typelib file for namespace 'cairo', version '1.0' not found

Change History (7)

comment:1 Changed 5 months ago by Antoine Martin

Status: newassigned

Definitely a bug. Strange that I'm not hitting it.

The missing gi bits must be found elsewhere on the system I use for testing.

Definitely caused by the changes from r25142 + r25144.

comment:2 Changed 5 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos
Status: assignednew

Well, that's very odd, I used a clean VM from Microsoft Edge Developer VMs and did not see the bug after installing r25177.
In any case, I've re-added the missing typelibs in r25178 and uploaded a new beta builds.
Does that work better for you?

comment:3 Changed 5 months ago by stdedos

Apparently, beta is missing the zip packages :/

https://www.xpra.org/beta/windows/?C=M&O=D&P=*r25*.zip*

comment:4 Changed 5 months ago by Antoine Martin

Apparently, beta is missing the zip packages :/

Ooops. Try now.

comment:5 Changed 5 months ago by stdedos

Blocked on #2588; working with Xpra-Python3-x86_64_4.0-r24762

comment:6 Changed 5 months ago by Antoine Martin

working with Xpra-Python3-x86_64_4.0-r24762

That's expected: r24762 is before this:

Definitely caused by the changes from r25142 + r25144.

comment:7 Changed 5 months ago by stdedos

Resolution: fixed
Status: newclosed

Seems that Xpra-Python3-x86_64_4.0-r25205 is working all of a sudden :/

Also, this is now fixed.

Note: See TracTickets for help on using tickets.