xpra icon
Bug tracker and wiki

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#2588 closed defect (fixed)

Error importing avcodec2 decoder (dec_avcodec2)

Reported by: stdedos Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc:

Description

Xpra-Python3-x86_64_4.0-r25205 Win 10

"Xpra-Python3-x86_64_4.0-r25205\xpra_cmd" shadow ssh://user@ip/0  --opengl=no --desktop-scaling=0.75 --min-speed=70 --webcam=no --speaker=off --microphone=off --pulseaudio=no --exit-with-client=no

2020-02-11 21:12:38,843 Xpra GTK3 client version 4.0-r25205 64-bit
2020-02-11 21:12:38,847  running on Microsoft Windows 10
2020-02-11 21:12:40,664 GStreamer version 1.16.2 for Python 3.8.1 64-bit
2020-02-11 21:12:41,343 Error importing avcodec2 decoder (dec_avcodec2)
2020-02-11 21:12:41,343  DLL load failed while importing decoder: The specified module could not be found.
2020-02-11 21:12:41,383 keyboard layout code 0x409
2020-02-11 21:12:41,383 identified as 'United States - English' : us
xpra initialization error:
 connection failed: 'NoneType' object has no attribute 'get'

I am seriously wondering what could possibly be to blame ....

I started having portable xpra / conf-on-cmd-line approach, so as to not hit any weird stuff :/

I have to downgrade all the way to Xpra-Python3-x86_64_4.0-r24762 to work :/

Attachments (1)

trac_2588-client.log (733.7 KB) - added by stdedos 7 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

Using the exact same command line (bar username / password), I'm not seeing any problems here.

Can you try with -d all?

Last edited 7 months ago by Antoine Martin (previous) (diff)

comment:2 Changed 7 months ago by stdedos

Re-downloading Xpra-Python3-x86_64_4.0-r25205 and installing https://support.microsoft.com/en-gb/help/2977003/the-latest-supported-visual-c-downloads (plink apparently needed it?) allows me to at least continue and connect to the shadow server.

The message comes regardless. However, when running with -d all I don't see the connection coming.

Attaching the full log now.

Last edited 7 months ago by stdedos (previous) (diff)

Changed 7 months ago by stdedos

Attachment: trac_2588-client.log added

comment:3 Changed 7 months ago by Antoine Martin

Owner: changed from stdedos to Antoine Martin
Status: newassigned

Error importing avcodec2 decoder (dec_avcodec2)

That's a different thing from the error that caused the connection to fail.

connection failed: 'NoneType' object has no attribute 'get'

Finally hit it. Using "paramiko" on win32 only.
This was caused by r25180 and is fixed in r25214.

You were no longer hitting it because you must have switched to plink. (judging from your log sample)

I am keeping this ticket open so I can ensure avcodec2 is linked properly (one of the MSYS2 libraries it links against probably needs rebuilding).
And as per ticket:2550#comment:1, maybe we should build our own ffmpeg to save space.

comment:4 in reply to:  3 Changed 7 months ago by stdedos

Error importing avcodec2 decoder (dec_avcodec2)

That's a different thing from the error that caused the connection to fail.

¯\_(ツ)_/¯ I didn't do anything different

connection failed: 'NoneType' object has no attribute 'get'

Finally hit it. Using "paramiko" on win32 only.
This was caused by r25180 and is fixed in r25214.

You were no longer hitting it because you must have switched to plink. (judging from your log sample)

... oops! Almost. Yes, I switched back to plink (#2549 issue of "weird" password prompt finally triggered me).
All my WinTerminal scripts are cludges, so, I forgot I didn't redirect the command (pretty similar to the old one). Here it is:

"Xpra-Python3-x86_64_4.0-r25205\xpra_cmd" shadow ssh://user@ip/0 --ssh="plink -ssh -agent" -d all \
    --opengl=no --desktop-scaling=0.75 --min-speed=70 --webcam=no --speaker=off --microphone=off --pulseaudio=no --exit-with-client=no
Last edited 7 months ago by Antoine Martin (previous) (diff)

comment:5 Changed 7 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Hit it today (ticket:2579#comment:20), turns out to be a problem with cx_Freeze not including libx265.dll with the ffmpeg decoder module.
(it picks up every other dependency - possibly from the gstreamer modules? - just not this one)
r25345 fixes that.

Updated beta builds are available.

comment:6 Changed 7 months ago by stdedos

LGTM

Note: See TracTickets for help on using tickets.