xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#2599 closed defect (fixed)

Shadow Information -> Session Information is not showing

Reported by: stdedos Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc:

Description

From the new zip r25280 build:

"Xpra-Python3-x86_64_4.0-r25280\xpra_cmd" shadow ssh://user@ip/0 --ssh="plink -ssh -agent" --opengl=no --desktop-scaling=0.75 --min-speed=70 --webcam=no --speaker=off --microphone=off --pulseaudio=no

2020-02-18 22:56:41,019 Xpra GTK3 client version 4.0-r25280 64-bit
2020-02-18 22:56:41,019  running on Microsoft Windows 10
2020-02-18 22:56:42,370 GStreamer version 1.16.2 for Python 3.8.1 64-bit
2020-02-18 22:56:42,750 keyboard layout code 0x409
2020-02-18 22:56:42,750 identified as 'United States - English' : us
2020-02-18 22:56:43,270  keyboard settings: layout=us
2020-02-18 22:56:43,278  desktop size is 1600x900 with 1 screen:
2020-02-18 22:56:43,282   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2020-02-18 22:56:43,282     (Standard monitor types) Generic PnP Monitor (309x174 mm - DPI: 131x131)
2020-02-18 22:56:43,282  downscaled to 75%, virtual screen size: 2133x1200
2020-02-18 22:56:43,286   Default (423x238 mm - DPI: 128x128) workarea: 2133x1147
2020-02-18 22:56:43,286     (Standard monitor types) Generic PnP Monitor (309x174 mm - DPI: 175x175)
2020-02-18 22:56:50,860 enabled remote logging
2020-02-18 22:56:50,868 Xpra GTK3 shadow server version 3.0.6-r25174 64-bit
2020-02-18 22:56:50,872  running on Linux Ubuntu 16.04 xenial
2020-02-18 22:56:50,872  remote desktop size is 6400x1440

(xpra_cmd:13360): Pango-WARNING **: 22:56:51.920: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
2020-02-18 22:56:52,987 UI thread is now blocked
2020-02-18 22:56:53,715 UI thread is running again, resuming
2020-02-18 22:56:58,428 server is not responding, drawing spinners over the windows
2020-02-18 22:56:58,980 server is OK again
2020-02-18 22:57:27,488 Error: failed to set clipboard data
2020-02-18 22:57:27,492  OpenClipboard: access denied
2020-02-18 22:57:27,504 Error: failed to set clipboard data
2020-02-18 22:57:27,508  OpenClipboard: access denied
2020-02-18 22:57:27,516 Error: failed to set clipboard data
2020-02-18 22:57:27,520  OpenClipboard: access denied
2020-02-18 22:57:27,532 Error: failed to set clipboard data
2020-02-18 22:57:27,532  OpenClipboard: access denied
2020-02-18 22:57:27,544 Error: failed to set clipboard data
2020-02-18 22:57:27,544  OpenClipboard: access denied
2020-02-18 22:57:27,548 Warning: cannot set clipboard value
2020-02-18 22:57:27,552  failed to set clipboard buffer
2020-02-18 22:57:35,186 Error: failed to set clipboard data
2020-02-18 22:57:35,190  OpenClipboard: access denied
2020-02-18 22:57:35,274 Error: failed to set clipboard data
2020-02-18 22:57:35,274  OpenClipboard: access denied
2020-02-18 22:57:35,286 Error: failed to set clipboard data
2020-02-18 22:57:35,286  OpenClipboard: access denied
2020-02-18 22:57:35,294 Error: failed to set clipboard data
2020-02-18 22:57:35,294  OpenClipboard: access denied
2020-02-18 22:57:35,302 Error: failed to set clipboard data
2020-02-18 22:57:35,302  OpenClipboard: access denied
2020-02-18 22:57:35,302 Warning: cannot set clipboard value
2020-02-18 22:57:35,302  failed to set clipboard buffer
2020-02-18 22:57:56,408 Error: failed to set clipboard data
2020-02-18 22:57:56,412  OpenClipboard: access denied
2020-02-18 22:57:56,416 Error: failed to set clipboard data
2020-02-18 22:57:56,416  OpenClipboard: access denied
2020-02-18 22:57:56,420 Error: failed to set clipboard data
2020-02-18 22:57:56,424  OpenClipboard: access denied
2020-02-18 22:57:56,428 Error: failed to set clipboard data
2020-02-18 22:57:56,432  OpenClipboard: access denied
2020-02-18 22:57:56,436 Error: failed to set clipboard data
2020-02-18 22:57:56,436  OpenClipboard: access denied
2020-02-18 22:57:56,440 Error: failed to set clipboard data
2020-02-18 22:57:56,448  OpenClipboard: access denied
2020-02-18 22:57:56,448 Error: failed to set clipboard data
2020-02-18 22:57:56,452  OpenClipboard: access denied
2020-02-18 22:57:56,456 Error: failed to set clipboard data
2020-02-18 22:57:56,460  OpenClipboard: access denied
2020-02-18 22:57:56,464 Error: failed to set clipboard data
2020-02-18 22:57:56,464  OpenClipboard: access denied
2020-02-18 22:57:56,468 Error: failed to set clipboard data
2020-02-18 22:57:56,472  OpenClipboard: access denied
2020-02-18 22:57:56,476 Warning: cannot set clipboard value
2020-02-18 22:57:56,480  failed to set clipboard buffer
2020-02-18 22:57:56,484 Error: failed to set clipboard data
2020-02-18 22:57:56,488  OpenClipboard: access denied
2020-02-18 22:57:56,492 Warning: cannot set clipboard value
2020-02-18 22:57:56,496  failed to set clipboard buffer
2020-02-18 23:02:23,416 server is not responding, drawing spinners over the windows
2020-02-18 23:02:23,925 server is OK again
2020-02-18 23:02:48,180 Error: failed to set clipboard data
2020-02-18 23:02:48,192  OpenClipboard: access denied
2020-02-18 23:02:48,204 Error: failed to set clipboard data
2020-02-18 23:02:48,208  OpenClipboard: access denied
2020-02-18 23:02:48,220 Error: failed to set clipboard data
2020-02-18 23:02:48,224  OpenClipboard: access denied
2020-02-18 23:02:48,360 Error: failed to set clipboard data
2020-02-18 23:02:48,364  OpenClipboard: access denied
2020-02-18 23:02:48,473 Warning: cannot set clipboard value
2020-02-18 23:02:48,473  failed to set clipboard buffer
2020-02-18 23:06:14,660 server is not responding, drawing spinners over the windows
2020-02-18 23:06:18,313 server is OK again
2020-02-18 23:06:19,725 server is not responding, drawing spinners over the windows
2020-02-18 23:06:21,855 server is OK again

(xpra_cmd:13360): Gtk-WARNING **: 23:06:23.879: Could not find the icon 'pan-end-symbolic'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases
2020-02-18 23:06:24,727 server is not responding, drawing spinners over the windows
2020-02-18 23:06:26,538 server is OK again
2020-02-18 23:06:29,036 UI thread is now blocked
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_tray_menu_base.py", line 454, in show_session_info_cb
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_tray_menu_base.py", line 315, in show_session_info
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_base.py", line 563, in show_session_info
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/session_info.py", line 226, in __init__
NameError: name 'server_version_info' is not defined
2020-02-18 23:06:29,092 UI thread is running again, resuming
2020-02-18 23:06:53,685 UI thread is now blocked
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_tray_menu_base.py", line 454, in show_session_info_cb
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_tray_menu_base.py", line 315, in show_session_info
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_base.py", line 563, in show_session_info
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/session_info.py", line 226, in __init__
NameError: name 'server_version_info' is not defined
2020-02-18 23:06:54,049 UI thread is running again, resuming

Attachments (1)

xpra_not-thicc-anymoar_2020-02-20_20-38-34.png (46.0 KB) - added by stdedos 3 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 3 months ago by stdedos

Also, a lot of OpenClipboard: access denieds.

  • Is it a real regression?
  • Can / Should they somehow be more silent if they are not happening all the time? :/
Last edited 3 months ago by Antoine Martin (previous) (diff)

comment:2 Changed 3 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

NameError: name 'server_version_info' is not defined

Fixed in r25299, still not sure how I missed that when testing the session info changes. (#2562)

Also, a lot of OpenClipboard: access denieds.
Is it a real regression?

Probably not: How can I fix “Cannot open clipboard: Access Denied” errors?, we retry until it works.
But it could be, so r25301 improves the locking code and makes -d clipboard more interesting.

Can / Should? they somehow be more silent if they are not happening all the time? :/

It is best to keep them visible for now:

  • we might find out why / when this happens and fix it
  • users will be able to see that there is a failure to read from / write to the clipboard
Last edited 3 months ago by Antoine Martin (previous) (diff)

comment:3 in reply to:  2 Changed 3 months ago by stdedos

I kinda feel there may be something:

On my gnome-terminal display, I cannot copy-paste from local to remote. Copying remote-to-local updates come (that's how I got the backtrace for ticket:2034#comment:4), but I cannot e.g. copy a URL locally and paste it remotely.

The most weird thing is that, in the gnome-terminal display, I get no error messages regarding clipboard.

Since I cannot open session details to indeed verify that I haven't disabled it, here is a grep for you:

$ xpra info 2 | grep clipboard
xpra for python 2.7 is not installed
 retrying with python3
client.clipboard.contents-slice-fix=True
client.clipboard.enabled=True
client.clipboard.greedy=True
client.clipboard.notifications=True
client.clipboard.preferred-targets=('UTF8_STRING', 'TEXT', 'STRING', 'text/plain')
client.clipboard.selections=('CLIPBOARD',)
client.clipboard.set-enabled=True
client.clipboard.want-targets=False
client.connection.input.count.clipboard-contents=1
client.connection.input.count.clipboard-enable-selections=1
client.connection.input.count.clipboard-token=75
client.connection.input.count.set-clipboard-enabled=1
client.connection.output.count.clipboard-pending-requests=82
client.connection.output.count.clipboard-request=59
client.connection.output.count.clipboard-token=74
client.connection.receive_alias.33=clipboard-enable-selections
client.connection.receive_alias.34=set-clipboard-enabled
client.connection.receive_alias.35=clipboard-contents
client.connection.receive_alias.36=clipboard-request
client.connection.receive_alias.53=clipboard-contents-none
client.connection.receive_alias.55=clipboard-loop-uuids
client.connection.receive_alias.61=clipboard-pending-requests
client.connection.receive_alias.62=clipboard-token
client.connection.send_alias.clipboard-contents=47
client.connection.send_alias.clipboard-contents-none=48
client.connection.send_alias.clipboard-enable-selections=50
client.connection.send_alias.clipboard-pending-requests=49
client.connection.send_alias.clipboard-request=46
client.connection.send_alias.clipboard-token=45
client.connection.send_alias.set-clipboard-enabled=44
clipboard.CLIPBOARD.blocked_owner_change=False
clipboard.CLIPBOARD.enabled=True
clipboard.CLIPBOARD.event.get_contents=0
clipboard.CLIPBOARD.event.got_token=52
clipboard.CLIPBOARD.event.request_contents=0
clipboard.CLIPBOARD.event.selection_clear=0
clipboard.CLIPBOARD.event.selection_get=0
clipboard.CLIPBOARD.event.selection_request=0
clipboard.CLIPBOARD.event.sent_token=0
clipboard.CLIPBOARD.greedy_client=True
clipboard.CLIPBOARD.have_token=True
clipboard.CLIPBOARD.last-targets=()
clipboard.CLIPBOARD.loop-uuid=Xpra-Clipboard-Loop-Detection:384699b223174de082bfc5af73be9557
clipboard.CLIPBOARD.preferred-targets=('UTF8_STRING', 'TEXT', 'STRING', 'text/plain')
clipboard.PRIMARY.blocked_owner_change=False
clipboard.PRIMARY.enabled=True
clipboard.PRIMARY.event.get_contents=0
clipboard.PRIMARY.event.got_token=13
clipboard.PRIMARY.event.request_contents=0
clipboard.PRIMARY.event.selection_clear=0
clipboard.PRIMARY.event.selection_get=0
clipboard.PRIMARY.event.selection_request=0
clipboard.PRIMARY.event.sent_token=0
clipboard.PRIMARY.greedy_client=True
clipboard.PRIMARY.have_token=False
clipboard.PRIMARY.last-targets=()
clipboard.PRIMARY.loop-uuid=Xpra-Clipboard-Loop-Detection:897bae4763e643da96b4c74291792d9c
clipboard.PRIMARY.preferred-targets=('UTF8_STRING', 'TEXT', 'STRING', 'text/plain')
clipboard.SECONDARY.blocked_owner_change=False
clipboard.SECONDARY.enabled=True
clipboard.SECONDARY.event.get_contents=0
clipboard.SECONDARY.event.got_token=0
clipboard.SECONDARY.event.request_contents=0
clipboard.SECONDARY.event.selection_clear=0
clipboard.SECONDARY.event.selection_get=0
clipboard.SECONDARY.event.selection_request=0
clipboard.SECONDARY.event.sent_token=0
clipboard.SECONDARY.greedy_client=True
clipboard.SECONDARY.have_token=False
clipboard.SECONDARY.last-targets=()
clipboard.SECONDARY.loop-uuid=Xpra-Clipboard-Loop-Detection:61e2ddbf7cea4ad1b22539492e124b0e
clipboard.SECONDARY.preferred-targets=('UTF8_STRING', 'TEXT', 'STRING', 'text/plain')
clipboard.can-receive=True
clipboard.can-send=True
clipboard.filters=()
clipboard.max_recv_size=-1
clipboard.max_send_size=-1
clipboard.max_size=16777216
clipboard.pending=()
clipboard.requests=94
clipboard.type=X11Clipboard
clipboard.want_targets=False
features.clipboard=True
features.clipboard-direction=both
features.clipboard.contents-slice-fix=True
features.clipboard.enable-selections=True
features.clipboard.loop-uuids.CLIPBOARD=Xpra-Clipboard-Loop-Detection:384699b223174de082bfc5af73be9557
features.clipboard.loop-uuids.PRIMARY=Xpra-Clipboard-Loop-Detection:897bae4763e643da96b4c74291792d9c
features.clipboard.loop-uuids.SECONDARY=Xpra-Clipboard-Loop-Detection:61e2ddbf7cea4ad1b22539492e124b0e
features.clipboard.preferred-targets=('UTF8_STRING', 'TEXT', 'STRING', 'text/plain', 'image/png')
features.clipboards=('CLIPBOARD', 'PRIMARY', 'SECONDARY')

Last edited 3 months ago by stdedos (previous) (diff)

comment:4 Changed 3 months ago by Antoine Martin

On my gnome-terminal display, I cannot copy-paste towards the gnome-terminal.

I don't understand: from where to where? Local to remote? Isn't local win10?

From gnome-terminal, updates come (that's how I got the backtrace for ticket:2034#comment:4), but I cannot e.g. copy a URL from my Windows PC and paste it to the terminal.

Try r25314 (clipboard fix for plain text with win32 clients) or later. Builds are available, even in ZIP format.

If you still have problems, please create a new ticket. This is unrelated to session info.

comment:5 Changed 3 months ago by stdedos

Nope :/

"Xpra-Python3-x86_64_4.0-r25314\xpra_cmd" shadow ssh://user@ip/0 --ssh="plink -ssh -agent" --opengl=no --desktop-scaling=0.75 --min-speed=70 --webcam=no --speaker=off --microphone=off --pulseaudio=no --exit-with-client=no --encoding=h264

2020-02-20 20:40:10,610 Xpra GTK3 client version 4.0-r25314 64-bit
2020-02-20 20:40:10,614  running on Microsoft Windows 10
2020-02-20 20:40:12,615 GStreamer version 1.16.2 for Python 3.8.1 64-bit
2020-02-20 20:40:13,217 keyboard layout code 0x409
2020-02-20 20:40:13,217 identified as 'United States - English' : us
2020-02-20 20:40:13,829  keyboard settings: layout=us
2020-02-20 20:40:13,829  desktop size is 1600x900 with 1 screen:
2020-02-20 20:40:13,845   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2020-02-20 20:40:13,845     (Standard monitor types) Generic PnP Monitor (309x174 mm - DPI: 131x131)
2020-02-20 20:40:13,845  downscaled to 75%, virtual screen size: 2133x1200
2020-02-20 20:40:13,845   Default (423x238 mm - DPI: 128x128) workarea: 2133x1147
2020-02-20 20:40:13,845     (Standard monitor types) Generic PnP Monitor (309x174 mm - DPI: 175x175)
2020-02-20 20:40:52,132 enabled remote logging
2020-02-20 20:40:52,132 server is using auto encoding instead of h264
2020-02-20 20:40:52,132 Xpra GTK3 shadow server version 3.0.6-r25174 64-bit
2020-02-20 20:40:52,148  running on Linux Ubuntu 16.04 xenial
2020-02-20 20:40:52,148  remote desktop size is 6400x1440

(xpra_cmd:8640): Pango-WARNING **: 20:40:52.973: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
2020-02-20 20:40:54,017 UI thread is now blocked
2020-02-20 20:40:54,156 UI thread is running again, resuming
2020-02-20 20:41:49,067 Warning: cannot set clipboard value
2020-02-20 20:41:49,067  failed to set clipboard buffer
2020-02-20 20:42:30,018 Warning: cannot set clipboard value
2020-02-20 20:42:30,018  failed to set clipboard buffer
2020-02-20 20:43:54,707 Warning: cannot set clipboard value
2020-02-20 20:43:54,707  failed to set clipboard buffer
2020-02-20 20:48:04,681 server is not responding, drawing spinners over the windows
2020-02-20 20:48:05,711 server is OK again
2020-02-20 20:48:14,791 server is not responding, drawing spinners over the windows
2020-02-20 20:48:15,050 server is OK again
2020-02-20 20:48:19,828 server is not responding, drawing spinners over the windows
2020-02-20 20:48:22,223 server is OK again
2020-02-20 20:48:50,111 server is not responding, drawing spinners over the windows
2020-02-20 20:48:51,409 server is OK again
2020-02-20 20:49:15,157 server is not responding, drawing spinners over the windows
2020-02-20 20:49:15,413 server is OK again
2020-02-20 20:49:35,193 server is not responding, drawing spinners over the windows
2020-02-20 20:49:36,477 server is OK again
2020-02-20 20:50:00,310 server is not responding, drawing spinners over the windows
2020-02-20 20:50:01,332 server is OK again
2020-02-20 20:50:25,360 server is not responding, drawing spinners over the windows
2020-02-20 20:50:26,422 server is OK again

(xpra_cmd:8640): Gtk-WARNING **: 20:50:48.109: Could not find the icon 'pan-end-symbolic'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_tray_menu_base.py", line 454, in show_session_info_cb
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_tray_menu_base.py", line 315, in show_session_info
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_base.py", line 563, in show_session_info
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/session_info.py", line 228, in __init__
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/session_info.py", line 227, in sgllabel
TypeError: 'NoneType' object is not iterable
2020-02-20 20:51:16,105 Error: failed to get clipboard data
2020-02-20 20:51:16,105  OpenClipboard: too many failed attemps, giving up

comment:6 Changed 3 months ago by stdedos

Splitted clipboard to #2603

also: Good job on client packaging!!! What did you do? Patchsets don't seem to have anything packaging/dependencies-related


comment:7 Changed 3 months ago by Antoine Martin

Nope :/

Ah, fixed in r25316. (builds may take a few days to land in beta)

also: Good job on client packaging!!! What did you do? Patchsets don't seem to have anything packaging/dependencies-related

Nothing whatsoever.
I think that this may be because the win10 VM I normally use for v4 builds is hosed (MSYS2 dependency problem) so I've used the win7 VM I normally use for v3 builds. (and not updating it for now)

FYI: those latest builds also don't have nvenc support builtin, which is why they're quite a bit smaller.

Note: See TracTickets for help on using tickets.