xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

#262 closed defect (fixed)

disappearing tooltips

Reported by: onlyjob Owned by: Antoine Martin
Priority: minor Milestone: 0.9
Component: core Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

I've noticed an interesting problem with tooltips in filelight:
When mouse is over the folders there is a semi-transparent rectangle tooltip with folder name, size and number of files.

If filelight is running within Xpra session there are number of problems with popup tooltips:

  • Soon enough they are stop displaying completely (bug).
  • They are often incompletely removed/drawn (another manifestation of #252 ?)
  • They are not transparent (feature test ?)

When those popups are displayed the following appears in server log:

not found transient_for=<gtk.gdk.Window object at 0x7ffca2bb2d70 (GdkWindow at 0x7ffca2ba46c0)>, xid=77594628
not found transient_for=<gtk.gdk.Window object at 0x7ffca2bb2d70 (GdkWindow at 0x7ffca2ba46c0)>, xid=77594628
not found transient_for=<gtk.gdk.Window object at 0x7ffca2bb2d70 (GdkWindow at 0x7ffca2ba46c0)>, xid=77594628
not found transient_for=<gtk.gdk.Window object at 0x7ffca2bb2d70 (GdkWindow at 0x7ffca2ba46c0)>, xid=77594628
not found transient_for=<gtk.gdk.Window object at 0x7ffca2bb2d70 (GdkWindow at 0x7ffca2ba46c0)>, xid=77594628

Just before those tooltips disappear completely the following appears in log (and the above log records are stop appearing):

the window <OverrideRedirectWindowModel object at 0x1acec30 (wimpiggy+window+OverrideRedirectWindowModel at 0x3bc4b40)> is not composited!?
the window <OverrideRedirectWindowModel object at 0x1acec30 (wimpiggy+window+OverrideRedirectWindowModel at 0x3bc4b40)> is not composited!?
the window <OverrideRedirectWindowModel object at 0x1acec30 (wimpiggy+window+OverrideRedirectWindowModel at 0x3bc4b40)> is not composited!?

I'm creating its own ticket for this issue as it is not related to #258.

Change History (5)

comment:1 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Owner: set to Antoine Martin
Status: newassigned

Confirmed

The not found transient_for= messages should not occur, but they be harmless when they do. It only means that the tooltips will not have this "transient-for" property set. Here's what the docs say:

The set_transient_for() method indicates to the window manager that the window is a transient dialog associated with the application window leader. This allows the window manager to do things like center the window on leader and keep the window above leader. See the gtk.Window.set_transient_for() method if you're using a gtk.Window or gtk.Dialog.

Strange thing is that when I tried to find the parent window by using its xid with xlsclients -l, it wasn't there.

Another thing that is a little odd is that you can have more than one tooltip shown at a time, and it looks like the app does not really expect that.
I think it's something to do with focus/raising other windows.

The other message, the the window ... is not composited!? can happen if the window got destroyed before we process damage for it. It's a little odd to see this when I'm pretty sure there wasn't any batching going on.

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 7 years ago by Antoine Martin

See also #310

comment:3 Changed 7 years ago by Antoine Martin

Looks fixed to me? Can I close?

Moving the tooltip resize/move issue to #319

(transparency is scheduled for later: #279)

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 7 years ago by onlyjob

As of r3118 tooltips no longer disappear so I believe this bug can be closed. Thanks.

comment:5 Changed 7 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.