xpra icon
Bug tracker and wiki

Opened 6 months ago

Closed 6 months ago

#2661 closed defect (fixed)

xpra shadow client barfing way too soon

Reported by: stdedos Owned by: stdedos
Priority: critical Milestone: 4.0
Component: server Version: 3.0.x
Keywords: Cc:

Description (last modified by stdedos)

I don't want to disappoint you even more today ...

"Xpra-Python3-x86_64_4.0-r25697\xpra_cmd" shadow ssh://user@ip/0 --ssh="plink -ssh -agent" --opengl=no --desktop-scaling=0.75 --min-speed=70 --webcam=no --speaker=off --microphone=off --pulseaudio=no

2020-03-20 17:53:33,287 Xpra GTK3 client version 4.0-r25697 64-bit
2020-03-20 17:53:33,289  running on Microsoft Windows 10
2020-03-20 17:53:34,180 GStreamer version 1.16.2 for Python 3.8.2 64-bit
2020-03-20 17:53:34,462 keyboard layout code 0x409
2020-03-20 17:53:34,463 identified as 'United States - English' : us
2020-03-20 17:53:34,877  keyboard settings: layout=us
2020-03-20 17:53:34,879  desktop size is 1600x900 with 1 screen:
2020-03-20 17:53:34,881   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2020-03-20 17:53:34,882     Generic PnP Monitor (309x174 mm - DPI: 131x131)
2020-03-20 17:53:34,883  downscaled to 75%, virtual screen size: 2133x1200
2020-03-20 17:53:34,884   Default (423x238 mm - DPI: 128x128) workarea: 2133x1147
2020-03-20 17:53:34,885     Generic PnP Monitor (309x174 mm - DPI: 175x175)
2020-03-20 17:53:39,822 Error: failed to receive anything, not an xpra server?
2020-03-20 17:53:39,826   could also be the wrong protocol, username, password or port
2020-03-20 17:53:39,827   or the session was not found
2020-03-20 17:53:39,829 Connection lost

2020-03-20 12:24:09,100 Warning: remote clipboard request timed out
2020-03-20 12:24:09,101  request id 0, selection=CLIPBOARD, target=TARGETS
2020-03-20 12:24:09,111 shadow server: setting default keymap translation
2020-03-20 12:24:09,126  client root window size is 4693x1441
2020-03-20 12:24:09,202 client   1 @25.624 Xpra GTK3 shadow server version 3.0.7-r25627 64-bit
2020-03-20 12:24:09,233 client   1 @25.626  running on Linux Ubuntu 16.04 xenial
2020-03-20 12:24:09,233 client   1 @25.628  remote desktop size is 6400x1440
2020-03-20 12:24:10,660 Warning: remote clipboard request timed out
2020-03-20 12:24:10,660  request id 1, selection=CLIPBOARD, target=TARGETS
2020-03-20 12:24:11,123 client   1 @27.544 UI thread is now blocked
2020-03-20 12:24:11,145 Warning: request id 1 not found
2020-03-20 12:24:11,145  timed out already?
2020-03-20 12:24:11,260 Warning: not adding duplicate printer 'OneNote'
2020-03-20 12:24:11,261 Warning: not adding duplicate printer 'Send To OneNote 16'
2020-03-20 12:24:11,261 Warning: not adding duplicate printer 'Microsoft Print to PDF'
2020-03-20 12:24:11,262 client   1 @27.678 UI thread is running again, resuming
2020-03-20 12:25:03,024 Warning: PRIMARY selection request for 'UTF8_STRING' timed out
2020-03-20 12:25:03,025  request 2 at time=0
2020-03-20 12:25:16,007 client   1 @31.194 unknown string message: 0xc0cc / 0x1 / 0x1
2020-03-20 12:25:16,161 client   1 @32.302 unknown string message: 0xc0cc / 0x2 / 0x0
2020-03-20 12:25:17,660 client   1 @34.082 unknown string message: 0xc0cc / 0x1 / 0x1
2020-03-20 12:25:18,585 client   1 @34.484 unknown string message: 0xc0cc / 0x2 / 0x0
2020-03-20 12:25:36,387 client   1 @50.873 window-close event on desktop or shadow window, disconnecting
2020-03-20 12:25:36,643 xpra client 1 disconnected.
2020-03-20 12:25:36,688 Last client has disconnected, terminating
xpra for python 2.7 is not installed
 retrying with python3
2020-03-20 12:25:38,170 removing socket '/run/user/1000/xpra/user-precision-t3620-0'
2020-03-20 12:25:38,170 removing socket '/run/xpra/user-precision-t3620-0'
xpra for python 2.7 is not installed
 retrying with python3
xpra initialization error:
 cannot find live server for display :0

3.0.7 release works

Attachments (1)

_usr_bin_xpra.1000.crash (117.6 KB) - added by stdedos 6 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

3.0.7 release works

Is this a client or server problem?

Changed 6 months ago by stdedos

Attachment: _usr_bin_xpra.1000.crash added

comment:2 Changed 6 months ago by stdedos

Seems like a server issue.

Note that the client log is fully copy-pasted on the description.
I only truncated server's for convenience

Last edited 6 months ago by stdedos (previous) (diff)

comment:3 Changed 6 months ago by stdedos

Description: modified (diff)
Owner: changed from stdedos to Antoine Martin

comment:4 Changed 6 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

The "crash" report contains just this:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/xpra/x11/server.py", line 909, in _process_map_window
    assert not window.is_OR()
AssertionError

And it's not really a crash, that's just Ubuntu being tiresome.
r25703 converts this into a warning.

Your log shows Last client has disconnected, terminating and then more messages, which is odd. Nothing should be happening after it terminates.

In any case, I am unable to reproduce this with the latest 3.0.8 or 4.0-RC builds.
I even tried removing python2-xpra to be running with python3 only, no difference. I get a shadow window, and the shadow server terminates when I close it.
What am I missing?

comment:5 Changed 6 months ago by stdedos

Replying to Antoine Martin:

And it's not really a crash, that's just Ubuntu being tiresome.

😂


Your log shows Last client has disconnected, terminating and then more messages, which is odd. Nothing should be happening after it terminates.

I didn't terminate it :/ and I don't think client generated a core

And apart from the client cores I've been sending you (which have raised nowadays), business as usual

In any case, I am unable to reproduce this with the latest 3.0.8 or 4.0-RC builds.
I even tried removing python2-xpra to be running with python3 only, no difference. I get a shadow window, and the shadow server terminates when I close it.
What am I missing?

I don't know :/ I jumped the gun to install it manually (wget+dpkg-i), but I had to roll back equally quickly.

comment:6 Changed 6 months ago by Antoine Martin

I don't know :/ I jumped the gun to install it manually (wget+dpkg-i), but I had to roll back equally quickly.

Probably because of r25706, prevented server from starting in 3.0.8-RC builds! (fixed now)

comment:7 in reply to:  4 Changed 6 months ago by stdedos

Replying to Antoine Martin:

The "crash" report contains just this:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/xpra/x11/server.py", line 909, in _process_map_window
    assert not window.is_OR()
AssertionError

I am wondering: Isn't it a "not safe" idea to depend on asserts, given the warning here https://docs.python.org/3/reference/simple_stmts.html#assert ?

Or have you overwritten the definition?

And it's not really a crash, that's just Ubuntu being tiresome.

A penny for your thoughts: "just Ubuntu being tiresome"

comment:8 Changed 6 months ago by Antoine Martin

Isn't it a "not safe" idea to depend on asserts...

No, as per the docs: In the current implementation, the built-in variable debug is True under normal circumstances
This is standard.

A penny for your thoughts: "just Ubuntu being tiresome"

I try not to swear on public forums. ;)

comment:9 Changed 6 months ago by stdedos

Resolution: fixed
Status: newclosed

Verified as working

Note: See TracTickets for help on using tickets.