xpra icon
Bug tracker and wiki

Changes between Initial Version and Version 1 of Ticket #2672


Ignore:
Timestamp:
03/24/20 07:00:01 (6 months ago)
Author:
Antoine Martin
Comment:

Ah. That's because the 4.0 builds are supposed to require 10.14 or later IIRC, but I forgot to bump the LSMinimumSystemVersion, which would have given you a nice warning message instead of failing with symbol errors.

The question now is, do I:

  • bump the requirements,
  • rebuild everything with 10.12 as minimum requirements instead

I think I will attempt (2) after making a backup. This is going to take time..

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #2672

    • Property Status changed from new to assigned
  • Ticket #2672 – Description

    initial v1  
    1 I'm not sure if the library errors are being caused by continuing to use 10.12 (are the 4.0 clients for OSX expecting libraries from 10.14?), or if it is because I installed the .dmg in ~/Downloads/Xpra-Python3-x86_64-4.0-r25729 (so I can have multiple versions installed... I then cd into the MacOS directory of each install and manually run {{{./Xpra attach}}} - which used to work)... or if there is a genuine issue with the libraries.
     1I'm not sure if the library errors are being caused by continuing to use 10.12 (are the 4.0 clients for OSX expecting libraries from 10.14?), or if it is because I installed the .dmg in `~/Downloads/Xpra-Python3-x86_64-4.0-r25729` (so I can have multiple versions installed... I then cd into the MacOS directory of each install and manually run {{{./Xpra attach}}} - which used to work)... or if there is a genuine issue with the libraries.
    22
    33Obviously (mostly), I downloaded the Xpra-Python3-x86_64-4.0-r25729.dmg build from your beta repo.