xpra icon
Bug tracker and wiki

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#2695 closed defect (duplicate)

(Xpra:38892): Gtk-CRITICAL

Reported by: Jeffrey Rice Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: server Version: 3.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Hello,
It appears with the release today (xpra v3.0.8-r25879) I've started getting an error:

(Xpra:37551): Gtk-CRITICAL **: 19:42:28.298: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed

I'm running Ubuntu 16.04, and everything was fine until today. On the client side, I'm running xpra v3.0.8-r25796 under OsX.

Here's all the output on the client side:

2020-03-31 20:05:42,820  running on Mac OS X 10.15.3
2020-03-31 20:05:43,887 GStreamer version 1.16.2 for Python 3.8.2 64-bit
2020-03-31 20:05:44,126 OpenGL_accelerate module loaded
2020-03-31 20:05:44,151 Using accelerated ArrayDatatype
/Applications/Xpra.app/Contents/Resources/lib/python/numpy/ma/core.py:4466: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if self.shape is ():
/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/gl/gtk3/nativegl_client_window.py:13: Warning: g_object_get_qdata: assertion 'G_IS_OBJECT (object)' failed
  return GLContext().check_support(force_enable)  #pylint: disable=not-callable
/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/gl/gtk3/nativegl_client_window.py:13: Warning: g_object_set_qdata_full: assertion 'G_IS_OBJECT (object)' failed
  return GLContext().check_support(force_enable)  #pylint: disable=not-callable
/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/gl/gtk3/nativegl_client_window.py:13: Warning: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
  return GLContext().check_support(force_enable)  #pylint: disable=not-callable
2020-03-31 20:05:46,614 OpenGL enabled with AMD Radeon Pro 450 OpenGL Engine
2020-03-31 20:05:51,826 Connected (version 2.0, client OpenSSH_7.6p1)
2020-03-31 20:05:52,574 loaded RSA private key from 'XXXXl'
2020-03-31 20:05:52,909 Authentication (publickey) successful!
2020-03-31 20:06:09,206  keyboard settings: layout=us
2020-03-31 20:06:09,207 Warning: invalid screen size 8532x9615mm
2020-03-31 20:06:09,207  using 330x206 mm
2020-03-31 20:06:09,213  desktop size is 1680x1050 with 1 screen:
2020-03-31 20:06:09,213   pacific-5.local (330x206 mm - DPI: 129x129) workarea: 1680x947 at 0x23
2020-03-31 20:06:09,213     monitor 2
/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/osx_tray.py:91: Warning: invalid cast from 'GtkMenuBar' to 'GtkWindow'
  self.macapp.set_menu_bar(self.menu)

(Xpra:38892): Gtk-CRITICAL **: 20:06:09.288: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed
2020-03-31 20:06:09,364 Error: failed to receive anything, not an xpra server?
2020-03-31 20:06:09,364   could also be the wrong protocol, username, password or port
2020-03-31 20:06:09,364   or the session was not found
2020-03-31 20:06:09,364 Connection lost

Change History (2)

comment:1 Changed 8 months ago by Antoine Martin

Description: modified (diff)
Resolution: duplicate
Status: newclosed

(Xpra:37551): Gtk-CRITICAL **: 19:42:28.298: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed

This one is not new.

Error: failed to receive anything, not an xpra server?

This is the real problem.

I assume that you're connecting via ssh?

In which case this bug is a duplicate of #2693.
Just update your server package again and you should be OK.

There are also updated macos builds, but those won't make a difference unless you use macos as a shadow server via ssh.

comment:2 Changed 8 months ago by Antoine Martin

Milestone: 3.14.0
Note: See TracTickets for help on using tickets.