xpra icon
Bug tracker and wiki

Changes between Initial Version and Version 2 of Ticket #2715


Ignore:
Timestamp:
04/07/20 11:26:46 (3 months ago)
Author:
Antoine Martin
Comment:

Just like #2713, I assume:

  • window manager is 'i3'
  • connection via ssh
  • OpenGL enabled with Mesa DRI Intel(R) UHD Graphics 620 (Kabylake GT2)

Questions:

  • does the problem go away if you start your server with python2 /usr/bin/xpra instead of the default python3?
  • same with the client (switch to python2)
  • have you tried disabling opengl, clipboard in the client?
  • maybe try the ibus workaround from #2359: start xpra with --input-method=ibus then run ibus-daemon --xim -v in the session

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #2715

    • Property Owner changed from Antoine Martin to jonathan
    • Property Component changed from android to client
  • Ticket #2715 – Description

    initial v2  
    55I upgraded to xpra 3.0.8-r25889 from 2.1.3 on Ubuntu 18.04 with i3-gnome, and the system tray icon disappeared. Antoine Martin helped fix so that the tray icon reappeared. But I have to click and hold to be able to manipulate it. Before the upgrade I could just click and the menu would stay open until i selected something or pressed Esc.
    66
    7 I also noticed that there are issues using clicks in Eclipse, running on a Debian server with the same version of xpra. Before the upgrade clicks worked (see #2713 for more details on the upgrade). At first clicks in Eclipse work, but then there are issues. Double click to open files in the file panel does not work. To right click I have to press and hold to see the menu, that appears after a little while. When the clicks fail I see a clipboard icon on the Xpra tray menu. Launching xpra with `XPRA_CLIPBOARD_NOTIFY=0 xpra attach ...` as suggested in comment https://www.xpra.org/trac/ticket/2713#comment:21 does not help. Another suggestion in the same comment refers to ibus issues, but I do not have ibus installed. Clicks so far seem to work fine in p4v that is running in the same xpra session.
     7I also noticed that there are issues using clicks in Eclipse, running on a Debian server with the same version of xpra. Before the upgrade clicks worked (see #2713 for more details on the upgrade). At first clicks in Eclipse work, but then there are issues. Double click to open files in the file panel does not work. To right click I have to press and hold to see the menu, that appears after a little while. When the clicks fail I see a clipboard icon on the Xpra tray menu. Launching xpra with `XPRA_CLIPBOARD_NOTIFY=0 xpra attach ...` as suggested in comment ticket:2713#comment:21 does not help. Another suggestion in the same comment refers to ibus issues, but I do not have ibus installed. Clicks so far seem to work fine in p4v that is running in the same xpra session.
    88
    99I get warnings from xpra on the client:
     
    1818Something is interpreting normal clicks as clipboard requests.
    1919
    20 This regression was triggered by something that changed between xpra version 2.1.3 that is default on Ubuntu 18.03 and version 3.0.8.
     20This regression was triggered by something that changed between xpra version 2.1.3 that is default on Ubuntu 18.04 and version 3.0.8.