xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 7 weeks ago

Last modified 7 weeks ago

#2743 closed enhancement (fixed)

client to listen on local sockets

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 4.1
Component: client Version: 3.0.x
Keywords: Cc:

Description

Add local unix domain sockets and named pipes to #2406.

Those sockets will need a different identifier than the display.. not sure what. PID?

Change History (4)

comment:1 Changed 5 months ago by Antoine Martin

Milestone: 4.04.1
Status: newassigned

See also #2742, #2744

comment:2 Changed 7 weeks ago by Antoine Martin

Mostly done in r27047.

Added more info in r27048.

Still TODO macos and win32 support: just socket paths?

comment:3 Changed 7 weeks ago by Antoine Martin

Updates:

  • r27049 name-pipe fix
  • r27050 answer id requests so we can ignore client sockets in the mdns session gui
  • r27051 win32 fix
  • r27053 + r27055 macos fix
  • r27054 macos: fix subcommands (ie: list)

Remaining issues:

  • pids look like display numbers and could be interpreted as such if any of the client directories are mistaken for a server socket directory
  • win32 shadow servers fail to create named-pipe listener (new? caused by r27049?)

comment:4 Changed 7 weeks ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Fixed:


Examples:

  • list clients (to be improved in #2856):
    xpra list --socket-dirs=$XDG_RUNTIME_DIR/xpra/clients/
    
  • if there's only one, this will work:
    xpra info --socket-dirs=$XDG_RUNTIME_DIR/xpra/clients/
    
  • enable keyboard debug:
    xpra control socket:///$XDG_RUNTIME_DIR/xpra/clients/localhost.localdomain-131651 debug enable keyboard
    

etc..

Last edited 7 weeks ago by Antoine Martin (previous) (diff)
Note: See TracTickets for help on using tickets.