xpra icon
Bug tracker and wiki

Opened 2 months ago

Closed 2 months ago

#2780 closed defect (duplicate)

Seeing a traceback about no csc module found with 4.0.1-r26379 client & server

Reported by: alas Owned by: Antoine Martin
Priority: minor Milestone: 4.1
Component: client Version: 4.0.x
Keywords: Cc:

Description

Starting a Fedora 31 v4.0.1-r26379 server with the Xpra-Python3-x86_64_Setup_4.0.1-r26379.exe client (on Windows 7 with NVIDIA video card) ... over a vpn, I'm often seeing my OpenGL test timeout and connecting without OpenGL.

I have found that disconnecting and then reconnecting will often be enough for the OpenGL probe to succeed (I mention because the tracebacks happened in one of those reconnected sessions, and I don't know if the latency indicated might be causing some kind of OpenGL related issue?).

Connecting with OpenGL enabled, I simply ran a chromium-browser app and opened to Google Docs, then left the browser session idle for a while (15 minutes?) while doing other things.

I soon saw the following traceback, both client side and in the server logs (not sure the origin) - though the session didn't show any problems (other than when scrolling, when the fragmentation of the image became downright psychedelic at times).

I shold also mention I was regularly getting notifications of network issues and clicking the popup option to reduce bandwidth limits.

Traceback (most recent call last):
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/mixins/window_manager.py", line 1407, in _draw_thread_loop
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/mixins/window_manager.py", line 1475, in _do_draw
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/client_window_base.py", line 697, in draw_region
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/window_backing_base.py", line 692, in draw_region
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/window_backing_base.py", line 588, in paint_with_video_decoder
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/window_backing_base.py", line 619, in do_video_paint
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/window_backing_base.py", line 495, in make_csc
Exception: no csc module found for wid 3 GBRP(2x24) to BGRA or BGRX or RGBA or RGBX or BGR or RGB(2x24) in {'RGB': {'BGR': [s
wscale(RGB to BGR)], 'XRGB': [swscale(RGB to XRGB)], 'BGRX': [swscale(RGB to BGRX)], 'RGBX': [swscale(RGB to RGBX)], 'XBGR':
[swscale(RGB to XBGR)], 'YUV420P': [swscale(RGB to YUV420P)], 'YUV422P': [swscale(RGB to YUV422P)], 'YUV444P': [swscale(RGB t
o YUV444P)], 'GBRP': [swscale(RGB to GBRP)]}, 'BGR': {'RGB': [swscale(BGR to RGB)], 'XRGB': [swscale(BGR to XRGB)], 'BGRX': [
swscale(BGR to BGRX)], 'RGBX': [swscale(BGR to RGBX)], 'XBGR': [swscale(BGR to XBGR)], 'YUV420P': [swscale(BGR to YUV420P)],
'YUV422P': [swscale(BGR to YUV422P)], 'YUV444P': [swscale(BGR to YUV444P)], 'GBRP': [swscale(BGR to GBRP)]}, 'XRGB': {'RGB':
[swscale(XRGB to RGB)], 'BGR': [swscale(XRGB to BGR)], 'BGRX': [swscale(XRGB to BGRX)], 'RGBX': [swscale(XRGB to RGBX)], 'XBG
R': [swscale(XRGB to XBGR)], 'YUV420P': [swscale(XRGB to YUV420P)], 'YUV422P': [swscale(XRGB to YUV422P)], 'YUV444P': [swscal
e(XRGB to YUV444P)], 'GBRP': [swscale(XRGB to GBRP)]}, 'BGRX': {'RGB': [swscale(BGRX to RGB)], 'BGR': [swscale(BGRX to BGR)],
 'XRGB': [swscale(BGRX to XRGB)], 'RGBX': [swscale(BGRX to RGBX)], 'XBGR': [swscale(BGRX to XBGR)], 'YUV420P': [swscale(BGRX
to YUV420P), libyuv(BGRX to YUV420P)], 'YUV422P': [swscale(BGRX to YUV422P)], 'YUV444P': [swscale(BGRX to YUV444P)], 'GBRP':
[swscale(BGRX to GBRP)]}, 'RGBX': {'RGB': [swscale(RGBX to RGB)], 'BGR': [swscale(RGBX to BGR)], 'XRGB': [swscale(RGBX to XRG
B)], 'BGRX': [swscale(RGBX to BGRX)], 'XBGR': [swscale(RGBX to XBGR)], 'YUV420P': [swscale(RGBX to YUV420P)], 'YUV422P': [sws
cale(RGBX to YUV422P)], 'YUV444P': [swscale(RGBX to YUV444P)], 'GBRP': [swscale(RGBX to GBRP)]}, 'XBGR': {'RGB': [swscale(XBG
R to RGB)], 'BGR': [swscale(XBGR to BGR)], 'XRGB': [swscale(XBGR to XRGB)], 'BGRX': [swscale(XBGR to BGRX)], 'RGBX': [swscale
(XBGR to RGBX)], 'YUV420P': [swscale(XBGR to YUV420P)], 'YUV422P': [swscale(XBGR to YUV422P)], 'YUV444P': [swscale(XBGR to YU
V444P)], 'GBRP': [swscale(XBGR to GBRP)]}, 'YUV420P': {'RGB': [swscale(YUV420P to RGB)], 'BGR': [swscale(YUV420P to BGR)], 'X
RGB': [swscale(YUV420P to XRGB)], 'BGRX': [swscale(YUV420P to BGRX)], 'RGBX': [swscale(YUV420P to RGBX)], 'XBGR': [swscale(YU
V420P to XBGR)], 'YUV422P': [swscale(YUV420P to YUV422P)], 'YUV444P': [swscale(YUV420P to YUV444P)]}, 'YUV422P': {'RGB': [sws
cale(YUV422P to RGB)], 'BGR': [swscale(YUV422P to BGR)], 'XRGB': [swscale(YUV422P to XRGB)], 'BGRX': [swscale(YUV422P to BGRX
)], 'RGBX': [swscale(YUV422P to RGBX)], 'XBGR': [swscale(YUV422P to XBGR)], 'YUV420P': [swscale(YUV422P to YUV420P)], 'YUV444
P': [swscale(YUV422P to YUV444P)]}, 'YUV444P': {'RGB': [swscale(YUV444P to RGB)], 'BGR': [swscale(YUV444P to BGR)], 'XRGB': [
swscale(YUV444P to XRGB)], 'BGRX': [swscale(YUV444P to BGRX)], 'RGBX': [swscale(YUV444P to RGBX)], 'XBGR': [swscale(YUV444P t
o XBGR)], 'YUV420P': [swscale(YUV444P to YUV420P)], 'YUV422P': [swscale(YUV444P to YUV422P)], 'GBRP': [swscale(YUV444P to GBR
P)]}, 'GBRP': {'RGB': [swscale(GBRP to RGB)], 'BGR': [swscale(GBRP to BGR)], 'XRGB': [swscale(GBRP to XRGB)], 'BGRX': [swscal
e(GBRP to BGRX)], 'RGBX': [swscale(GBRP to RGBX)], 'XBGR': [swscale(GBRP to XBGR)], 'YUV420P': [swscale(GBRP to YUV420P)], 'Y
UV422P': [swscale(GBRP to YUV422P)], 'YUV444P': [swscale(GBRP to YUV444P)]}}
2020-05-27 13:50:36,476 Error: no matching CSC module found
2020-05-27 13:50:36,478  for 2x24 GBRP source format,
2020-05-27 13:50:36,479  to 2x24 BGRA or BGRX or RGBA or RGBX or BGR or RGB
2020-05-27 13:50:36,480  with options=['BGRA', 'BGRX', 'RGBA', 'RGBX', 'BGR', 'RGB'], speed=50
2020-05-27 13:50:36,481  tested:
2020-05-27 13:50:36,482  * BGRX:
2020-05-27 13:50:36,483    - swscale(GBRP to BGRX):
2020-05-27 13:50:36,484        source width 2 is out of range: minimum is 8
2020-05-27 13:50:36,486  * RGBX:
2020-05-27 13:50:36,487    - swscale(GBRP to RGBX):
2020-05-27 13:50:36,488        source width 2 is out of range: minimum is 8
2020-05-27 13:50:36,489  * BGR:
2020-05-27 13:50:36,491    - swscale(GBRP to BGR):
2020-05-27 13:50:36,501        source width 2 is out of range: minimum is 8
2020-05-27 13:50:36,503  * RGB:
2020-05-27 13:50:36,505    - swscale(GBRP to RGB):
2020-05-27 13:50:36,507        source width 2 is out of range: minimum is 8
2020-05-27 13:50:36,509 Error drawing on window 3

I also grabbed xpra info, which I'll attach.

Attachments (1)

26379-info.txt (530.1 KB) - added by alas 2 months ago.
xpra info with 4.0.1-r26379 server and client

Download all attachments as: .zip

Change History (2)

Changed 2 months ago by alas

Attachment: 26379-info.txt added

xpra info with 4.0.1-r26379 server and client

comment:1 Changed 2 months ago by Antoine Martin

Resolution: duplicate
Status: newclosed

Duplicate of #2642.

Note: See TracTickets for help on using tickets.