xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#280 closed defect (duplicate)

Systray icon transparency broken

Reported by: ahuillet Owned by: Antoine Martin
Priority: minor Milestone:
Component: client Version:
Keywords: Cc:

Description

Hello,

systray icons are properly forwarded but their transparency isn't - this is with Fluxbox.
See attached screenshot, where the VMWare icon (the one on the right) appears with black background.

Attachments (6)

a.jpg (7.7 KB) - added by ahuillet 7 years ago.
eggtray.py (253 bytes) - added by Antoine Martin 6 years ago.
simple test tray code using egg.trayicon
eggtray2.py (1.1 KB) - added by Antoine Martin 6 years ago.
another test tray example using egg.trayicon
testtray.c (1.4 KB) - added by Antoine Martin 6 years ago.
test tray example in C/GTK
wxtray.py (1.1 KB) - added by Antoine Martin 6 years ago.
test tray example using python wx
wxtray2.py (3.1 KB) - added by Antoine Martin 6 years ago.
another test tray example using python wx

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by ahuillet

Attachment: a.jpg added

comment:1 Changed 7 years ago by Antoine Martin

Resolution: duplicate
Status: newclosed

dupe of #77 (see comment 7, and #279)

Changed 6 years ago by Antoine Martin

Attachment: eggtray.py added

simple test tray code using egg.trayicon

Changed 6 years ago by Antoine Martin

Attachment: eggtray2.py added

another test tray example using egg.trayicon

Changed 6 years ago by Antoine Martin

Attachment: testtray.c added

test tray example in C/GTK

Changed 6 years ago by Antoine Martin

Attachment: wxtray.py added

test tray example using python wx

Changed 6 years ago by Antoine Martin

Attachment: wxtray2.py added

another test tray example using python wx

comment:2 Changed 6 years ago by Antoine Martin

transparency fixed in r3475 for *nix

Note: See TracTickets for help on using tickets.