xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#2817 closed defect (duplicate)

v4.0.x\src/xpra/client/client_tray.py", line 102, in reconfigure

Reported by: stdedos Owned by: Antoine Martin
Priority: minor Milestone: 4.1
Component: client Version: 3.0.x
Keywords: Cc:

Description (last modified by stdedos)

client r26623, server r26630

"Xpra-Python3_4.0.2-r26623\xpra_cmd" attach ssh://user@ip/20 --ssh="plink -ssh -agent" --modal-windows=no --title="@title@ on @@/@server-display@" --opengl=no --bandwidth-limit=6Mbps

2020-06-25 11:40:20,106 Xpra GTK3 client version 4.0.2-r26623 32-bit
2020-06-25 11:40:20,108  running on Microsoft Windows 10
2020-06-25 11:40:20,885 GStreamer version 1.16.2 for Python 3.8.3 32-bit
2020-06-25 11:40:21,322 keyboard layout code 0x409
2020-06-25 11:40:21,323 identified as 'United States - English' : us
2020-06-25 11:40:21,613  keyboard settings: layout=us
2020-06-25 11:40:21,616  desktop size is 4160x1440 with 1 screen:
2020-06-25 11:40:21,616   Default (1100x380 mm - DPI: 96x96) workarea: 4160x1400
2020-06-25 11:40:21,617     Generic PnP Monitor 1600x900 at 0x534 (309x174 mm - DPI: 131x131) workarea: 1600x860
2020-06-25 11:40:21,617     C32JG5x 2560x1440 at 1600x0 (697x392 mm - DPI: 93x93) workarea: 2560x1400
2020-06-25 11:40:31,411 enabled remote logging
2020-06-25 11:40:31,415 Xpra GTK3 X11 server version 3.0.10-r26630 64-bit
2020-06-25 11:40:31,415  running on Linux Ubuntu 16.04 xenial
2020-06-25 11:40:31,427 Attached to ip:22
2020-06-25 11:40:31,428  (press Control-C to detach)


(xpra_cmd:21588): Pango-WARNING **: 11:40:32.285: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
2020-06-25 11:40:32,832 sound output using 'opus' audio codec
2020-06-25 11:40:33,312 UI thread is now blocked
2020-06-25 11:40:33,329 UI thread is running again, resuming
2020-06-25 11:41:45,637 Warning: failed to parse string for key
2020-06-25 11:41:45,643  keyname=adiaeresis, keycode=231
2020-06-25 11:41:45,645  'utf-8' codec can't decode byte 0xe4 in position 0: unexpected end of data
Traceback (most recent call last):
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/client_tray.py", line 102, in reconfigure
TypeError: cannot unpack non-iterable NoneType object
Traceback (most recent call last):
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/client_tray.py", line 86, in send_configure
  File "E:\Xpra\tags\v4.0.x\src/xpra/client/client_tray.py", line 102, in reconfigure
TypeError: cannot unpack non-iterable NoneType object
2020-06-25 12:51:33,231 system is suspending
2020-06-25 12:51:33,758 server is not responding, drawing spinners over the windows
2020-06-25 13:03:47,676 server ping timeout - waited 60 seconds without a response
2020-06-25 13:03:48,202 sound output stopping

Take the report with a grain of salt; I am in troubleshooting stage, and I do not keep close track of things

Change History (3)

comment:1 Changed 3 months ago by stdedos

Description: modified (diff)

comment:2 Changed 3 months ago by Antoine Martin

Resolution: duplicate
Status: newclosed

Duplicate of #2805

comment:3 Changed 3 months ago by stdedos

Oh, yeah, right - 4.0.2 was to update to, not that it contained the #2805 fix.

Apologies

Note: See TracTickets for help on using tickets.