xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#2844 closed defect (fixed)

Xpra refuses to attach sessions / honor display number

Reported by: stdedos Owned by: Antoine Martin
Priority: major Milestone: 4.1
Component: client Version: 3.0.x
Keywords: Cc:

Description

set "XPRA_EXECUTABLE=Xpra-Python3_4.0.2-r26623"
set "XPRA_EXECUTABLE=Xpra-Python3-x86_64_4.1-r26973"

"Xpra-Python3-x86_64_4.1-r26973\xpra_cmd" attach ssh://user@ip/2 --ssh="plink -ssh -agent" --modal-windows=no --title="@title@ on @@/@server-display@" --opengl=no --bandwidth-limit=6Mbps

2020-07-15 09:10:50,603 Xpra GTK3 client version 4.1-r26973 64-bit
2020-07-15 09:10:50,606  running on Microsoft Windows 10
2020-07-15 09:10:53,259 GStreamer version 1.16.2 for Python 3.8.3 64-bit
2020-07-15 09:10:53,905 keyboard layout code 0x409
2020-07-15 09:10:53,906 identified as 'United States - English' : us
2020-07-15 09:10:54,291  keyboard settings: layout=us
2020-07-15 09:10:54,295  desktop size is 4160x1440 with 1 screen:
2020-07-15 09:10:54,295   Default (1100x381 mm - DPI: 96x96) workarea: 4160x1400
2020-07-15 09:10:54,296     Generic PnP Monitor 1600x900 at 0x534 (309x174 mm - DPI: 131x131) workarea: 1600x860 at 0x534
2020-07-15 09:10:54,296     C32JG5x 2560x1440 at 1600x0 (697x392 mm - DPI: 93x93) workarea: 2560x1400 at 1600x0
2020-07-15 09:10:58,459 Error: failed to receive anything, not an xpra server?
2020-07-15 09:10:58,468   could also be the wrong protocol, username, password or port
2020-07-15 09:10:58,469   or the session was not found
2020-07-15 09:10:58,470 Connection lost

and then:

"Xpra-Python3-x86_64_4.1-r26973\xpra_cmd" start ssh://user@ip/1 --ssh="plink -ssh -agent" --modal-windows=no --desktop-scaling=no --title="@title@ on @hostname@/@server-display@" --microphone=off --speaker=off --webcam=no --pulseaudio=no --start=gnome-terminal

2020-07-15 09:11:56,046 Xpra GTK3 client version 4.1-r26973 64-bit
2020-07-15 09:11:56,048  running on Microsoft Windows 10
2020-07-15 09:12:01,775 GStreamer version 1.16.2 for Python 3.8.3 64-bit
2020-07-15 09:12:02,357 keyboard layout code 0x409
2020-07-15 09:12:02,358 identified as 'United States - English' : us
2020-07-15 09:12:02,528 OpenGL_accelerate module loaded
2020-07-15 09:12:02,598 Using accelerated ArrayDatatype
2020-07-15 09:12:03,380 Warning: vendor 'Intel' is greylisted,
2020-07-15 09:12:03,380  you may want to turn off OpenGL if you encounter bugs
2020-07-15 09:12:03,659 OpenGL enabled with Intel(R) HD Graphics 4000
2020-07-15 09:12:03,830  keyboard settings: layout=us
2020-07-15 09:12:03,833  desktop size is 4160x1440 with 1 screen:
2020-07-15 09:12:03,833   Default (1100x381 mm - DPI: 96x96) workarea: 4160x1400
2020-07-15 09:12:03,834     Generic PnP Monitor 1600x900 at 0x534 (309x174 mm - DPI: 131x131) workarea: 1600x860 at 0x534
2020-07-15 09:12:03,834     C32JG5x 2560x1440 at 1600x0 (697x392 mm - DPI: 93x93) workarea: 2560x1400 at 1600x0
2020-07-15 09:12:17,230 enabled remote logging
2020-07-15 09:12:17,235 Xpra GTK3 X11 server version 3.0.10-r26630 64-bit
2020-07-15 09:12:17,236  running on Linux Ubuntu 16.04 xenial

(xpra_cmd:11852): Pango-WARNING **: 09:12:18.341: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
2020-07-15 09:12:19,383 UI thread is now blocked
2020-07-15 09:12:19,425 UI thread is running again, resuming
2020-07-15 09:14:21,049 unknown string message: 0xc253 / 0xc0b1 / 0x0
2020-07-15 09:14:49,310 unknown string message: 0xc253 / 0xc0b1 / 0x0

Note that I specifically asked for :1

$ xpra list
Found the following xpra sessions:
/run/user/1000/xpra:
	LIVE session at :1
	LIVE session at :2
	LIVE session at :3
	LIVE session at :4
/run/xpra:
	LIVE session at :1
	LIVE session at :2
	LIVE session at :3
	LIVE session at :4

I think both of these issues have a common cause: ssh://user@ip/x is not enough to pinpoint to a display number somehow anymore.
Furthermore, there is no warning / issue coming up to the user's side.

Attachments (1)

xpra-284xx_2020-07-15_09-13-47.png (62.7 KB) - added by stdedos 3 weeks ago.

Download all attachments as: .zip

Change History (3)

Changed 3 weeks ago by stdedos

comment:1 Changed 3 weeks ago by Antoine Martin

Resolution: fixed
Status: newclosed

This was caused by r26648 for #2794 and is fixed in r26986.

Thanks for reporting that.

comment:2 Changed 3 weeks ago by stdedos

So subtle, yet so deadly.

Maybe a unit test for it would be nice?

Note: See TracTickets for help on using tickets.