xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

#285 closed defect (worksforme)

Crash in swscale on CentOS6

Reported by: ahuillet Owned by: ahuillet
Priority: critical Milestone:
Component: server Version: 0.8.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Hello,

using the latest RPMs on CentOS 6, Paraview 3.12 x86_64 makes the server segfault in swscale.

The segfault happens as soon as the client connects; or as soon as Paraview is started, if the client was already connected.

Change History (5)

comment:1 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Status: newassigned

comment:2 Changed 7 years ago by Antoine Martin

Resolution: worksforme
Status: assignedclosed

Confirmed with CentOS 6.4 fully up to date and xpra 0.8.8:

ERROR: In /home/kitware/Dashboards/MyTests/ParaView-master/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x1f0be50): Could not find a decent visual
ERROR: In /home/kitware/Dashboards/MyTests/ParaView-master/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x1f0be50): Could not find a decent visual
ERROR: In /home/kitware/Dashboards/MyTests/ParaView-master/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 609
vtkXOpenGLRenderWindow (0x1f0be50): GLX not found.  Aborting.

Aborted

It needs the GL extension which is not available with Xvfb.

I then tried it with Xdummy and that works fine, so either use the Xorg xdummy packages in the repo or upgrade to CentOS 6.4 (RPM packages for 6.4 should have Xdummy enabled by default starting with 0.9.0).

comment:3 Changed 7 years ago by Antoine Martin

Resolution: worksforme
Status: closedreopened

New details I was not aware of:

  • it needs to run with vglrun (what graphics card is used on display :0 ??)
  • it's a regression (since when? what version?)

comment:4 Changed 7 years ago by Antoine Martin

Owner: changed from Antoine Martin to ahuillet
Status: reopenednew

comment:5 Changed 7 years ago by Antoine Martin

Resolution: worksforme
Status: newclosed

The problem apparently fixed itself, not sure how/why...

Note: See TracTickets for help on using tickets.