xpra icon
Bug tracker and wiki

Opened 6 weeks ago

Closed 6 weeks ago

Last modified 5 weeks ago

#2879 closed defect (fixed)

second maximization causes paint issues

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: critical Milestone: 4.1
Component: client Version: 4.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

This bug is not reproducible with virtualbox or the 3 machines I have: 2 with nvidia cards (mswindows and Linux) and 1 Intel chipset (Linux only).

  • run in qemu, ie:
    qemu-kvm -vnc unix:/tmp/vnc -m 4096 \
        -device qxl-vga \
        -drive file=./CentOS-8.1.1911-x86_64-dvd1.iso,media=cdrom \
        -drive file=./disk-0,cache=unsafe,format=raw,aio=threads,detect-zeroes=on \
        -net nic -net user
    

Steps:

  • connect with vncviewer /tmp/vnc
  • install centos (default install)
  • install xpra, ie:: cd /etc/yum.repos.d/;wget https://xpra.org/repos/CentOS/xpra.repo;yum install xpra
  • xpra start --start=xterm --attach=yes reproduces the bug
  • maximize the xterm, unmaximize then maximize it again

Attachments (1)

qemu-vnc.png (30.5 KB) - added by Antoine Martin 6 weeks ago.
xterm looks wrong!

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 weeks ago by Antoine Martin

Description: modified (diff)
Status: newassigned

Changed 6 weeks ago by Antoine Martin

Attachment: qemu-vnc.png added

xterm looks wrong!

comment:2 Changed 6 weeks ago by Antoine Martin

xterm looks wrong!

The whole xterm window should be plain white.
The cursor is a bit off too, but this looks like a different bug: ticket:2618#comment:7.

comment:3 Changed 6 weeks ago by Antoine Martin

Description: modified (diff)

Also reproducible with -display sdl and -display gtk instead of using a VNC connection.
Also affects python2 client builds.
Using -vga cirrus instead of -device qxl-vga makes no difference, but -vga vmware does not have this problem, that's both with and without opengl acceleration!
(so likely a graphics driver bug)

comment:4 Changed 6 weeks ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Latest versions of all branches do not have this problem thanks to the workaround in r27438 (and the backport in r27439).

comment:5 Changed 5 weeks ago by Antoine Martin

So... I wanted to see how far back I needed to go to find a version without this painting problem (assuming that a rendering change had caused this issue), and that cost me hours for nothing: the bug comes and goes, making it impossible to bisect.

Note: See TracTickets for help on using tickets.