xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 6 days ago

#2886 closed defect (fixed)

Mac OS installer for 4.0.4 fails at validating package step

Reported by: ljw1 Owned by: ljw1
Priority: blocker Milestone: 4.1
Component: packaging Version: 4.0.x
Keywords: Cc:

Description

Using the default download installer (version 4.0.4) for Mac OS 29 from September 2020 at 6:19 am from https://xpra.org/dists/osx/x86_64/Xpra-x86_64.pkg fails at the validating package step within the installer. There doesn't appear to be logs anywhere obvious.

The pkg file also is unsigned and requires an override to even open.

Mac OS version 10.15.6 (19G2021)

Change History (6)

comment:1 Changed 4 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to ljw1

Is this a regression from a previous version?
If not, this is a duplicate of #2441 and you can just use a right click to run it: ticket:2441#comment:7.

Last edited 4 weeks ago by Antoine Martin (previous) (diff)

comment:2 Changed 3 weeks ago by Antoine Martin

Resolution: needinfo
Status: newclosed

comment:3 Changed 6 days ago by Arne Burmeister

Resolution: needinfo
Status: closedreopened

Still happens with 4.0.4 package on Mac OS 10.15.7 using direkt package download or homebrew. There is no relation to #2441 as this happens after the workaround and the installer just crashes at the end.

This is was my first try to install Xpra on that machine, there is no previous version installed.

Here are some information I found in the install.log:

Install Failed:
Error Domain=PKInstallErrorDomain
Code=110
NSURL=file:///Users/arne/Downloads/Xpra-x86_64.pkg#base.pkg
PKInstallPackageIdentifier=org.xpra.pkg
PKInstallPackageSHA256Digest=d89cc22cc427431d04b8e34ba64e4416c56784742870db302e074a0ad4db8bd6
NSUnderlyingError=0x7fe37d819220 {
  Error Domain=NSPOSIXErrorDomain
  Code=34
  "Result too large"
  UserInfo={NSErrorFailingURLKey=file:/Users/arne/Downloads/Xpra-x86_64.pkg#base.pkg/Scripts}
}

Her is the full log (sorry, some messages are German):

2020-10-23 12:55:28+02 aWorkplace Installer[78727]: @(#)PROGRAM:Install  PROJECT:Install-1000
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: @(#)PROGRAM:Installer  PROJECT:Installer-965.1
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Hardware: MacBookPro16,1 @ 2.40 GHz (x 16), 65536 MB RAM
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Running OS Build: Mac OS X 10.15.7 (19H2)
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: USER=arne
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: COMMAND_MODE=unix2003
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: LOGNAME=arne
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.9D8gDSPbEG/Listeners
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: HOME=/Users/arne
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: SHELL=/bin/zsh
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: __CF_USER_TEXT_ENCODING=0x1F5:0x0:0x3
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: TMPDIR=/var/folders/d_/5bzd3fy94fs1zz8r5qk01s200000gn/T/
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: XPC_SERVICE_NAME=com.apple.xpc.launchd.oneshot.0x100002a7.Installer
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Env: XPC_FLAGS=0x0
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Xpra 4.0.4  Installation Log
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Opened from: /Users/arne/Downloads/Xpra-x86_64.pkg
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Package Authoring Error: <background> has an unsupported MIME type: image/data
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Package Authoring Error: <background_scaling> has an unsupported MIME type: X-NSObject/NSNumber
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Package Authoring Error: <background_alignment> has an unsupported MIME type: X-NSObject/NSNumber
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Package Authoring Error: <layout-direction> has an unsupported MIME type: X-NSObject/NSNumber
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Failed to load specified background image
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Product archive /Users/arne/Downloads/Xpra-x86_64.pkg trustLevel=350
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: External component packages (1) trustLevel=350
2020-10-23 12:55:28+02 aWorkplace Installer[78727]: Could not load resource readme: (null)
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Administrator authorization granted.
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: ================================================================================
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: User picked Standard Install
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Choices selected for installation:
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: 	Installieren: "Xpra 4.0.4"
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: 	Installieren: "base"
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: 		Xpra-x86_64.pkg#base.pkg : org.xpra.pkg : 4.0.4
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: ================================================================================
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: It took 0.00 seconds to summarize the package selections.
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: location = file://localhost
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: file://localhost/Users/arne/Downloads/Xpra-x86_64.pkg#base.pkg
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Set authorization level to root for session
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Will use PK session
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Using authorization level of root for IFPKInstallElement
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Starting installation:
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Configuring volume "Macintosh HD"
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Preparing disk for local booted install.
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Free space on "Macintosh HD": 764,95 GB (764945625088 bytes).
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Create temporary directory "/var/folders/d_/5bzd3fy94fs1zz8r5qk01s200000gn/T//Install.78727eTsz2u"
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: IFPKInstallElement (1 packages)
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: Current Path: /System/Library/CoreServices/Installer.app/Contents/MacOS/Installer
2020-10-23 12:55:40+02 aWorkplace installd[569]: PackageKit: Adding client PKInstallDaemonClient pid=78727, uid=501 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
2020-10-23 12:55:40+02 aWorkplace Installer[78727]: PackageKit: Enqueuing install with framework-specified quality of service (utility)
2020-10-23 12:55:40+02 aWorkplace installd[569]: PackageKit: ----- Begin install -----
2020-10-23 12:55:40+02 aWorkplace installd[569]: PackageKit: request=PKInstallRequest <1 packages, destination=/>
2020-10-23 12:55:40+02 aWorkplace installd[569]: PackageKit: packages=(
	    "<null>"
	)
2020-10-23 12:55:40+02 aWorkplace installd[569]: PackageKit: Set reponsibility for install to 78727
2020-10-23 12:55:41+02 aWorkplace installd[569]: PackageKit: Cleared responsibility for install from 78727.
2020-10-23 12:55:41+02 aWorkplace installd[569]: PackageKit: Cleared permissions on Installer.app
2020-10-23 12:55:41+02 aWorkplace installd[569]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=110 "Beim Extrahieren von Dateien aus dem Paket „Xpra-x86_64.pkg“ ist ein Fehler aufgetreten." UserInfo={NSLocalizedDescription=Beim Extrahieren von Dateien aus dem Paket „Xpra-x86_64.pkg“ ist ein Fehler aufgetreten., NSURL=file:///Users/arne/Downloads/Xpra-x86_64.pkg#base.pkg, PKInstallPackageIdentifier=org.xpra.pkg, PKInstallPackageSHA256Digest=d89cc22cc427431d04b8e34ba64e4416c56784742870db302e074a0ad4db8bd6, NSUnderlyingError=0x7fe37d819220 {Error Domain=NSPOSIXErrorDomain Code=34 "Result too large" UserInfo={NSErrorFailingURLKey=file:/Users/arne/Downloads/Xpra-x86_64.pkg#base.pkg/Scripts}}} {
	    NSLocalizedDescription = "Beim Extrahieren von Dateien aus dem Paket \U201eXpra-x86_64.pkg\U201c ist ein Fehler aufgetreten.";
	    NSURL = "file:///Users/arne/Downloads/Xpra-x86_64.pkg#base.pkg";
	    NSUnderlyingError = "Error Domain=NSPOSIXErrorDomain Code=34 \"Result too large\" UserInfo={NSErrorFailingURLKey=file:/Users/arne/Downloads/Xpra-x86_64.pkg#base.pkg/Scripts}";
	    PKInstallPackageIdentifier = "org.xpra.pkg";
	    PKInstallPackageSHA256Digest = d89cc22cc427431d04b8e34ba64e4416c56784742870db302e074a0ad4db8bd6;
	}
2020-10-23 12:55:41+02 aWorkplace installd[569]: PackageKit: Running idle tasks
2020-10-23 12:55:41+02 aWorkplace Installer[78727]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=110 "Beim Extrahieren von Dateien aus dem Paket „Xpra-x86_64.pkg“ ist ein Fehler aufgetreten." UserInfo={NSUnderlyingError=0x600002a7fe70 {Error Domain=NSPOSIXErrorDomain Code=34 "Result too large" UserInfo={NSErrorFailingURLKey=file:/Users/arne/Downloads/Xpra-x86_64.pkg#base.pkg/Scripts}}, NSURL=file:///Users/arne/Downloads/Xpra-x86_64.pkg#base.pkg, PKInstallPackageIdentifier=org.xpra.pkg, PKInstallPackageSHA256Digest=d89cc22cc427431d04b8e34ba64e4416c56784742870db302e074a0ad4db8bd6, NSLocalizedDescription=Beim Extrahieren von Dateien aus dem Paket „Xpra-x86_64.pkg“ ist ein Fehler aufgetreten.}
2020-10-23 12:55:41+02 aWorkplace installd[569]: PackageKit: Removing client PKInstallDaemonClient pid=78727, uid=501 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
2020-10-23 12:55:41+02 aWorkplace installd[569]: PackageKit: Done with sandbox removals
2020-10-23 12:55:41+02 aWorkplace Installer[78727]: Install failed: Die Installation ist aufgrund eines Fehlers fehlgeschlagen. Wende dich an den Hersteller der Software.
2020-10-23 12:55:41+02 aWorkplace Installer[78727]: IFDInstallController 24C25E0 state = 8
2020-10-23 12:55:41+02 aWorkplace Installer[78727]: Displaying 'Install Failed' UI.
2020-10-23 12:55:41+02 aWorkplace Installer[78727]: 'Install Failed' UI displayed message:'Die Installation ist aufgrund eines Fehlers fehlgeschlagen. Wende dich an den Hersteller der Software.'.

comment:4 Changed 6 days ago by Antoine Martin

The error from macos is totally unhelpful and does not tell us anything about the cause - just Result too large...

Please try the latest 4.1 beta builds: https://xpra.org/beta/MacOS/, these builds have been trimmed down further as of r27696 - maybe this will help.

comment:5 Changed 6 days ago by Arne Burmeister

Thanks @Antoine, the Beta from https://xpra.org/beta/MacOS/Xpra.pkg ran successfully and the app started!

comment:6 Changed 6 days ago by Antoine Martin

Resolution: fixed
Status: reopenedclosed

The fix will also be included in 4.0.5

Note: See TracTickets for help on using tickets.