xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 4 weeks ago

Last modified 4 weeks ago

#2887 closed defect (fixed)

Win 4.0.x client shift+arrow, shift+enter doesn't work, shift+letter/symbol OK

Reported by: schvab Owned by: schvab
Priority: minor Milestone: 4.1
Component: client Version: 4.0.x
Keywords: keyboard, shift Cc:

Description

Hello,
In all Windows 10 client v4.0.x Im observing strange behavior of shift key (server is ubuntu, always same version as client).
When using shift+arrow key to highlight text nothing happens, same for shift+enter (eg to get to new line in chat app) - in both cases the shift is ignored, only the arrow/enter key has effect.
When I enable caps-lock the highlighting works (same for enter key) as it is supposed to with shift.
For letters/symbols the shift works correctly as well as caps-lock does.
This defect doesnt happen when client is running on ubuntu.
This defect did not happen in v3.0.x.

Attachments (1)

br.zip (82.5 KB) - added by schvab 4 weeks ago.

Download all attachments as: .zip

Change History (4)

Changed 4 weeks ago by schvab

Attachment: br.zip added

comment:1 Changed 4 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to schvab

As per wiki/ReportingBugs, please be a lot more specific about what versions you have tested, the commands you used, etc.

This sounds like a duplicate of #2632

comment:2 Changed 4 weeks ago by schvab

Resolution: fixed
Status: newclosed

The server is started as:

XPRA_CLIPBOARD_IMAGE_STAMP=0 PATH="/usr/lib/xorg:$PATH" xpra start :1 \
    --mdns=no --webcam=no --use-display=yes --opengl=no --tcp-auth=sys \
    --html=on --bind-tcp=127.0.0.1:14501

running on Ubuntu 18.04.5 LTS, version xpra v4.0.3-r27082

The client is started as:

C:\"Program Files"\Xpra\xpra_cmd attach ssh://<user>@<host>/1 \
    --speaker=disabled --microphone=disabled \
    --encoding=vp8 --opengl=no --min-quality=88

running on Microsoft Windows [Version 10.0.18362.1082], version xpra v4.0.4-r27557

Adding XPRA_XKB=0 to server start solved the problem.

Last edited 4 weeks ago by Antoine Martin (previous) (diff)

comment:3 Changed 4 weeks ago by Antoine Martin

Adding XPRA_XKB=0 to server start solved the problem.

You should just update your system to 4.0.4 instead - that's very likely to fix the problem and more correctly too.

Note: See TracTickets for help on using tickets.