xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 3 weeks ago

#2889 closed defect (fixed)

xpra i386 should depend on python 3.8 in debian bullseye

Reported by: thevladsoft Owned by: thevladsoft
Priority: minor Milestone: 4.1
Component: packaging Version: 4.0.x
Keywords: packaging Cc:

Description

In debian bullseye i386, there is no candidate for install as the most recent package depends on python << 3.8. Apparently this is not the case on amd64 systems, however, this means that bullseye binary support is broken for 32bits.

Change History (4)

comment:1 Changed 3 weeks ago by Antoine Martin

Priority: majorminor
Status: newassigned

Thanks for pointing that out - the buildbot is out of date for bullseye and debootstrap fails completely.
Since I don't know when Debian is going to fix this, I cannot give you an ETA for package updates.

FYI: x86 will be dropped sooner or later... it really does not get tested much.

comment:2 Changed 3 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to thevladsoft
Status: assignednew

I have successfully re-built the base bullseye environment today.

There are beta builds of 4.1, does that work for you?

comment:3 Changed 3 weeks ago by thevladsoft

Works perfectly, thanks.

comment:4 Changed 3 weeks ago by Antoine Martin

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.