xpra icon
Bug tracker and wiki

Opened 2 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#2891 closed defect (fixed)

Cannot connect with r27603

Reported by: stdedos Owned by: Antoine Martin
Priority: major Milestone: 4.1
Component: client Version: 3.0.x
Keywords: Cc:

Description (last modified by stdedos)

I've tried unpacking the r27603 version (after #2890), however, just after plink authentication:

"Xpra-Python3-x86_64_4.1-r27603\xpra_cmd" attach ssh://user@ip/3 --ssh="plink -ssh -agent" --modal-windows=no --title="@title@ on @@/@server-display@" --headerbar=off --opengl=no --bandwidth-limit=6Mbps

2020-10-06 12:24:55,977 Xpra GTK3 client version 4.1-r27603 64-bit
2020-10-06 12:24:55,989  running on Microsoft Windows 10
2020-10-06 12:24:57,872 GStreamer version 1.18.0 for Python 3.8.6 64-bit
2020-10-06 12:24:58,331 created named pipe 'Xpra\8968'
2020-10-06 12:24:58,726 keyboard layout code 0x409
2020-10-06 12:24:58,727 identified as 'United States - English' : us
2020-10-06 12:24:59,084  keyboard settings: layout=us
2020-10-06 12:24:59,088  desktop size is 4160x1440 with 1 screen:
2020-10-06 12:24:59,088   Default (1100x381 mm - DPI: 96x96) workarea: 4160x1400
2020-10-06 12:24:59,089     Generic PnP Monitor 1600x900 at 0x534 (309x174 mm - DPI: 131x131) workarea: 1600x860 at 0x534
2020-10-06 12:24:59,089     C32JG5x 2560x1440 at 1600x0 (697x392 mm - DPI: 93x93) workarea: 2560x1400 at 1600x0
2020-10-06 12:26:13,409 Error: failed to receive anything, not an xpra server?
2020-10-06 12:26:13,411   could also be the wrong protocol, username, password or port
2020-10-06 12:26:13,411   or the session was not found
2020-10-06 12:26:13,411 Connection lost

and the log from the server does not even see the attempt:

2020-10-05 17:14:01,513 Warning: failed to send file 'https://url//path/to/folder/',
2020-10-05 17:14:01,513  the send approval request timed out                                 # I think I canceled this one, so I wonder "why" timeout, but okay
2020-10-06 12:21:39,771 New unix-domain connection received
2020-10-06 12:21:39,771  on '/run/user/1000/xpra/u-h-3'
2020-10-06 12:21:39,773 Handshake complete; enabling connection
2020-10-06 12:21:39,780  automatic picture encoding enabled, also available:
2020-10-06 12:21:39,780   h264, vp9, vp8, png, png/P, png/L, rgb24, rgb32, jpeg
2020-10-06 12:21:39,781 Python/GTK3 Microsoft Windows 10 aero client version 4.1-r27519 64-bit
2020-10-06 12:21:39,781  connected from 'x' as 'y' - 'z'

Change History (5)

comment:1 Changed 2 weeks ago by Antoine Martin

Could be r27578.
Can you add -d ssh?

comment:2 Changed 2 weeks ago by stdedos

Description: modified (diff)

comment:3 in reply to:  1 Changed 2 weeks ago by stdedos

Replying to Antoine Martin:

Can you add -d ssh?

2020-10-06 12:34:00,645 parse_ssh_string(plink -ssh -agent)
2020-10-06 12:34:00,815 executing ssh command: "plink" "-ssh" "-agent" "-l" "user" "-T" "1.2.3.4" "sh -c if [ -x $XDG_RUNTIME_DIR/xpra/run-xpra ]; then $XDG_RUNTIME_DIR/xpra/run-xpra _proxy ":3";elif which "xpra" > /dev/null 2>&1; then xpra _proxy ":3";elif [ -x /usr/local/bin/xpra ]; then /usr/local/bin/xpra _proxy ":3";elif [ -x ~/.xpra/run-xpra ]; then ~/.xpra/run-xpra _proxy ":3";elif [ -x Xpra_cmd.exe ]; then Xpra_cmd.exe _proxy ":3";else echo "no run-xpra command found"; exit 1; fi"
Last edited 2 weeks ago by stdedos (previous) (diff)

comment:4 Changed 2 weeks ago by Antoine Martin

Resolution: fixed
Status: newclosed

Fixed in r27614. (this was caused by the fix for #2867)

New builds have been uploaded, or you can also use r27603 with:

XPRA_SSH_MAGIC_QUOTES=0 Xpra_cmd ...

comment:5 Changed 2 weeks ago by stdedos

Verified as fixed

Note: See TracTickets for help on using tickets.