xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#290 closed enhancement (fixed)

Launcher: expose encoding speed and quality

Reported by: ahuillet Owned by: ahuillet
Priority: major Milestone: 0.10
Component: client Version:
Keywords: Cc:

Description

Hello,

currently the launcher exposes a "quality" combobox that I believe is ignored, or at least has misleading/outdated labels.
It also doesn't expose a "speed" combobox.

It would be good to expose both of those features, with a default on Auto.

Change History (9)

comment:1 Changed 7 years ago by Antoine Martin

Milestone: 0.10
Status: newaccepted

comment:2 Changed 6 years ago by Antoine Martin

Status: acceptednew

Many launcher improvements in r3806 + r3807 + r3809

  • we re-use the same rich option menu we already had for speed in the tray menu, and extends that to offer the same multiple choices for quality (now also in tray): allows us to select both fixed speed/quality or auto + min speed/quality
  • we can now load and save session files from the UI


The default is unchanged: whatever is in the file (or global default file) should be what is shown in the menu. Note: if two options are selected in one of the menus then the first one is used as label. (eg: "Auto" + "min=Low Latency" shows up as "Auto")

Please close when tested.

comment:3 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to ahuillet

comment:4 Changed 6 years ago by ahuillet

The rich option menu looks good. However, it still seems to me that the parameters from my session file are ignored.

I have this in the file:

min-speed=80
min-quality=20

But when running, if I go to the tray menu, quality is set to "Fixed quality: auto", speed is set to "Fixed speed: auto". Is that expected?

comment:5 Changed 6 years ago by Antoine Martin

It is expected:

Fixed XXXX : Auto

Means that you are using auto-mode with "min-XXXXX".

If you switch to fixed quality/speed, the min-XXXXX option will go to auto, and vice versa.

Put another way with some specific examples:

  • if you select a fixed speed, min-speed turns to auto (unused)
  • if you select a min-quality, quality goes to auto (another word for it would be "dynamic")


Make sense? (not saying that there aren't bugs... just that what you describe looks fine, though we may want to word it differently?)

comment:6 Changed 6 years ago by ahuillet

What puzzles me is that the parameters from the file do not appear to be reflected in the tray menu. Perhaps they are taken into account anyway, but what I see is the same as if they were not specified at all.

comment:7 Changed 6 years ago by Antoine Martin

I believe that's because you've chosen values which aren't mapped to the default list of options, which is defined as:

LOSSLESS = "Lossless"
QUALITY_OPTIONS_COMMON = {
                50      : "Average",
                30      : "Low",
                }
MIN_QUALITY_OPTIONS = QUALITY_OPTIONS_COMMON.copy()
MIN_QUALITY_OPTIONS[0] = "None"
QUALITY_OPTIONS = QUALITY_OPTIONS_COMMON.copy()
QUALITY_OPTIONS[0]  = "Auto"
QUALITY_OPTIONS[1]  = "Lowest"
QUALITY_OPTIONS[90]  = "Best"
QUALITY_OPTIONS[100]  = LOSSLESS
SPEED_OPTIONS_COMMON = {
                70      : "Low Latency",
                30      : "Low Bandwidth",
                }
MIN_SPEED_OPTIONS = SPEED_OPTIONS_COMMON.copy()
MIN_SPEED_OPTIONS[0] = "None"
SPEED_OPTIONS = SPEED_OPTIONS_COMMON.copy()
SPEED_OPTIONS[0]    = "Auto"
SPEED_OPTIONS[1]    = "Lowest Bandwidth"
SPEED_OPTIONS[100]  = "Lowest Latency"

r3857 will just add the missing values to the menu.

comment:8 Changed 6 years ago by ahuillet

Resolution: fixed
Status: newclosed

Confirmed, thanks!

comment:9 Changed 6 years ago by Antoine Martin

More fixes in r3872

Note: See TracTickets for help on using tickets.