xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 4 months ago

Closed 4 months ago

Last modified 3 months ago

#2959 closed defect (invalid)

Xpra doesnt detect lz4, just when Iam root

Reported by: grandfather22 Owned by: Antoine Martin
Priority: major Milestone: 4.1
Component: server Version: 3.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Xpra cant detect lz4 installed:

XPRA_NETWORK_DEBUG=1 /usr/lib64/python2.7/site-packages/xpra/net/compression.py
2020-11-30 15:46:48,462 lz4 not found
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/net/compression.py", line 30, in <module>
    from lz4 import VERSION as python_lz4_version   #@UnresolvedImport
ImportError: No module named lz4
2020-11-30 15:46:48,462 lzo not found: No module named lzo
* brotli                          : False
* lz4                             : False
* lzo                             : False
* zlib                            : True
  - version                       : 1.0
sudo XPRA_NETWORK_DEBUG=1 /usr/lib64/python2.7/site-packages/xpra/net/compression.py
2020-11-30 15:49:14,855 lzo not found: No module named lzo
* brotli                          : False
* lz4                             : True
  - version                       : 2.2.1
* lzo                             : False
* python-lz4                      : True
  - version                       : 2.2.1
* zlib                            : True
  - version                       : 1.0
pip list | grep lz4
lz4 (2.2.1)
cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.9 (Maipo)

Change History (6)

comment:1 Changed 4 months ago by Antoine Martin

Description: modified (diff)
Resolution: invalid
Status: newclosed

python-lz4 should not be installed using pip, the only supported way is using the python-lz4 RPM packages provided in the repository.

If you choose a different method, then you get to keep the pieces..

comment:2 Changed 4 months ago by grandfather22

Resolution: invalid
Status: closedreopened

Sadly, its not helped

comment:3 Changed 4 months ago by grandfather22

At the beginning, I try to use the original package, but it working lesser, because it didnt work with sudo either:
(Sorry for my bad English)

rpm -qa | grep lz4
python2-lz4-0.8.2-2.el7.x86_64
lz4-1.8.3-1.el7.i686
lz4-1.8.3-1.el7.x86_64

pip list | grep lz4
lz4 (0.8.2)
You are using pip version 8.1.2, however version 20.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

XPRA_NETWORK_DEBUG=1 /usr/lib64/python2.7/site-packages/xpra/net/compression.py
2020-11-30 16:48:21,865 lz4 not found
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/net/compression.py", line 31, in <module>
    from lz4.version import version as lz4_version
ImportError: No module named version
2020-11-30 16:48:21,866 lzo not found: No module named lzo
* brotli                          : False
* lz4                             : False
* lzo                             : False
* python-lz4                      : True
  - version                       : 0.8.2
* zlib                            : True
  - version                       : 1.0
sudo XPRA_NETWORK_DEBUG=1 /usr/lib64/python2.7/site-packages/xpra/net/compression.py
2020-11-30 16:50:41,966 lz4 not found
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/net/compression.py", line 31, in <module>
    from lz4.version import version as lz4_version
ImportError: No module named version
2020-11-30 16:50:41,966 lzo not found: No module named lzo
* brotli                          : False
* lz4                             : False
* lzo                             : False
* python-lz4                      : True
  - version                       : 0.8.2
* zlib                            : True
  - version                       : 1.0

Thank you!

Last edited 4 months ago by Antoine Martin (previous) (diff)

comment:4 Changed 4 months ago by Antoine Martin

Resolution: invalid
Status: reopenedclosed

At the beginning, I try to use the original package, but it working lesser, because it didnt work with sudo either:

It works fine, even from sudo.

My guess is that you've messed up your installation, probably by using pip and now you have multiple versions of lz4 installed, which is why this fails for you:

python -c "from lz4.version import version"

Please do not re-open this ticket. This is not a problem with xpra, or with the packages from the xpra.org repository.

comment:5 Changed 4 months ago by grandfather22

I used pip after xpra lz4 did not work. Thank you the test command. I will try this with a new os install... Thank you! And have a nice day! :)

comment:6 Changed 3 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2959

Note: See TracTickets for help on using tickets.