xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#296 closed defect (fixed)

Redraw errors with opengl enabled on win 7 64 - nvidia gtx 670

Reported by: aradtech Owned by: aradtech
Priority: major Milestone: 0.9
Component: client Version: trunk
Keywords: opengl Cc:

Description (last modified by Antoine Martin)

I was re-sizing the client window when I got this anomaly and the error message beside it that kept going over and over.

Traceback (most recent call last):
  File "xpra\gl\gl_window_backing.pyc", line 171, in do_gl_paint
  File "xpra\gl\gl_window_backing.pyc", line 227, in update_texture_yuv
  File "latebind.pyx", line 32, in OpenGL_accelerate.latebind.LateBind.__call__
(src\latebind.c:768)
  File "wrapper.pyx", line 315, in OpenGL_accelerate.wrapper.Wrapper.__call__ (s
rc\wrapper.c:5933)
GLError: GLError(
        err = 1281,
        description = 'invalid value',
        baseOperation = glTexSubImage2D,
        pyArgs = (
                GL_TEXTURE_RECTANGLE_ARB,
                0,
                0,
                0,
                586,
                615,
                GL_LUMINANCE,
                GL_UNSIGNED_BYTE,
                "\x95\x95\x95\x95\x95\x95\x95\x96\x93...,
        ),
        cArgs = (
                GL_TEXTURE_RECTANGLE_ARB,
                0,
                0,
                0,
                586,
                615,
                GL_LUMINANCE,
                GL_UNSIGNED_BYTE,
                "\x95\x95\x95\x95\x95\x95\x95\x96\x93...,
        ),
        cArguments = (
                GL_TEXTURE_RECTANGLE_ARB,
                0,
                0,
                0,
                586,
                615,
                GL_LUMINANCE,
                GL_UNSIGNED_BYTE,
                "\x95\x95\x95\x95\x95\x95\x95\x96\x93...,
        ) 

I have attached screenshots of said anomaly.

Other behaviors noted with it.

  • 1 Re-sizing the image didn't remove the bottom part if I moved it sideways or up ,but not above the line.
  • 2 soon as it went above the top line when I pulled it down the issue had gone away and the error message stopped.

Machine specs
Intel I5-3350P
16 gig ram
Nvidia GTX 670
2 monitors attached.
Win 7 64 up to date with all patches.

Attachments (7)

xpra1.jpg (707.6 KB) - added by aradtech 7 years ago.
Problem Image 1
xpra2.jpg (683.9 KB) - added by aradtech 7 years ago.
Problem Image 2 showing version and other options
xpra3.jpg (713.1 KB) - added by aradtech 7 years ago.
Problem Image 3 showing more features and videoCard used
xpra4.jpg (685.8 KB) - added by aradtech 7 years ago.
Problem Image 4 showing Connection info
xpra5.jpg (689.5 KB) - added by aradtech 7 years ago.
Problem Image 5 showing Statistics
xpra6.jpg (734.0 KB) - added by aradtech 7 years ago.
Problem Image 6 showing graphs
xpra7.jpg (683.4 KB) - added by aradtech 7 years ago.
Problem Image 7 showing fixed after I moved the frame above the blue line.

Change History (15)

Changed 7 years ago by aradtech

Attachment: xpra1.jpg added

Problem Image 1

Changed 7 years ago by aradtech

Attachment: xpra2.jpg added

Problem Image 2 showing version and other options

Changed 7 years ago by aradtech

Attachment: xpra3.jpg added

Problem Image 3 showing more features and videoCard used

Changed 7 years ago by aradtech

Attachment: xpra4.jpg added

Problem Image 4 showing Connection info

Changed 7 years ago by aradtech

Attachment: xpra5.jpg added

Problem Image 5 showing Statistics

Changed 7 years ago by aradtech

Attachment: xpra6.jpg added

Problem Image 6 showing graphs

Changed 7 years ago by aradtech

Attachment: xpra7.jpg added

Problem Image 7 showing fixed after I moved the frame above the blue line.

comment:1 Changed 7 years ago by ahuillet

Please scroll to the bottom of wiki/Debugging and get an Apitrace of the problem (if you can reproduce it).
If you can't, I'm not sure what to do, I think it's likely to be a race condition.

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Owner: set to Antoine Martin
Status: newaccepted

fix bug formatting

comment:3 Changed 7 years ago by Antoine Martin

Owner: changed from Antoine Martin to aradtech
Status: acceptedassigned

aradtech, please see comment:1

comment:4 Changed 7 years ago by Antoine Martin

Please reproduce and post the command output with this env var set

XPRA_OPENGL_DEBUG=1

Also please specify if this can be reproduced on this setup only (the machine hardware details, some of which is in the bug title) or if the setup is irrelevant (in which case edit the bug title to reflect that).

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:5 Changed 7 years ago by aradtech

Unable to reproduce at all , its a random issue when using opengl. I get no issues at all like that when not using opengl.

comment:6 Changed 7 years ago by Antoine Martin

Please see comment:4 and edit the details

comment:7 Changed 7 years ago by aradtech

Unable to reproduce.

comment:8 Changed 7 years ago by aradtech

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.