xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 6 years ago

#297 closed defect (fixed)

Sound stops working and gives errors when turned on and off using --speaker-codec wavpack.

Reported by: aradtech Owned by: aradtech
Priority: major Milestone: 0.9
Component: client Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

Using youtube on video , playing with speaker on /off features , got error

2013-03-19 13:23:54,980 sound source pipeline error: GStreamer encountered a general stream error. / 
    \..\..\..\Source\gstreamer\libs\gst\base\gstbasesrc.c(2563): \
    gst_base_src_loop (): /GstPipeline:pipeline0/GstAppSrc:src: \
    streaming task paused, reason not-linked (-1)
2013-03-19 13:23:55,474 push-buffer error: <enum GST_FLOW_WRONG_STATE of type GstFlowReturn>
2013-03-19 13:23:55,973 push-buffer error: <enum GST_FLOW_WRONG_STATE of type GstFlowReturn>
2013-03-19 13:23:56,469 push-buffer error: <enum GST_FLOW_WRONG_STATE of type GstFlowReturn>
2013-03-19 13:23:56,963 push-buffer error: <enum GST_FLOW_WRONG_STATE of type GstFlowReturn>
2013-03-19 13:23:57,463 push-buffer error: <enum GST_FLOW_WRONG_STATE of type GstFlowReturn>
2013-03-19 13:23:57,963 push-buffer error: <enum GST_FLOW_WRONG_STATE of type GstFlowReturn>
2013-03-19 13:23:58,464 push-buffer error: <enum GST_FLOW_WRONG_STATE of type GstFlowReturn>
2013-03-19 13:23:58,864 push-buffer error: <enum GST_FLOW_WRONG_STATE of type GstFlowReturn>

over and over in console

turning off speaker and back on would produce same results. Unable to get sound to work in that session again.

Server and client 3018 build date 201303-19

Gstreamer client 0.10.31 Server 0.10.36
Pygst Client 0.10.20 Server 0.10.22

Server Codecs mp3,opus,flac, wavpack,wav,speex
Client mp3,flac,wavpack,wav,speex active wavpack

Win 7 64

Change History (11)

comment:1 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Owner: set to Antoine Martin
Status: newaccepted

comment:2 Changed 7 years ago by Antoine Martin

Description: modified (diff)

comment:3 Changed 7 years ago by Antoine Martin

Description: modified (diff)

See #298, looks like gstreamer has some serious problems on win32..

comment:4 Changed 7 years ago by Antoine Martin

Owner: changed from Antoine Martin to aradtech
Status: acceptedassigned

Maybe you were lucky, my testing is much much worse: as soon as I stop the sound, all the windows and the applet stop responding, the UI thread is blocked as per #298.
Also it looks to me like this has nothing to do with wavpack and happens with every other codec on win32, right? (please confirm this is isn't a regression caused by recent changes done to accomodate #298 - not that we can easily undo them to get a major advantage, it's still a datapoint)

On Linux, you need r3031 to restart sound, but there it works reliably.

Trying #299 first might be a good way forward.

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:5 Changed 6 years ago by Antoine Martin

r3032 removes the ability to turn the speaker on or off for win32 hosts since it cannot be made to work reliably with "current" available gstreamer builds, will follow up in #299 or #300.

Please test an close.

comment:6 Changed 6 years ago by aradtech

Resolution: fixed
Status: assignedclosed

comment:7 Changed 6 years ago by Antoine Martin

Restored the ability to start/stop sound in r3095 - seems to work again since r3092 fixed the signal stuff.

comment:8 Changed 6 years ago by Antoine Martin

Err, just happened again - but I swear it was working OK when I committed r3095!
(looks like I'll have to undo the undo...)

comment:9 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: closedreopened

comment:10 Changed 6 years ago by Antoine Martin

This one is so hit and miss that I am not at all sure that I have found the cause, or the solution.


See the r3100 commit message for the latest attempts at allowing sound and ^C to coexist on win32.

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:11 Changed 6 years ago by alas

Resolution: fixed
Status: reopenedclosed

Seems to work swimmingly now. Closing.

Note: See TracTickets for help on using tickets.