xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 19 months ago

Closed 19 months ago

Last modified 17 months ago

#2972 closed defect (invalid)

python << 3.9

Reported by: Francesco Potortì Owned by: Antoine Martin
Priority: major Milestone: 4.1
Component: android Version: trunk
Keywords: Cc:


Is there a reason why the current Xpra build for Debian requires python << 3.9?

This is blocking Debian testing upgrade

Change History (4)

comment:1 Changed 19 months ago by Antoine Martin

Resolution: invalid
Status: newclosed

Debian testing is not frozen yet, so they can and do break the ABI.
AFAICT, this upgrade to Python 3.9 was very recent.

For that reason, you should be using the beta repository, which gets updated much more regularly and will have recent builds - those builds will usually have the correct ABI - only sometimes with a slight unavoidable delay.

comment:2 Changed 19 months ago by Francesco Potortì

Thank you. I am indeed using the beta repository. I meant to ask whether

1) Xpra cannot go to Python higher than 3.9 for some specific reason
2) it is just a matter of rebuilding the package, which will happen soon

I am asking because this is blocking some updates of Debian packages and I would like to get an idea for how long.

comment:3 Changed 19 months ago by Antoine Martin

Ah, now I see what you mean:

 xpra : Depends: python3 (< 3.9) but 3.9.0-4 is to be installed

The packages were there but the repository metadata had not been updated, try again now.

There is nothing in the xpra source or its packaging that conflicts with python 3.9.

comment:4 Changed 17 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2972

Note: See TracTickets for help on using tickets.