xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 4 weeks ago

Last modified 4 days ago

#2992 closed defect (invalid)

Images pasted from clipboard stamped with "via Xpra" string

Reported by: Don Turron Owned by: Antoine Martin
Priority: minor Milestone: 4.2
Component: clipboard Version: 4.0.x
Keywords: Cc:

Description

When images are pasted from the local environment into a remote xpra window, a label is printed over the image on the remote xpra window containing the string "via Xpra" and the current date.

This is very annoying as it complicates remote editing when screenshots need to be pasted.

To reproduce, just take any screenshot (local application), on the xpra session open any application that can paste images, Libreoffice, Thunderbird, or even Gimp, paste the image on the remote application and the string will be stamped on top of the remotely pasted image.

Attachments (2)

xpra_clipboard_image.png (1.9 KB) - added by Don Turron 4 weeks ago.
Example of the problem in action
xpra_os_details.txt (9.9 KB) - added by Don Turron 4 weeks ago.
Os and server details

Download all attachments as: .zip

Change History (5)

Changed 4 weeks ago by Don Turron

Attachment: xpra_clipboard_image.png added

Example of the problem in action

Changed 4 weeks ago by Don Turron

Attachment: xpra_os_details.txt added

Os and server details

comment:1 Changed 4 weeks ago by Don Turron

I just realised there was a ticket for this already #2634

And that the solution is just to pass the parameter:

--env=XPRA_CLIPBOARD_IMAGE_STAMP=0

To the client connection parameters.

Please close this ticket.

Many thanks for your hard work on this, I appreciate your work on XPRA a lot.

Last edited 4 weeks ago by Antoine Martin (previous) (diff)

comment:2 Changed 4 weeks ago by Antoine Martin

Resolution: invalid
Status: newclosed

comment:3 Changed 4 days ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2992

Note: See TracTickets for help on using tickets.