xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 12 months ago

Last modified 12 months ago

#3006 closed defect

python2-lz4 in centos 7.9 — at Initial Version

Reported by: Caleb Khor Owned by: Antoine Martin
Priority: major Milestone: 3.1
Component: packaging Version: 3.0.x
Keywords: centos Cc:

Description

I've noticed the following for the packaging for Centos 7.x versions of xpra:

Centos 7.6: lz4 and python2-lz4 are from xpra. Latest xpra version is 3.0.13.
Centos 7.7: lz4 and python2-lz4 are from xpra. Latest xpra version is 3.0.9
Centos 7.8: python2-lz4 is from xpra. lz4 is absent. latest xpra version is 3.0.13
Centos 7.9: python2-lz4 and lz4 are both absent. latest xpra version is 3.0.13

It seems that the version of python2-lz4 (2.2.1) is critical for xpra to work, not so for lz4, as it can be swapped with the system version.

While 3.0.13 largely worked on Centos 7.9, there is a bug when xpra shadow is invoked (both via the command line and gui), the xpra session just crashes after a while during launch. It just terminates itself without any reason, and UNKNOWN sessions were created (which of course cleaned up later). It seems that restoring python2-lz4 (2.2.1) (obtained from the other distros) makes it work again.

It is in my view that for the Centos 7.9 distribution, perhaps python2-lz4 should be included?

Change History (0)

Note: See TracTickets for help on using tickets.