xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#334 closed defect (fixed)

Server fails to start up on Ubuntu 12.10 64-bit server

Reported by: Joel Martin Owned by: Joel Martin
Priority: major Milestone: 0.10
Component: server Version: trunk
Keywords: startup Cc:

Description (last modified by Antoine Martin)

With revision r3385, I am getting this error when I try and start Xpra:

Traceback (most recent call last):
  File "root/usr/local/bin/xpra", line 6, in <module>
    sys.exit(xpra.scripts.main.main(__file__, sys.argv))
  File "/home/jmartin/repos/Xpra.current/root/usr/local/lib/python2.7/dist-packages/xpra/scripts/main.py", line 449, in main
    return run_server(parser, options, mode, script_file, args)
  File "/home/jmartin/repos/Xpra.current/root/usr/local/lib/python2.7/dist-packages/xpra/scripts/server.py", line 485, in run_server
    app.init(clobber, sockets, opts)
  File "/home/jmartin/repos/Xpra.current/root/usr/local/lib/python2.7/dist-packages/xpra/x11/server.py", line 162, in init
    X11ServerBase.init(self, clobber, sockets, opts)
  File "/home/jmartin/repos/Xpra.current/root/usr/local/lib/python2.7/dist-packages/xpra/x11/x11_server_base.py", line 65, in init
    self.x11_init()
  File "/home/jmartin/repos/Xpra.current/root/usr/local/lib/python2.7/dist-packages/xpra/x11/server.py", line 181, in x11_init
    self._wm = Wm("Xpra", self.clobber)
  File "/home/jmartin/repos/Xpra.current/root/usr/local/lib/python2.7/dist-packages/xpra/x11/gtk_x11/wm.py", line 214, in __init__
    self._wm_selection.acquire(mode)
  File "/home/jmartin/repos/Xpra.current/root/usr/local/lib/python2.7/dist-packages/xpra/x11/gtk_x11/selection.py", line 102, in acquire
    ts_num, selection_xatom, self._xwindow, 0, 0)
  File "window_bindings.pyx", line 642, in xpra.x11.bindings.window_bindings.X11WindowBindings.sendClientMessage (xpra/x11/bindings/window_bindings.c:4821)
  File "window_bindings.pyx", line 447, in xpra.x11.bindings.window_bindings.X11WindowBindings.get_xatom (xpra/x11/bindings/window_bindings.c:2200)
OverflowError: can't convert negative value to unsigned long

The Xvfb-for-Xpra-:101 process is left running after the error and must be manually killed.

This is on a 64-bit Ubuntu 12.10 server installation.

Attachments (1)

paste.txt (515.6 KB) - added by Nick Burrett 6 years ago.
Debug log from xpra session that accepts no keyboard imput

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Antoine Martin

Status: newassigned

Well, that's an interesting one.
Why would the atom be negative... Strange.

comment:2 Changed 6 years ago by Antoine Martin

Description: modified (diff)
Resolution: worksforme
Status: assignedclosed

Cannot reproduce with latest trunk, but in the process I found some other problems: r3896, r3895, r3894

Feel free to re-open if you still have issues. If so, I don't think it will tell us much more, but maybe running with "-d all" can help.

comment:3 Changed 6 years ago by Antoine Martin

Resolution: worksforme
Status: closedreopened

Also occurs in focus code on CentOS 6.3: ML: xpra 0.10.0 no keyboard input

comment:4 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Joel Martin
Status: reopenednew

I've tried very hard to reproduce this bug and I just cannot hit it, there must be something different in my env.


Can you please post the output with:

XPRA_X11_DEBUG=1 xpra start ... -d all

Changed 6 years ago by Nick Burrett

Attachment: paste.txt added

Debug log from xpra session that accepts no keyboard imput

comment:5 Changed 6 years ago by Nick Burrett

I've found that if I start /usr/bin/emacs, it may spawn an xterm to run 'lynx' when I click on the 'GNU Emacs' link. That spawned xterm does have working keyboard input, whilst the emacs window remains without any keyboard input.

comment:6 Changed 6 years ago by Antoine Martin

That spawned xterm does have working keyboard input, whilst the emacs window remains without any keyboard input.


That's because there are two ways to give focus to an application (one of X11's quirks..), and those apps must be using different ones.

The one that was having problems should be fixed in r4185, but:

  • I have not been able to hit it myself - so I am just guessing
  • this code has not changed for a very long time, why it would suddenly start to misbehave is still a mistery

I have added a test script to show us the value of the x11_server_time in r4189 (that was the value that ended up being negative)

comment:7 Changed 6 years ago by Nick Burrett

I applied the r4185 patch. I now have working keyboard entry.

comment:8 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

comment:9 Changed 6 years ago by Antoine Martin

Milestone: future0.10

(setting correct milestone the work was completed in)

Note: See TracTickets for help on using tickets.