xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

#335 closed defect (needinfo)

default mouse cursor in menus

Reported by: onlyjob Owned by: onlyjob
Priority: minor Milestone: 0.9
Component: core Version:
Keywords: Cc:

Description

In many applications mouse cursor shape is not forwarded for menus. To reproduce start kcalc and open any menu -- mouse cursor will look like default 'X' on menu entries.

Change History (14)

comment:1 Changed 7 years ago by Antoine Martin

Component: servercore
Milestone: 0.9
Status: newassigned

Is this a regression? (0.9.2 in title, why is that?)

I'm not seeing anything unusual here with cinnamon as DE. The cursor looks the same with and without xpra.

Please try with the patch from r3387 (either using trunk or applying it to v0.9.x) to get more debug output from the server, simply grep for:

send_cursor()

And please add some context to the log output so I know what I am looking at.
(what happened, what you expected to see, what you did see)

The client debug output will have the corresponding calls (also worth having just to check), just grep for cursor.

comment:2 Changed 7 years ago by onlyjob

I'm not sure if it is a regression. I'm pretty confident that I've seen it on 0.9.1 but I don't remember if it was the case in 0.8.8.

I set the title because that's was the version that I used to reproduce and I couldn't choose 0.9.x from version drop-down list as 0.9.x wasn't there when I logged this ticket...

I'll try r3387 on top of 0.9.x and will report back. Thank you.

comment:3 Changed 7 years ago by onlyjob

With "send_cursor()" logging patch applied the following is logged upon start of kcalc:

2013-05-16 11:10:25,283 send_cursor() cursor=[375, 59, 24, 24, 5, 0, 3L, '2304 bytes', 'left_ptr']

There is no "send_cursor()" on menu when cursor is actually changing to 'X'.

comment:4 Changed 7 years ago by Antoine Martin

Owner: changed from Antoine Martin to onlyjob
Status: assignednew

Then I am pretty sure that it is your client DE (KDE right?) that is deciding it knows best and is changing the cursor for you.

You can confirm this is the case by temporarily switching to a more minimalistic DE (fluxbox, openbox, ..)

comment:5 Changed 7 years ago by onlyjob

Interesting... Usually I'm using KDE.

I tried with Enlightenment and found that mouse cursor is also changing on menus (although to different shape than 'X').

On Xfce4 cursor stays the same in menu.

comment:6 Changed 7 years ago by Antoine Martin

From what you're saying, this does not happen when the application runs native, right?

So maybe we aren't forwarding all the window attributes for the menu window and that changes the behaviour of the DE.
It would be worth comparing the window attributes and properties with and without xpra (using xwininfo and xprop) if you can (difficult and will need to be scripted since the mouse needs to be focused in that window when the menu is shown..)

comment:7 Changed 7 years ago by Antoine Martin

Resolution: wontfix
Status: newclosed

I'm pretty sure this is DE behaviour and not much we can do about it.

comment:8 Changed 7 years ago by onlyjob

Perhaps something (like forwarding all the window attributes for the menu window) could be done because this does not happen when the application runs native.

I didn't have time to catch menu attributes yet...

I'd prefer to keep this bug open even if there is a little chance for fix...

comment:9 Changed 7 years ago by Antoine Martin

Resolution: wontfix
Status: closedreopened
Summary: 0.9.2: default mouse cursor in menusdefault mouse cursor in menus

OK, but then please provide the window attributes so that we can compare (xwininfo, xprop, ..)

Also, I've removed "0.9.2" from the title as I believe this bug has nothing to do with this particular version - is this even a regression at all?

comment:10 Changed 7 years ago by onlyjob

Thank you. Of course this is not a regression or anything specific to 0.9.2 even though this issue started to manifest with introduction of support for forwarding mouse cursors...

comment:11 Changed 7 years ago by Antoine Martin

Status: reopenednew

comment:12 Changed 7 years ago by onlyjob

Sorry, I wasn't able to get property dumps yet (it is more difficult that I thought and more time is needed) but I've noticed that in 0.9.6 cursor is looking OK (as expected) in menus.

Thank you for fixing it, whatever it was.

Shall we close this issue and reopen if it ever comes back?

comment:13 Changed 7 years ago by Antoine Martin

There was nothing that dealt with cursors explicitly in 0.9.6, the only slightly related change is r3748 (and I don't see why toolkits would take the workarea into account when deciding what cursor size to use - they should use the total screen size)

The last cursor related change was in 0.9.4: r3517 (revert of r3429)

comment:14 Changed 7 years ago by Antoine Martin

Resolution: needinfo
Status: newclosed

closing

Note: See TracTickets for help on using tickets.