xpra icon
Bug tracker and wiki

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#34 closed defect (fixed)

holding down Ctrl + N sometimes produces ^N and sometimes n

Reported by: Timo Juhani Lindfors Owned by: Antoine Martin
Priority: critical Milestone: 0.0.7.x
Component: client Version: 0.0.7.30
Keywords: Cc:

Description (last modified by Antoine Martin)

I'm using r259

Steps to reproduce:
1) open gnome-terminal
2) run "cat"
3) press and hold ctrl
4) press and hold N

Expected results:
4) gnome-terminal is filled with

^N^N^N^N^N^N^N^N^N^N^N^N...

Actual results:
4) gnome-terminal has

^Nn^Nn^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N^Nn^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N^N...

More info:
1) xev also shows that ctrl is released and pressed multiple times even though I never release the physical key.

Change History (5)

comment:1 Changed 9 years ago by Antoine Martin

Status: newaccepted

This is caused by #21 (sigh)

The problem is that the jitter compensation code fires too easily, causing ctrl to be released when it should not be.
Is this on a slow line? Jitter? Were there many screen updates at the time?

comment:2 Changed 9 years ago by Antoine Martin

Description: modified (diff)

comment:3 Changed 9 years ago by Timo Juhani Lindfors

No this is a very fast 10/10 VDSL2 link.

comment:4 Changed 9 years ago by Antoine Martin

Resolution: fixed
Status: acceptedclosed

Should be fixed by r263: jitter compensation was too trigger-happy

Please re-open if necessary.

comment:5 Changed 9 years ago by Antoine Martin

Milestone: 0.0.7.x
Version: 0.0.7.30
Note: See TracTickets for help on using tickets.