xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#348 closed defect (fixed)

Unable to attach if SSH handshake or entering password takes > ~8 seconds.

Reported by: onlyjob Owned by: Antoine Martin
Priority: major Milestone:
Component: android Version: 0.9.x
Keywords: Cc:

Description

0.9.4 is unable to attach to session if SSH handshake or entering password takes longer than ~8 seconds.

Perhaps 8 seconds is too short for (establishing) connection timeout while there shall be no timeout for password prompt.

See more

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=710868
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=710866

Change History (7)

comment:1 Changed 7 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

(taken from the bug linked above)

To simulate SSH that takes a while to connect, create a file named "slowssh.bash" with the following contents and make it executable:

#!/bin/bash
sleep 15
exec /usr/bin/ssh "$@"

and use this with xpra --ssh=./slowssh.bash ssh:...

comment:2 Changed 7 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

should be fixed in r3561 - will backport to v0.9.x

comment:3 Changed 7 years ago by Antoine Martin

in v0.9.x as of r3591

comment:4 Changed 6 years ago by Timo Juhani Lindfors

Resolution: fixed
Status: closedreopened

This still occurs with 0.9.6+dfsg-1:

oregano:~$ xpra attach --ssh ./slowssh.bash ssh:lindi1:7
xpra client version 0.9.6
2013-07-17 06:26:04,694 connection closed after 0 packets received (0 bytes) and 1 packets sent (8264 bytes)
2013-07-17 06:26:04,696 Connection lost

comment:5 Changed 6 years ago by Timo Juhani Lindfors

Resolution: fixed
Status: reopenedclosed

Or hmm, ignore the previous comment, this must be a new bug that doesn't occur exactly in the same way, sorry for the noise...

comment:6 Changed 6 years ago by Antoine Martin

FWIW: just tested again, and this works fine with both trunk and the v0.9.x branch.

BTW, you can ensure your server is running the latest version with:

xpra version ssh:lindi1:7

comment:7 Changed 6 years ago by Timo Juhani Lindfors

It is, the bug of course occured only on unreliable 3G connection and I can't reproduce it with the slowssh.bash now when I'm at office.

Note: See TracTickets for help on using tickets.