xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 6 years ago

#351 closed defect (fixed)

--use-display seems to be broken

Reported by: ahuillet Owned by: ahuillet
Priority: major Milestone:
Component: android Version:
Keywords: Cc:

Description

Using --use-display produces the following error message:

Traceback (most recent call last):
  File "./scripts/xpra", line 6, in <module>
    sys.exit(xpra.scripts.main.main(__file__, sys.argv))
  File "/mnt/data/src/xpra/src/build/lib.linux-x86_64-2.7/xpra/scripts/main.py", line 433, in main
    return run_server(parser, options, mode, script_file, args)
  File "/mnt/data/src/xpra/src/build/lib.linux-x86_64-2.7/xpra/scripts/server.py", line 459, in run_server
    xvfb_pid = get_pid()
  File "/mnt/data/src/xpra/src/build/lib.linux-x86_64-2.7/xpra/scripts/server.py", line 96, in get_pid
    from xpra.x11.gtk_x11.prop import prop_get
  File "/mnt/data/src/xpra/src/build/lib.linux-x86_64-2.7/xpra/x11/gtk_x11/prop.py", line 27, in <module>
    X11Window = X11WindowBindings()
  File "core_bindings.pyx", line 60, in xpra.x11.bindings.core_bindings.X11CoreBindings.__cinit__ (xpra/x11/bindings/core_bindings.c:791)
AssertionError: display is not set!

Change History (2)

comment:1 Changed 7 years ago by Antoine Martin

Owner: changed from Antoine Martin to ahuillet

should be fixed in r3587, works for me - but then again I didn't notice it was broken before.

Please close if fixed.

comment:2 Changed 6 years ago by ahuillet

Resolution: fixed
Status: newclosed

Confirmed fixed.

Note: See TracTickets for help on using tickets.